[GUIDE] error 12/43 & other detection, bootup, stability & performance issues
 
Notifications
Clear all

[GUIDE] error 12/43 & other detection, bootup, stability & performance issues  

 of  73
  RSS

Martín Pérez Alfonso
(@martin_perez_alfonso)
New Member
Joined: 11 months ago
 

hi everyone. a couple weeks ago I started using a nvdivia geforce gt 710 gpu with a egpu adapter that uses the express card port of my x220, I connect the gpu to a monitor I have through a vga cable, and at first it worked smoothly. about last week or so I started having a couple crashes. they only appeared occasionaly, and it could be fixed with just a windows restart, but now my computer doesn't work for more than 30 minutes without crashing.

sometimes it shows a blue screen of death, and sometimes the monitor stops showing image, and only the x220 screen works, ocassionaly it shows the error from the first photo of the album, which I'll link at the end of the post. also, sometimes, windows would show me an error (from which I haven't been able to take a photo of) that says:

"La instrucción 0x00*** referencia de memoria 0x00***. La memoria no pudo ser read"

I have my windows in spanish so I guess this translates to this error:

"The instruction at 0x00*** referenced memory at 0x00***. The memory could not be read"

the x220 works completely fine without the eGPU. I have made a couple times a fresh install of windows 7, all my drivers are up to date. actually, the latests drivers from nvidia don't even work correctly, the ones that last most without crashing are older drivers, I have a folder with like 10 different versions for the gt 710. I have tried lots of them and most of them work similarly.

I have tried lots of stuff. really. I made sure I had enough vram allocated, I checked the power source for the 710 has enough power, several clean installs of windows 7, updating net. framework, using /sfc scannow, I don't know, I lost the track of everything I've tried to fix this. Does anyone have any ideas? I'm open to anything. if you need more info I will provide it. In any case, I'm just using the computer for lightweight gaming, just playing TF2. Runescape, LoL, Rocket League, stuff like that.

The specs of my computer in case anyone needs it:

Lenovo Thinkpad x220

Intel Core i5-2520m 2.50 GHz

8gb ram

64 bits Windows 7

not sure what else to put here hehe.

https://imgur.com/a/Es4b3BC

 

please help people, I'm desesperate.

thinkpad 220, trying to make it work with a gt 710


ReplyQuote
Alyen
(@alyen)
Active Member
Joined: 12 months ago
 

@martin_perez_alfonso,

s the GPU power supply working properly? I would advise you to give it a try. lowers the resolution lowers the gpu clocks if the pc does not crash then it is the gpu power supply that cannot stably supply your external graphics card.

 

Lenovo Z50-70, I7 4510U 2,6 herz, 16GB DDR3 dual-channel
EXP GDC 8.0 + Nvidia GTX 980 Ti Exstreme external monitor lg full hd


ReplyQuote
Villium Films
(@villium_films)
New Member
Joined: 11 months ago
 

Hi all it seems that my exp gdc is not actually using power from my psu. When I can switch it on even when the laptop is off but that is because is is using power from my laptop battery or charger. It is not using the power from my psu. Therefore creating a lot of problems. Such as being not recognised. 

i5 4310u -gtx 150ti -hd4400 -1tb external hdd -16gb ram -128gb ssd -windows 10


ReplyQuote
travisify
(@travisify)
New Member
Joined: 2 years ago
 

Hi guys, I might need a little bit of your help. Smile I've completed the eGPU setup that I was aiming, with RX 570. The card seems working without any issue, my laptop easily detected it. But I have couple of problems I faced and I couldn't manage to solve them since 2 days.

So the problems are;

1.) Games are stuttering (or fps droping?). I've also used MSI Afterburner to see what's going on, and it seems like GPU Usage drops frequently, especially when I move my mouse to look around in game or change the scene a little bit faster. This unfortunately makes a noticable difference and makes the game kinda unplayable. Plus, I've noticed that desktop is also kinda glitchy/laggy when using, sometimes. Tried on GTA V, GTA IV, BeamNG Drive and Baldi's Basics which can even be run by Intel HD Graphics, and it was probably stuttering on a very very unplayable level when I should have getting around 500 FPS.

2.) I've benchmarked my setup on Unigine Heaven 4.0, and taken around 1700 score, which is 85% of a regular desktop. Result is very satisfying for me. But can't say the same for GTA V for example, when I compared with the one's that run on desktop it was about 55%. Furthermore, I'm currently using an external, Freesync supported monitor. I don't get it. Is it because of some different specs like tesselation or is it because of what this stuttering/fps dropping problem with eGPU? Or is it really because of my CPU, mini PCI Express, HDMI Cable or monitor etc.?

3.) My USB Wifi Adapter seems to loosing connections frequently when I'm using EXP GDC dock. But for now that's not really important problem to solve for me, I'm using an ethernet cable to connect to the network.

so I've put in an order of importance the problems for me from 1 to 3, even if the first issue could be solved I'd be happy enough to go.

My laptop specs are:

     ASUS N56VZ

  • CPU: Intel Core i7-3630QM
  • dGPU: NVIDIA GeForce GT 650M (Disabled)
  • 1TB HDD, 5400 rpm
  • Samsung Evo 860 SSD (240GB)
  • 2 x 8GB DDR3 SDRAM

eGPU Setup:

  • eGPU Dock: EXP GDC Beast v8.5c
  • Video Card: ASUS ROG STRIX RX 570 GAMING OC
  • PSU: High Power 500W 80+ Bronze

External Monitor:

  • ViewSonic VX2457-mhd 24"

What I've done for setup is:

1.) Uninstalled dGPU entirely from laptop by using DDU on safemode,

2.) Disabled the PCI express port that was used by dGPU,

3.) Pluged in EXP GDC to wifi card slot and rebooted laptop,

4.) Installed AMD Drivers for RX 570 as the external GPU appeared on Device Manager.

After the installation AMD setup programme did not ask me to restart my PC, however I've restarted after all of the installation process has been done.

If you have the answers I've been looking for, I'd be really appreciate if any of you can help me out. After all these effort I hope it will pay it's price.

And I'm sorry if I have made grammatical mistakes. English is not my mother tongue. Smile

Hopefully I'll be able to use my eGPU without any issue. I'd like to make a build post of my setup.

This post was modified 11 months ago

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Tamim Mahmud
(@tamim_mahmud)
Active Member
Joined: 1 year ago
 

Installed the driver(442.19) properly with nvidia-error 43-fixer.

Whenever launching in games or 3D apps the processes  called "System Interrupts"  and "Service Host Diagnostic Policy" starts with about 30% of CPU usage. I have disabled the Diagnostic Policy service but now System Interrupts is takin about 25% of CPU. And with that when the processor works at above 95%  sounds become choppy and if something intensive happens in games windows crashes saying dxgkrnl fetal error or nvlddmkmsys . Sometimes the crash occurs for no reason.

One more thing my 1050Ti's base clock 1341Mhz and Boos 1455Mhz. But when running games it shows 1784Mhz in MSI Afterburner. No overclocked done by me. Normally(when not in 3D Apps) the GPU runs at 139Mhz.

Considering my situation any help would be appreciated .

My Notebooks Specs:

Processor: core i-5 6200u

RAM: 8GB DDR4

dGPU:GTX 920m (Disabled)

eGPU: Msi 1050Ti OC 

OS: Windows 10 Pro 64bit (build 18362)

Exp Dock: EXP GDC 8.5 (m.2/ngff version)

ATX 450Watt PSU

ASUS P553UJ - CPU: i56200u . RAM:8GB DDR4-dGPU:GTX 920m-eGPU:GTX 1050Ti -Adapter:EXP GDC 8.5c


ReplyQuote
Viking_Sail
(@viking_sail)
Active Member
Joined: 11 months ago
 

Greetings community. 😀 I've been lurking here for almost a year before I finally decided to give eGPU a go on my old potato Dell laptop through its mini PCIe port (replaces the WiFi card). 

First I'll describe the problem: the laptop refuses to boot up if the eGPU is connected, not even showing BIOS after I press the power button. The fan is spinning, power LED is on. But all I have is a black screen. 🙁 Using the "hotplug" method, I was able to by pass this problem sometimes 😛 (not 100%. sometimes after I plug in the eGPU cable, Device Manager still wouldn't detect the eGPU. In which case I'll have to reboot and try it again)

My setup is as follows:

TLDR: Intel Gen.4 CPU + nVidia dGPU + nVidia eGPU + mini PCIe port + Dell DA-2 "Brick" PSU

  • CPU i7-4510u (4. Gen Haswell with Intel HD 4400)
  • dGPU nVidia GT-750M
  • eGPU nVidia GTX-960
  • the 6 dollar PCIe riser card (PCE164P-N03)
  • Dell DA-2 220W PSU
  • Windows 10 Pro 1909

My "adventure" so far (IT'S FUN! 😎 ):

  1. Rebooted into safe mode and cleaned up the nVidia driver using DDU
  2. Turned laptop off. Connected the assembed eGPU unit to the mini PCIe port (replacing the WiFi card)
  3. Powered on the PSU to turn on the eGPU first
  4. Turn laptop on - the (laptop) fan spins. Laptop power LED is on. But screen is black (not even backlighting). It won't even boot into BIOS Roll (the fan spins initally at a higher RPM. After half a second goes to a lower RPM)
  5. Unplugged the mPCIe cable. Booted up normally. In Device Manager, I noticed one PCIe port is missing under "System Devices" (normally I have 4 PCIe ports #1 #3 #4 #5, now only #1 #4 #5 are showing)
  6. I thought: the mPCIe port might be whitelisted in the BIOS so it refuses unauthorised PCIe devices. So I decided to try the "hotplug" method
  7. Booted up with the original WiFi card. Rechecked Device Manager - 4 PCIe ports all enabled. dGPU disabled (and without driver)
  8. Replaced the WiFi card with the eGPU mPCIe cable. Refreshed Device Manager and it detected "Microsoft Basic Display Adapter"
  9. Installed driver version 368.81 without any problem. eGPU GTX 960 properly detected with error code 14. At the same time, the disabled dGPU also enabled itself automatically with error code 22 (just for reference. i don't plan to use the dGPU)
  10. Now I'm in a dilemma : I have to reboot to use the eGPU. But if I reboot with the cable connected, I get the same blackscreen as in step 5. If I reboot with the WiFi card and try "hotplug", sometimes it works - which means othertimes it doesn't.
  11. After an attempt when "hotplug" finally worked. GPU-Z is showing the eGPU is working at PCI-e Gen. 2 x1 speed. Hooray! 😀 I ran a few stress tests (3DMark, GPU-Z) and demanding games (Kingdom Come: Deliverance, theHunter: Call of the Wild, DiRT Rally). All went smoothly. System was stable with minor framedrops occasionally. 😉 

Possible fixes I can think of:

  • well the easiest and the stupidest one is obviously NOT to fix it aka try "hotplug" until it works. 
  • maybe there's some kind of jumpwire that can be set to let the system detect the WiFi card when booting. And immediately switching to the eGPU after BIOS?
  • I don't think nando's "DIY eGPU Setup 1.35" would work because the laptop won't even boot into BIOS if the eGPU cable is plugged in. From my understanding, the DIY Setup software is something between BIOS and Windows to let Windows detect the eGPU properly. But my problem is before BIOS was loaded up?
  • another "fix" that is hardly a fix is to abandon the current machine and build a new computer instead. But that's unlikely to be involving eGPU. So far this adventure has been fun for me so I'd like to continue... LoL

Any ideas how I can fix the bootup problem? 

i7-4510u (Intel HD 4400) + nVidia GT-750M + nVidia GTX-960 + PCE164P-N03 + Dell DA-2


ReplyQuote
nando4
(@nando4)
Noble Member Admin
Joined: 4 years ago
 

@tamim_mahmud , per opening post and Buyer GuideEXP GDC has can be problematic with a Gen2 link. Your system, being a 6th-gen i-core is probably running a Gen3 link.

Solution to stabilize your link is to either downgrade your link to Gen2/Gen1 using eGPU Setup 1.35 or get a better eGPU adapter capable of running a Gen3 link like a ADT-Link R43S or ADT-Link R53S .

eGPU Setup 1.35    •    eGPU Port Bandwidth Reference Table

 
2015 15" Dell Precision 7510 (Q M1000M) [6th,4C,H] + GTX 1080 Ti @32Gbps-M2 (ADT-Link R43SG) + Win10 1803 // compares M.2 vs TB3 performance inc unoptimized H-CPU BIOS [build link]  


ReplyQuote
Viking_Sail
(@viking_sail)
Active Member
Joined: 11 months ago
 

@kian_moiny, it would be extremely helpful if you can point me to how to disable the dGPU onboard. I seem to be stuck on the same issue. Laptop won't POST if eGPU's cable is connected.

 

i7-4510u (Intel HD 4400) + nVidia GT-750M + nVidia GTX-960 + PCE164P-N03 + Dell DA-2


ReplyQuote
Mikita Karalkou
(@mikita_karalkou)
New Member
Joined: 11 months ago
 

Still not solved 🙁

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
kian moiny
(@kian_moiny)
Trusted Member
Joined: 2 years ago
 

@viking_sail, I can’t help you with that as I don’t have the knowledge, but if you dig around hard enough you just might find your answer.

 

Acer Nitro 5, AMD Radeon RX 470, ADT-Link R43SR, 450W cooler master PSU


ReplyQuote
 of  73