my short egpu "experience" and why I gave up
 
Notifications
Clear all

my short egpu "experience" and why I gave up  

  RSS

Gerson Ya
(@gerson_ya)
New Member
Joined: 3 months ago
 

I'm not posting it to ask for help though I'd not refuse it if somebody knows how to solve it 😉 

 

I'm not here to discuss the setup. I know if it worked it was going to be a huge bottleneck but I didn't have money to spend in a brand new gamer hardware nor in a better (not top) laptop either. Though it was a huge investment (waste?) of money, time, (lack of) skills, energy...

 

My laptop's specs:

CPU: Intel Skylake i7-6500u (yes, it is a U)

IGFX: Intel HD Graphics 520

RAM: 32MB (2x16) 1600MHz (whatever...I just wanted my laptop running at its max)

Storage: 2x1.75TB SSD SATA 3 6Gbps

Wireless card: M.2 NGFF Intel AX200ngw (a brand new card I got and was willing to put on the drawer to use the EXP GDC Beast 8.5c I got later)

 

eGPU items bought:

-EXP GDC Beast 8.5c

-A good mATX computer cabinet (just an option if I decide to get a new hardware in the near future)

-PSU Corsair White 650W

-6x120mm cabinet coolers (3 already came with the cabinet I got - a bit too much just to make sure the gpu would be cool enought without any watercooler)

-GPU: Nvidia GTX 1080 Ti (Gigabyte Gaming OC)

That's it. Definitely it was not cheap (just cheaper than buying a complete and good desktop)

 

The first time I put connected it, got both displays (external on the egpu and the laptop's screen on the igfx).

I don't know why but connecting the external gpu into the M.2 Ngff interface opened the "Advanced" and "Power" tabs in the BIOS (InsydeH20) and made all the motherboard/laptop's uuid and other codes with strange/unrecognizable characters. But it booted.

It was already possible to see everything very slow (even in the grub boot selector - I have dual boot with Linux). But I wouldn't care if I could play some games...

The laptop's keyboard was dead. But who cares? If it would allow me to play some games, I'd just use a usb keyboard!

No touchpad in Windows/Linux. Whatever...I'll use an usb mouse

I was able to install Nvidia's drivers, rebooted and...first problem: Windows automatic repair loop

None of the options worked. Neither my usb windows recovery boot. I had to boot from linux, download a Windows image and install it from "zero" (at least it kept my linux installation alone).

Again...first thing I did was installing the nvidia's driver to check if it was the driver or if it was any conflict with the version of the (many) Windows updates installed (I installed 2004 just before installing egpu).

I did got an automatic repair screen but it the system solved it itself. I checked "error 43" in device manager. Tried some older drivers before looking for something else, gave up and found the nando4 fix in this forum.

Device manager showed me my laptop's keyboard, touchpad and ethernet network adapter with a yellow exclamation mark (error code 10). but I was using usb alternatives...I just wanted to play a little.

Okay, now the driver was nice, resolution at 4k 60Hz on my tv screen (nothing exceptional but good enough for me), while the intel would run in 4k 30Hz at most.

But the system was still super slow.

Task manager and both CPUID Cpu-z and HWMonitor showed my cpu was running at pathetic 399MHz.

So began my 1 week and a half journey trying to solve it...

First, explored almost every (related) possible configuration in bios, except manual OC. Nothing

Then, tried many methods to solve the stuck cpu's clock. Nothing

Tried setFSB but didn't find any PLL code/number on my mobo (I disassembled it all, took pictures of every little part to check it with attention later but no PLL found)

Tried ThrottleStop9.0, unchecking BD PROCHOT, checking/unchecking SpeedStep (in bios too), but multipliers was stuck at 4 (399Mhz). But it did changed the CPU's voltage if I forced it, so I had a little hope that I was missing something.

Tired of trying, I tried a manual OC in the bios, overriding the voltages instead of using "Adaptative" setup and...Nothing.

Oh...I didn't mention, but in Linux, I got 400MHz. Somehow, using cpufreq I was able to change the "current" frequency to 1GHz but I was configuring it to run at 100% (2.6GHz w/o turbo boost...2.9~3.0Ghz w/ turbo boost). So yeah...something was really wrong.

At this point I had connected/disconnected the egpu cable from the m.2 ngff inteface so many times that I noticed that if disconnected, the mobo/system uuid/codes were back to normal and so the bios, with no "advanced" nor "power" tabs anymore, and the keyboard, touchpad and nic were back to life as soon as I disconnected the gpu from the m.2 ngff connector and the cpu's clock normal values (the opposite would occur as soon as I connected it back).

But I am stubborn and wanted to play/pay my investment. Played for one more week with bios, throttlestop and windows registry/configs but...nothing.

 

So I just gave up.

Maybe...next year, when I have some money saved (if everything goes fine), I'll buy desktop components, one by one. Of course the gtx 1080 ti will be older than it is but...it will still be miles and miles ways ahead of the intel hd graphics 520. I think I'll be able to play gta v with it. Maybe I'll wish something better to play the gta6? But whatever...I have nothing else to do.

 

Sorry for making you lose your time, well...if you got until here.

 

Oh...and ThrottleStop worked (until 30x, not 31x as it is said) with the cpu with no egpu. Everything running as fast as it was supposed to, except 3d graphics and rendering stuff.

Just covered my cabinet to avoid dust and that's it.

End of story 😕 

This topic was modified 3 months ago

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
nando4
(@nando4)
Noble Member Admin
Joined: 4 years ago
 

1. Hide the eGPU from the BIOS using the CTD/PTD switch to ensure it initializes devices like keyboard without interference.

2. You might need to boot with wifi, then hotplug the eGPU, to get detection.

This thread is your friend:

https://egpu.io/forums/expresscard-mpcie-m-2-adapters/mpcieecngff-m2-resolving-detection-bootup-and-stability-problems/

eGPU Setup 1.35    •    eGPU Port Bandwidth Reference Table

 
2015 15" Dell Precision 7510 (Q M1000M) [6th,4C,H] + GTX 1080 Ti @32Gbps-M2 (ADT-Link R43SG) + Win10 1803 [build link]  


ReplyQuote
Gerson Ya
(@gerson_ya)
New Member
Joined: 3 months ago
 

@nando4

Thanks again, nando4.

I tried to follow exactly as you said and reconnected my wireless m.2 ngff and booted into Windows. Everything normal.

Unplugged the card and connected the egpu cable, the keyboard, touchpad and lan card stopped working right there but no "code 10" in device manager.

Turned the psu on but the nvidia gpu wasn't detected in device manager BUT...CPU's clocks were normal!

Shutdown.

Changed the jumper position of PDT but the ATX was blocked by the material of the gdc enclosure (plastic). Tried to remove the screws but it was SO tight I think I've stripped the heads of three screws. Then I gave a f**k and "carefully" broke the plastic blocker with another screwdriver and changed the ATX jumper to the ON position. I didn't know what position I had to put the PDT so I changed it from OFF to "75" (there is also "155").

Everything repeated. No gpu detected on device manager. Clocks were still normal.

But now, with the ATX jumper ON, the egpu would keep on even if I turn the laptop off. So I kept the cable connected into the m.2 ngff interface, left the gpu on, shutdown the laptop...wait....turned it on again. Device manager detected both the Intel and Nvidia cards. Clocks were normal!!! F**k it the keyboard/touchpad/LAN card...

Ran Furmark just for a fast test with all the stuff (cpu-z, hwmonitor, throttlestop working!!!)

The video from the egpu was configure as an extension of the igfx but I ran it anyway.

The results were way better than those obtained from the igfx BUT were just half or below half of the tests I had done with the gpu card in a desktop (also had a weak cpu as mine, but the results were much better). NVIDIA Control Panel wouldn't open so I didn't know how to force an application to use the egpu.

I risked to reboot and disable the igfx in bios and...CPU's clocks were normal, throttlestop working and only egpu card detected!

Ran the benchmark again and...YEAH!!! Results practically the same as I'd tested the nvidia in a desktop (the desktop had a PCIe 2.0 x16, while my m.2 ngff pcie is 3.0 x1).

Done some more testing and benchmarks and, at that point, I was afraid to turn everything off and get the problem again.

Shutdown test...I turned on in the wrong sequence (first the laptop, then egpu's psu) and got the problem again.

Turned all off...Turned the psu on, laptop after...Same problem.

Redone the first steps again (hot plug included even though I knew the card wasn't going to be detected but just to make sure it was work as the same otherwise I'd give up).

Okay. Everything's good. Rebooted, deactivated igfx. Everything working as before. Shutdown test again.

FIRST, I turned on the egpu's psu. A little nervous, waited 10s and turned the laptop on....It's working again! Cool  

 

Done all testing...gta v in 4k at maximum was a bit too much (low was fine...didn't test medium) but I was good with 1080p @high/ultra quality (lied...had to lower a little distance draw and another two options that give more work to the cpu) and it is perfect now.

 

Today, after work, tested Linux but still got the limited clocks (@1000MHz as I've written before). Trying to find an alternative to ThrottleStop and found someone saying I could use "RT MSR Tool" in Windows to read the "instructions" that ThrottleStop passes to the cpu's registers and knowing them, I could start to try some commands in Linux. I'll try that on the weekend.

I'm gonna also try to find anything about the "code 10" errors for the HID devices in device manager (oh...they appeared there again even with all working fine).

Anyone think it might be the laptop's psu (the original one is 65W 12V and 3.42A, I think so). There are also 90W ("original") and alternatives with pin-adapters...Found some with 120W, 150W and even 200W< (but for All-in-Ones which uses the same pin size as my laptop). Anyone think it's worth it to try?

 

Well, for now, I'm satisfied. Didn't follow nando4's steps literally but I got a signal of hope (normal clock values) to keep trying. Thanks again, @nando4!

 

Any news...I'll post here. Now, it's time to enjoy it 😉

Sorry for the bad English...

Take care

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

nando4 liked
ReplyQuote
nando4
(@nando4)
Noble Member Admin
Joined: 4 years ago
 

@gerson_ya , consider sharing the good news by completing a build template to submit a build.

eGPU Setup 1.35    •    eGPU Port Bandwidth Reference Table

 
2015 15" Dell Precision 7510 (Q M1000M) [6th,4C,H] + GTX 1080 Ti @32Gbps-M2 (ADT-Link R43SG) + Win10 1803 [build link]  


Gerson Ya liked
ReplyQuote
Gerson Ya
(@gerson_ya)
New Member
Joined: 3 months ago
 

**Update**

Sorry for the big delay but it was for a good reason.

I think it's better not submitting my build and here is why:

Thought it is possible to make egpu works in my hardware, it works perfectly while it's on and sometimes it continues to work perfectly after "short intervals" from shutdown and power on (I didn't measure it; maybe I'll measure someday but I don't think it's relevant since it's not gonna solve anything).

Now, if the system is powered off and keeps like that for "more time", the problem with the cpu clock at 0.39GHz comes back when it is turned on and the solution is basically the same:

-turn off the computer

-disassemble the egpu adapter from the M.2 interface

-turn on the computer

-everything will run smoother again

-assemble the egpu adapter into the M.2 interface

-turn the egpu/psu on

-reboot or power off/on

-Windows will (probably) be normally running and the egpu card will be recognized again (no need to do anything, since the drivers are already installed)

-reboot and enter BIOS/Setup

-deactivate the iGFX/integrated gpu and configure all BIOS settings as you wish, again

-your egpu system will be working perfectly again (Windows)

 

Though it's very simple and easy (now), it's very boring having to follow these steps everytime you have to keep the computer off (power consumption or any other motive). Adapting my laptop's motherboard to the desktop enclosure made things a little simpler. I think it would be even boring if I had to remove the laptop's lower cover everytime (I would need to find a way to keep it removed but still protected from dust and/or short circuit all the time it would be kept in my room).

 

I do it because I wasted a considerable amount($).

For a cheaper setup, I believe few egpu users would be that patient on refollowing the steps over and over.

 

That's what I have to say about my experience so far.

If anyone need some help with this specific laptop (I don't believe though since it's a 2016 model), I can try to help you. Just post here or send me a PM.

 

That's all.

See ya

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote