[Sticky] NVidia is killing off mPCIe/NGFF.M2 eGPUs : error 43 with 372.90 or newer driver  

Page 2 / 2 Prev
  RSS

nando4
Honorable Member
Joined: 3 months  ago
Posts: 404
January 23, 2017 8:06 pm  
Posted by: James2406

 

  • Can confirm gtx 1070 pe4c v3.0 via express card on a Thinkpad W530 i7-3740qm with Intel 4000 and the Nvidia Quadro K2000m works but only with the rollback 372.70 driver. I will look around for the hotplug option or listing in the bios and online. I'll also try to move up drivers one by one to see what happens. I would be up for possibly a hacked/modded bios to get around this issue if possible. 

   

James, the expresscard interface is specced as being hotpluggable. Did you check whether  your eGPU hosting PCIe port (expresscard) is already hotplug enabled like shown on the opening post? Two posts up, @Velitacast managed to use 375.70 on his expresscard equipped HP 8760W.

DIY eGPU Setup 1.35eGPUing since '09


ReplyQuote
L502X
New Member
Joined: 1 month  ago
Posts: 1
January 29, 2017 8:53 am  

So is this driver issue specific to Windows 10? Has anyone tried on Windows 7/8?


ReplyQuote
BeautyRazor
New Member
Joined: 3 weeks  ago
Posts: 4
February 2, 2017 3:26 am  

I cant install driver older than 375.95, because this isn't contains my dev and subsys ids. But newer drivers get error 43. Please help me to install older drivers...


ReplyQuote
nando4
Honorable Member
Joined: 3 months  ago
Posts: 404
February 2, 2017 3:46 am  
Posted by: BeautyRazor

 

I cant install driver older than 375.95, because this isn't contains my dev and subsys ids. But newer drivers get error 43. Please help me to install older drivers...

   

See Plastixx' attempt at adding a new card to be supported by the 372.70 driver at https://egpu.io/forums/pc-setup/i-got-gtx-1050-ti-to-work-with-372-70-sort-of/

DIY eGPU Setup 1.35eGPUing since '09


ReplyQuote
Sirios
Active Member
Joined: 3 weeks  ago
Posts: 12
February 5, 2017 8:05 am  
Posted by: z_y

 

hi,

i have a thinkpad x220 and i am using pe4c v3.0 expresscard with gtx1060.

372.70 working fine with internal LCD over optimus, but newer drivers gives error43.

notebook has modded bios and i activated hotplug enable option on all pci port.

so, i am not sure whether this problem is related with hotplug issue...

 

   

Hey! I have eGPU set-up with x220 too! What OS is installed on your system?

Thanks

X220, IPS, Intel Core i7-2620m, 16 gb, Samsung 840 pro 256 gb, eGPU + EVGA FTW GTX1080.


ReplyQuote
DavidC
New Member
Joined: 2 weeks  ago
Posts: 2
February 18, 2017 7:00 pm  
Posted by: nando4

 

 UPDATE: This problem is specific to the GTX10xx series. GTX9xx and older cards are reportedly not be affected.
Worst are GTX1050 and some new GTX1060 cards that are not supported on the 372.70 downgrade workaround driver solution.

 

Otherwise you can still go with mPCIe/NGFF.M2, but be aware that future games will need new driver capabilities. Likely you've got about 1-2 years of current gaming use then.

 

   

Hi Nando4.  Thanks for the info.  I have been reading up on this for couple weeks now since running into the same problem with a 1060 6G card with a error 43.  So is the conclusion still remains that the 10xx cards (any 10xx card) with mPCIe and non-hotplug setup will only work with 372.70 and older driver?  Mine is working in Wins 8.1 with 372.70 but not newer driver.

I am trying to decide if I should stay with this setup or return the card and get a 980 TI for better future prove.  You mentioned without the capabilities of using new driver, this setup may only be viable for a year or two.  TIA.


ReplyQuote
nando4
Honorable Member
Joined: 3 months  ago
Posts: 404
February 18, 2017 11:22 pm  

DavidC, unfortunately the conclusion remains the same. GTX10xx and drivers 372.90 and thereafter cause error 43 on non-hotpluggable mPCIe/M2 interfaces. GTX9xx and older or AMD cards are the workaround to avoid being stuck on the NVidia 372.70 driver with a GTX10xx card.

Edited: 6 days  ago

DIY eGPU Setup 1.35eGPUing since '09


ReplyQuote
DavidC
New Member
Joined: 2 weeks  ago
Posts: 2
February 19, 2017 7:59 am  

nando4, thanks a lot for the reply.  I guess another option is to mod the hotplug bit in the bios.  I have a Lenovo G510 running Win 8.1.  Do you know if modding the bios is reversible assuming I made a backup prior in case something goes wrong?  I will do more research myself but in general how difficult is it to mod the bios?  Thanks.


ReplyQuote
carage
New Member
Joined: 1 week  ago
Posts: 2
February 19, 2017 9:29 am  

I have a ThinkPad W520 connected to a GTX 1080 via EXP GDC Beast ExpressCard,

375.63 has been great for me, it is even much more reliable than any of the 372 and earlier series.

Things have been great until this morning when I noticed the external monitor no longer has a signal,

as I suspected, Windows 10 decided to sneakily update the driver to 376.53 WHQL in the middle of the night.

I reinstalled 375.70 over it and followed the instructions to turn off automatic driver updates in the control panel,

but a few hours later I found Windows 10 did it again. 

Is there anyway to tell Windows 10 not to mess with a particular set of drivers permanently?

I don't really want to turn off automatic driver updates/installation for all devices as I find the feature to be pretty convenient,

but I also hate to reinstall display drivers every morning when I wake up or come back home after work. 

 

Additionally, my patience is wearing thin on this.  As nVidia is apparently ignoring those of us on "legacy connections",

I might as well get a ThinkPad P50 and join the TB3 crowd or build a desktop and ditch the whole EGPU scene altogether.


nando4 liked
ReplyQuote
Curucail
New Member
Joined: 2 days  ago
Posts: 1
February 23, 2017 12:44 pm  
Posted by: carage

 

I have a ThinkPad W520 connected to a GTX 1080 via EXP GDC Beast ExpressCard,

375.63 has been great for me, it is even much more reliable than any of the 372 and earlier series.

Things have been great until this morning when I noticed the external monitor no longer has a signal,

as I suspected, Windows 10 decided to sneakily update the driver to 376.53 WHQL in the middle of the night.

I reinstalled 375.70 over it and followed the instructions to turn off automatic driver updates in the control panel,

but a few hours later I found Windows 10 did it again. 

Is there anyway to tell Windows 10 not to mess with a particular set of drivers permanently?

I don't really want to turn off automatic driver updates/installation for all devices as I find the feature to be pretty convenient,

but I also hate to reinstall display drivers every morning when I wake up or come back home after work. 

 

Additionally, my patience is wearing thin on this.  As nVidia is apparently ignoring those of us on "legacy connections",

I might as well get a ThinkPad P50 and join the TB3 crowd or build a desktop and ditch the whole EGPU scene altogether.

   

I had the same issue with Win 10 updating the driver all the time (even when i was in a game!)

If you go to your device manager after windows updates to 376 again, you can right-click on your graphics card, go to properties -> driver and then choose the third option (go back/ revert to an old driver). After that windows will revert to your old driver version and wont install it again.


ReplyQuote
Page 2 / 2 Prev

eGPU

10 User(s) Online Join Server
  • Markcus
  • AquaeAtrae
  • CharlieWax
  • Wasabi
  • -2EZ
  • Mikeal
  • navalava
  • A§H»rUnRiÕt
  • jahrudz
  • James2406
  
Working

Please Login or Register