NVidia is killing off mPCIe/NGFF.M2 eGPUs : error 43 with 372.90 or newer driver
 
Notifications
Clear all

NVidia is killing off mPCIe/NGFF.M2 eGPUs : error 43 with 372.90 or newer driver  

 of  30
  RSS

Gonzalo Bulnes Diaz
(@gonzalo_bulnes_diaz)
New Member
Joined: 3 years ago
 

lenovo g400s + gtx 1050 + 385.41 = worked

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Gunther Gasner
(@gunther_gasner)
New Member
Joined: 3 years ago

Ajayajayaj and nando4 liked
ReplyQuote
Volkan Gur
(@volkan_gur)
New Member
Joined: 3 years ago
 

Hello i have  1060 3gb. Im install 368.81 after 

385.41 with no code 43 but i have a new problem direct x error when i check with gpu-z direct compute non tick and when ı try a start game give directx error. when im downgrade 

375.7 or

 370.7 everything worked without problem pls help me sorry for my language

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
favas0
(@favas0)
Eminent Member
Joined: 3 years ago
 

Okay , this is my spec 

laptop : lenovo z410 

Bios : modded (Hotplug Enabled)

Gpu : 1070 8gb

Nvidia Driver Version : 385.41 WHQL

This was possible by 

- If you have any nvidia driver installed use DDU to remove it then start the steps

1) Install Nvidia Driver  368.81

2)Open your registry editor, proceed to HKEY_LOCAL_MACHINE\SOFTWARE and delete nvidia_rebootneeded. (thanks Cacada for this additional step)

3) Install 385.41 Driver (or whatever is the latest) and PhysX! (not clean install!).

4)Reboot your system after install procedure will be done and there will be no error 43, and videocard will work perfectly with 385.41 driver.

Thank you forum

Laptop : Lenovo z410 ( i5-4200m GT740M 12GB 1TB-SSD) running Windows 10 Pro build 14393 // Hot-Plug Enabled BIOS
eGPU : Gigabyte GTX1070@4Gbps-mPCIe2 (EXP GDC 8.4d) + SilverStone sfx-500L PSU


Chartone and nando4 liked
ReplyQuote
favas0
(@favas0)
Eminent Member
Joined: 3 years ago
 
Posted by: favas0

Okay , this is my spec 

laptop : lenovo z410 

Bios : modded (Hotplug Enabled)

Gpu : 1070 8gb

Nvidia Driver Version : 385.41 WHQL

This was possible by 

- If you have any nvidia driver installed use DDU to remove it then start the steps

1) Install Nvidia Driver  368.81

2)Open your registry editor, proceed to HKEY_LOCAL_MACHINE\SOFTWARE and delete nvidia_rebootneeded. (thanks Cacada for this additional step)

3) Install 385.41 Driver (or whatever is the latest) and PhysX! (not clean install!).

4)Reboot your system after install procedure will be done and there will be no error 43, and videocard will work perfectly with 385.41 driver.

Thank you forum

I regret doing this , i had like 6 BSOD with dxgkrnl.sys based error  and i reverted back to 375.76 . Now a little more info about the settings , on both versions i have downclocked my gpu by 10%. The last thing i have to check is changing the speed from gen 2 to gen 1 , which i didnt want to do as it will seriously affect gameplay. Posting this so that others with my config knows what they are getting into.

Laptop : Lenovo z410 ( i5-4200m GT740M 12GB 1TB-SSD) running Windows 10 Pro build 14393 // Hot-Plug Enabled BIOS
eGPU : Gigabyte GTX1070@4Gbps-mPCIe2 (EXP GDC 8.4d) + SilverStone sfx-500L PSU


ReplyQuote
renanrigamonte
(@renanrigamonte)
Active Member
Joined: 3 years ago
 

Hello everyone, I have success intaling GTX 1060 3gb in W10 with no problems, but whem the graphics card is "Forced" to work, the laptop (asus x550c) restart without explication but before this the display turn off and recovery after a few seconds and get the message error "" Display driver stopped working and has recovered ", I`m try to downgrade to W7 trying to fix it without success, I get the same error, I used CCleaner, DDU, Disk Clean still restarting .... and restarting ... and restarting ...

 

Anyone know how to solve this?

Especification> Notebook Asus X550C, Power Suplly CoolerMaster  GX650 80+, GTX 1060 3GB, EGDC Beast PCI-E version.

 
 
UPDATE> 
I have sucess instaling 368.81 before 375.70 at the moment working fine without issues and without  restart
 
DOUBT>
I update or not?
Untitled

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
thegameplayer
(@thegameplayer)
Active Member
Joined: 3 years ago
 
Posted by: favas0
Posted by: favas0

Okay , this is my spec 

laptop : lenovo z410 

Bios : modded (Hotplug Enabled)

Gpu : 1070 8gb

Nvidia Driver Version : 385.41 WHQL

This was possible by 

- If you have any nvidia driver installed use DDU to remove it then start the steps

1) Install Nvidia Driver  368.81

2)Open your registry editor, proceed to HKEY_LOCAL_MACHINE\SOFTWARE and delete nvidia_rebootneeded. (thanks Cacada for this additional step)

3) Install 385.41 Driver (or whatever is the latest) and PhysX! (not clean install!).

4)Reboot your system after install procedure will be done and there will be no error 43, and videocard will work perfectly with 385.41 driver.

Thank you forum

I regret doing this , i had like 6 BSOD with dxgkrnl.sys based error  and i reverted back to 375.76 . Now a little more info about the settings , on both versions i have downclocked my gpu by 10%. The last thing i have to check is changing the speed from gen 2 to gen 1 , which i didnt want to do as it will seriously affect gameplay. Posting this so that others with my config knows what they are getting into.

How much performance loss with gen 1?

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
favas0
(@favas0)
Eminent Member
Joined: 3 years ago
 
Posted by: thegameplayer
Posted by: favas0
Posted by: favas0

Okay , this is my spec 

laptop : lenovo z410 

Bios : modded (Hotplug Enabled)

Gpu : 1070 8gb

Nvidia Driver Version : 385.41 WHQL

This was possible by 

- If you have any nvidia driver installed use DDU to remove it then start the steps

1) Install Nvidia Driver  368.81

2)Open your registry editor, proceed to HKEY_LOCAL_MACHINE\SOFTWARE and delete nvidia_rebootneeded. (thanks Cacada for this additional step)

3) Install 385.41 Driver (or whatever is the latest) and PhysX! (not clean install!).

4)Reboot your system after install procedure will be done and there will be no error 43, and videocard will work perfectly with 385.41 driver.

Thank you forum

I regret doing this , i had like 6 BSOD with dxgkrnl.sys based error  and i reverted back to 375.76 . Now a little more info about the settings , on both versions i have downclocked my gpu by 10%. The last thing i have to check is changing the speed from gen 2 to gen 1 , which i didnt want to do as it will seriously affect gameplay. Posting this so that others with my config knows what they are getting into.

How much performance loss with gen 1?

I didnt check it out as  driver version 375.76 is stable for me with downclocked memory and clock speeds. Currently running with gen 2 speed. Never had a bsod in this version 

Laptop : Lenovo z410 ( i5-4200m GT740M 12GB 1TB-SSD) running Windows 10 Pro build 14393 // Hot-Plug Enabled BIOS
eGPU : Gigabyte GTX1070@4Gbps-mPCIe2 (EXP GDC 8.4d) + SilverStone sfx-500L PSU


ReplyQuote
crema
(@crema)
New Member
Joined: 3 years ago
 

Nice try, did follow  GynTh0rs summary and got Driver 385.41 working . But when i started any game, after a few seconds of play, a BSOD appears with nvlddmkm.sys  error. 

Tried some older NVIDIA drivers, but the only one that works without errors is still 372.70.

Ah and I  always prevent installing driver updates automatically, because windows tries to updates the 372.70 driver  

(see this https://www.howtogeek.com/263851/how-to-prevent-windows-from-automatically-updating-specific-drivers/ , maybe you could add this to your tutorial).

 

Any suggestions?

Like I said, i'm getting the BSOD appears with nvlddmkm.sys Error after a some minutes of playing any GPU intens game. Only 372,70 does work. Maybe I will do a fresh reinstall of Windows to avoid any unknown misconfigurations.

 

 

My Setup:

 

Asus Zenbook UX32: Intel Core I5, 8GB RAM, with hybride Intel and NVIDIA 840m graphics (not using), GTX 1060 3GB eGPU on BEAST EXP GDX Mini-PCIe.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Rizky Ikhsan
(@rizky_ikhsan)
New Member
Joined: 3 years ago
 

Nice solution but I couldn't get my eGPU detected at all.

instead now my 740m getting 43 error and I've uninstalled the driver.

my specs:

cpu : i7 4500u

gpu: 740m

egpu: 1050ti zotac 4g oc

laptop: asus s551lb

*update : i managed to get it all working. the main problem was the ATX switch button that turned off. turned it on and all problem solved along with the solution up there.
the current problem now with the random restart problem that surfaced after using GTX 1050 ti. current suspect is the CPU getting overheat for some reason.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
 of  30