NVidia is killing off mPCIe/NGFF.M2 eGPUs : error 43 with 372.90 or newer driver
 
Notifications

NVidia is killing off mPCIe/NGFF.M2 eGPUs : error 43 with 372.90 or newer driver  

 of  9
  RSS

(@xard_top)
New Member
Joined: 1 year ago
 
Posted by: Ajayajayaj
Posted by: e-raser

Hi there, I have a Nvidia GeForce GTX 1050 Ti and about 1 year ago I managed to make it working in an eGPU setup with Setup 1.3x and Nvidia driver v375.70. This was - in January 2017 - the latest Nvidia driver working.

Now as some games aren´t working - assuming it´s a driver thing, e. g. DirectX 12 etc. - I´m wondering what´s the latest official Nvidia driver working with my hardware? What´s the current broad agreement on this?

Is it "only" v388.13 as @janver_codilan posted here some time ago?

I'm using 385.41 with the trick from  https://egpu.io/forums/expresscard-mpcie-m-2-adapters/FIXED-Nvidia-GTX1050Ti-error-43-on-mPCIe-or-M2-non-hotplug-eGPU-interfaces-applicable-to-GTX10xx/ EDIT: Using 390.65 now with that trick

Works with Zotec Mini 1080 Ti on an MSI GP62mvr
Using  Driver: 390.65
 
Device Manager: 
https://imgur.com/jCG51CW
Card:
https://imgur.com/eJzojUP
Nvidia:
https://imgur.com/aKOj44A

Update: Made it work with all screens Now:
https://imgur.com/yXmE5a8
https://imgur.com/9wL93x4

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
nando4
(@nando4)
Noble Member Admin
Joined: 3 years ago
 
Posted by: Xard TopWorks with Zotec Mini 1080 Ti on an MSI GP62mvr
Using  Driver: 390.65
 
Device Manager: 
https://imgur.com/jCG51CW
Card:
https://imgur.com/eJzojUP
Nvidia:
https://imgur.com/aKOj44A

How about giving your MSI GP62mvr some representation by submitting a build guide for it?

eGPU Setup 1.35    •    eGPU Port Bandwidth Reference Table

2015 15" Dell Precision 7510 (6th,4C,H) + GTX 1080 Ti @32Gbps-M2 (ADT-Link R43SG) + Win10 // compares M.2 vs TB3 performance


ReplyQuote
(@xard_top)
New Member
Joined: 1 year ago
 

I'm sorry, I would not be the best for that.

I just followed the steps on the   https://egpu.io/forums/expresscard-mpcie-m-2-adapters/FIXED-Nvidia-GTX1050Ti-error-43-on-mPCIe-or-M2-non-hotplug-eGPU-interfaces-applicable-to-GTX10xx/

And then made sure that the Integrated graphics Driver is the oldest.

Also, newer Nvidia Drivers like the 416.93 did Soft lock the 1080 Ti on the MSI Laptop. So I hade to redo it.

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
 of  9