Notifications
Clear all

[Solved] Random eGPU/driver crash  

 of  2
  RSS

IxAMxR34PER
(@ixamxr34per)
Active Member
Joined: 2 years ago
 

Whenever my eGPU (exp gdc beast is under any kind of workload (like games or just a lot of open programs) it suddenly stops giving a signal while remaining detected in the device manager in a result to this my game would crash. Is there anyone that knows what is causing this to happen and how to fix it?

GPU: GTX 750 ti windforce
Processor: Intel Core i5 2540M
Ram: 8gb ddr3
PSU: EVGA 450BT Bronze
Using the Exp Gdc Beast


ReplyQuote
Nick Vasey
(@nick_vasey)
Eminent Member
Joined: 2 years ago
 

Hi,

I've experienced pretty-much the same manner of problem that you describe (my system reported losing the GPU's driver and/or would crash/blue-screen when under graphical load). It turned out - via my following a process of elimination - that the fault lay with my cheapo, Chinese [500W] PSU, which would hiccup horribly at anything from a few seconds to thirty minutes of being under load i.e. playing a reasonably demanding game. That fact that you're using a PSU from a reputable manufacturer (EVGA, though your model is suspiciously lacking in online reviews) doesn't preclude the possibility that your PSU is at fault too. Is it possible for you to swap-out your PSU for another unit? -- doing-so would tell you whether or not your power supply lies at the root of your problem.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
IxAMxR34PER
(@ixamxr34per)
Active Member
Joined: 2 years ago
 

I already tried using a different powersupply (a seasonic focus plus gold 550w) but then i got code 43 which i fixed somehow (i dont know how) so i dont think the PSU is the problem in this case. Thanks for thinking with me though 😀

GPU: GTX 750 ti windforce
Processor: Intel Core i5 2540M
Ram: 8gb ddr3
PSU: EVGA 450BT Bronze
Using the Exp Gdc Beast


ReplyQuote
Nick Vasey
(@nick_vasey)
Eminent Member
Joined: 2 years ago
 

Hmmmm. No prob, I'll endeavour to help if I'm able.

After you switched to the Seasonic PSU (and fixed the Code 43 error), was your system experiencing the same crashes as before or were they different? If they were different, how so? Also, what is the make and model of your laptop, which version of the Beast and which connection-type (to your laptop) are you using?

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
IxAMxR34PER
(@ixamxr34per)
Active Member
Joined: 2 years ago
 

alright so i dont know what i did differently but it seemed to have improved sort of  by still crashing but now giving a different error in the device manager logs this is the error i get now:

Faulting application name: osu!.exe, version: 1.3.3.7, time stamp: 0x5c10c6cd
Faulting module name: nvoglv32.dll, version: 25.21.14.1735, time stamp: 0x5c0f569e
Exception code: 0xc0000409
Fault offset: 0x00c29bc9
Faulting process ID: 0x2978
Faulting application start time: 0x01d497cffe82ebc4
Faulting application path: C:\Users\Finley\AppData\Local\osu!\osu!.exe
Faulting module path: C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_01c064f3d89f92be\nvoglv32.dll
Report ID: 250b699a-dcfa-4131-844c-762c44f41c53
Faulting package full name:
Faulting package-relative application ID:

I hope that someone here knows what causes this since it seems like a OpenGL crash but i dont know how to fix this. Also this happens on all games not just osu.

also i use a lenovo thinkpad t420 and the version of my exp gdc beast is: V8.0 using a PCI expresscard connection

GPU: GTX 750 ti windforce
Processor: Intel Core i5 2540M
Ram: 8gb ddr3
PSU: EVGA 450BT Bronze
Using the Exp Gdc Beast


ReplyQuote
Nick Vasey
(@nick_vasey)
Eminent Member
Joined: 2 years ago
 

Hi,

Thanks for the info. Your machine and mine (a Lenovo X220 Tablet) have a lot in common. When I was setting up my eGPU, I followed this guide pretty-much verbatim and it worked flawlessly (aside, that is, from the fact that my first PSU was on its way out and causing crashes). Perhaps if you follow the linked, step-by-step guide then your problems too will be resolved. Good luck!

PS   Oh, and if your T420 has a dedicated GPU (something like an Nvidia 4200M), then I believe you'll need to disable it in the BIOS.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
IxAMxR34PER
(@ixamxr34per)
Active Member
Joined: 2 years ago
 

I dont know why but i cant see my old reply to yours so here it is again just in case.

OH MY GOD YOU ARE A SAINT. 

All i needed to do was switch the pci speed thingy to generation 1 and it was fixed and its still working.

I hope that this thread can help some other people out that are having the same issue.

GPU: GTX 750 ti windforce
Processor: Intel Core i5 2540M
Ram: 8gb ddr3
PSU: EVGA 450BT Bronze
Using the Exp Gdc Beast


ReplyQuote
epac
 epac
(@epac)
New Member
Joined: 9 months ago
 

@ixamxr34per

I'm about to try this myself, as I'm having a similar problem. But I got really curious why it works with gen 1 and not latter, because shouldt that just limit the bandwith? Did you experience increased bottlenecking?

Well I guess a stable setup is better in any case though.

Asus K95VM - GDC EXP BEAST - GTX 970


ReplyQuote
Laiton
(@laiton)
Active Member
Joined: 2 years ago
 

Hello guys.
I have similar problems:
1) random crash and blue screen while the pc is not doing anything.
2) when I change the graphic settings of the game on the second screen (where the game is started) becomes black / white and then the pc crashes.

Spoiler
3 Blue Screen Error

how can I see what generation it is? how can i change the generation?

thank you

PS:

I want to add more information:
- the cooling fans of the video card are not always active. (when I turn on the video card they start, but after a few seconds they stop | rarely they start again for a few seconds and then they stop).
- EXP GDC / ATX PW: ON
- EXP GDC / PTD: 15s

This post was modified 5 months ago

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Laiton
(@laiton)
Active Member
Joined: 2 years ago
 
Posted by: @laiton

Hello guys.
I have similar problems:
1) random crash and blue screen while the pc is not doing anything.
2) when I change the graphic settings of the game on the second screen (where the game is started) becomes black / white and then the pc crashes.

Spoiler
3 Blue Screen Error

how can I see what generation it is? how can i change the generation?

thank you

PS:

I want to add more information:
- the cooling fans of the video card are not always active. (when I turn on the video card they start, but after a few seconds they stop | rarely they start again for a few seconds and then they stop).
- EXP GDC / ATX PW: ON
- EXP GDC / PTD: 15s

i bought a new power atx and maybe the gpu works better. But I always have the video_tdr_failure error that crashes my pc !!!

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
 of  2