Notifications
Clear all

[SCRIPT] nvidia-error43-fixer  

 of  6
  RSS

Ken Davis
(@ken_davis)
New Member
Joined: 11 months ago
 

I have a windows 10 Pro PC Desktop with the NVIDIA GeForce GTX 1660 card installed.  I will never know what kept causing the Device Driver Error code 43 from happening as it happened after 2 fresh installations and after 2 restore point rollbacks....and it happened after things worked fine for 1-2 weeks each time ...but then the error code 43 disabled the NVIDIA driver.  I used DDU numerous times and reinstalled everything using GeForce Experience and direct download method from NVIDIA website...but nothing worked to get rid of this error code 43 the final time it occurred and I was petrified I would have to do another fresh reinstall on Win 10 Pro or try a restore point...but knew both were doomed because this surely would come back again.  Then...lo and behold...Go sent me to my angel Nando4 by having his FIX IT page show up in a Google search...and the Nando4 Script for Error Coe 43 kept me out of the Crypt.  Everyone should follow all that Nando4 does post, as he surely knows the most.  The bottom line is there is a problem with NVIDIA GeForce GTX 1660 and its current drivers with either Win 10 Pro and its most current update...or...with some unknown application(s) that are installed.  Honestly, I'll never know the cause but I do know the fix and that fix is known as Nando4 for sure!!!

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

nando4 liked
ReplyQuote
Monzer
(@monzer)
New Member
Joined: 9 months ago
 

Hello everyone , I'm new here an I'm wondering what are the steps to use the script should I uninstall drivers first using u then install them an use the script afterwards ? 

I have dell alienware m17xr4 with GTX 680m I took it to couple of technician they told me the gpu is dead ( error code 43 ) although it was working great a while ago !!  

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
edu2046
(@edu2046)
New Member
Joined: 8 months ago
 

Thank you very much, got a GT1030 working with mPCIe in a 15-p087sa laptop.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

nando4 liked
ReplyQuote
skc
 skc
(@skc)
New Member
Joined: 8 months ago
 

@nando4, after previous version can't work on my eGPU with GTX 1060, despite all the hassle of DDU that none work, your fixer is amazing and it work, simple and straight forward, my country card not supported to donate to you, anyway, big thanks, now can play shadow of tomb raider 😊

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

nando4 liked
ReplyQuote
comp_soc
(@comp_soc)
New Member
Joined: 1 year ago
 

It really work on my RTX 3080 + ADT-Link R43S +window 10 !!!

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

nando4 liked
ReplyQuote
Meheret Tesfaye
(@meheret_tesfaye)
New Member
Joined: 5 months ago
 

Hey @nando4, Great Job  Smile  It works on EVGA Geforce  GTX 1080  FTW.

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Mike Harp
(@mike_harp)
New Member
Joined: 5 months ago
 

This worked perfectly for me. I have a T430 with a 1030 egpu using express card and after about an hour of searching this fixed it in around 10 seconds 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
illuminism
(@illuminism)
New Member
Joined: 1 month ago
 

I have a Toshiba Satellite P875 using the mPCIe slot with the EXP GDC beast adapter and an Nvidia 'Colorful'(Chinese brand) GTX 1060 3gb GPU.
Had a weird screen issue when drivers finished installing, like the monitor showed the background has the Toshiba startup splash screen, and then two identical mini screens overlayed in the left and right corner.
Device manager showed code 43, looked up a fix and found this thread.
The script fixed my problem completely! Tested my setup on the game 'Desync' and Furmark (got a score of 4030).
I sent some coffee money, thanks Nando!

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
SALIM F
(@salim_f)
New Member
Joined: 2 weeks ago
 

THANKS LoL

Worked perfectly. I tested with EXP GDC  mPCIe, on the GTX 1060 3GB!

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
 of  6