eGPU.io Community
HELP!! Macbook 13' + Omen Accelerator not being detected at all
 

HELP!! Macbook 13' + Omen Accelerator not being detected at all  

  RSS

sanslash85
(@sanslash85)
New Member
Joined: 4 months ago
 

Hello friends! I recently got my hands on an eGPU (Omen Accelerator) with a GTX 1070 founders gpu. I have macOS High sierra 10.13.5.

When I plug in my eGPU the GPU fan spins, and the red light on the mobo lights up and that is it. I have bootcamp installed and that doesn't detect anything also. I tried installing drivers on bootcamp but can't do a firmware update on the eGPU because it doesn't recognize it.

On the flip side, macOS doesn't detect anything and says there is no thunderport hardware found. I tried installing new drivers for thunderport but says the newest ones are installed.

 

Things i have tried:
Disabled csrutil in boot recovery.

Install omen accelerator drivers on bootcamp (Omen accelerator app doesn't even open...)

Check device manager to see if anything is plugged in...(nothing is detected)

The gpu is 100% working, I tested it

 

The only thing that happens when i plug in my TB3 cable is it starts charging my laptop. That is all. Please help! I'm running out of ideas. Thanks

 

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote