After MacOS Catalina latest upgrade in June now my MBP 2019 13” wont recognize m...
 
Notifications
Clear all

After MacOS Catalina latest upgrade in June now my MBP 2019 13” wont recognize my Blackmagic PRO Vega eGPU  

  RSS

liadb
(@liadb)
New Member
Joined: 4 months ago
 

I’ve been to the Genius Bar at Apple, no help. Since BMagic has discontinued this Pro Vega eGPU, they aren’t sure if it will be addressed in Big Sur.  The eGPU works with the following exceptions; MBP doesn’t recognize the eGPU in app/utilities or menu bar, and it won’t drive my LG 5k ultrafine, which I now run from a TB port in the laptop.  It runs time machine backups and powers all other peripherals.  BlackMagic has sent an RMA, but I know the problem is with the latest version of MacOS Catalina in May/June 2020. Any suggestions for a moderately ignorant household IT manager?

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
mac_editor
(@mac_editor)
Famed Member Moderator
Joined: 4 years ago
 

@liadb, Consider trying NVRAM and SMC resets. Beyond that, retry installing macOS on top of your existing macOS install (no data loss). If GPU still does not work, it could possibly be an issue with the Vega card. While the eGPU is connected, what do you see in About This Mac > System Report > PCI section?

 

purge-wranglertbt-flashpurge-nvdaset-eGPU
Insights Into macOS Video Editing Performance

Master Threads:
2014 15-inch MacBook Pro 750M
2018 15-inch MacBook Pro

 
2019 13" MacBook Pro [8th,4C,U] + RX Vega 64 @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.14.6 & Win10 [build link]  


ReplyQuote
liadb
(@liadb)
New Member
Joined: 4 months ago
 

@mac_editor

pci1b73, 1100 usbextensible host controller installed - yes - slot tb@9,0,0

pci8086,150, 1100 usbextensible host controller installed - yes - slot tb@70,0,0

for the pci1b73,1100 it has more info below The table;

 

type USB eXtensible host Controller

driver installed yes

tunnel and pause compatibile - yes

msi - yes, same tb slot as above, vendor, device, subsystem vendor ID, subsystem ID, revision ID, Link width - x1, Link speed 5.0 GT/s

 

 

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote