Error 173 with Windows BootCamp on iMac 2017 and Radeon RX 5700 XT
 
Notifications
Clear all

Error 173 with Windows BootCamp on iMac 2017 and Radeon RX 5700 XT  

  RSS

InvisibleOs
(@invisibleos)
New Member
Joined: 1 year ago
 

Setup:

iMac 2017  5K 27 Inch and I am using it with the Sapphire Nitro+ RX 5700 Radeon XT as eGPU (Razer Core X). I installed Windows via BootCamp.

------

Hello everybody,

Unfortunately, I still get Error 173 (hardware not recognised) when installing the AMD Drivers . The Windows drivers recognize the Radeon Pro 570, which is installed in the iMac , but the Sapphire is shown as "Microsoft Basic Display Adapter" in device manager with a yellow exclamation mark.

The fans of the eGPU do work, though, when it is plugged in.

I did try using Windows 1903 instead of the newest Version.

Does it have to do something with the fact that the Razer Core X is plugged into the iMac and that there is no external display? Should I maybe try connecting the graphics card via Displayport to an external display?

 

Thanks for Your help!

Oskar

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Topic Tags
mac_editor
(@mac_editor)
Famed Member Moderator
Joined: 5 years ago
 

@invisibleos, DDU all drivers and get bootcampdrivers.

 

"Desultory reading is delightful, but to be beneficial, our reading must be carefully directed." — Seneca

Author: kryptonitepurge-wranglertbt-flashpurge-nvdaset-eGPU
Insights Into macOS Video Editing Performance
Launching Apps on Specific (e)GPUs on macOS
Definitive macOS Thunderbolt eGFX Compatibility Registry

Master Threads:
2014 15-inch MacBook Pro 750M
2018 15-inch MacBook Pro

 
2019 13" MacBook Pro [8th,4C,U] + RX Vega 64 @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.14.6 & Win10 [build link]  


ReplyQuote
InvisibleOs
(@invisibleos)
New Member
Joined: 1 year ago
 

@mac_editor, I deleted BootCamp Partition and reset it, installing the old Windows 1903 version as You describe in Your 8-Step guide here on the forum. That should have deleted all drivers, shouldn‘t it? I did try with the AMD drivers then before trying to download the latest BootCamp driver. Do You think, that makes a difference? 

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote