How to fix screen flickering on LG 5K Ultrafine display UPDATED  

  RSS

Eightarmedpet
(@eightarmedpet)
Noble Member
Joined: 2 years ago
Posts: 1134
April 12, 2018 10:41 am  

Bit of an edge case here, so not sure how many are effected, might link this thread in my sig for visibility.

For those who are unaware, the LG 5K Displays have a habit of flickering from picture to black screen in W10. For me it only happens on Desktop, so not while in game, so was only a minor annoyance, however I accidentally found the fix...

Switch to best performance as per these instructions...

"Adjust your visual effects settings under Start > type performance > Adjust the appearance and performance of Windows > Adjust for best performance > Apply > OK. Head to the Advanced tab of the same window and ensure that Adjust the best performance of: is set to Programs as well."

edit: spoke too soon, appears to still have issues when playing youtube videos.

edit 2: I’ve done some more poking about and i may have found a proper fix - by setting Nvidia 3D settings to always prefer the 1070 - as suspected it was the intel igpu that was causing the issue as it was driving the external screen and the 1070 only kicked in when gaming. 

2017 13" MacBook Pro Touchbar + [email protected] (AKiTiO Thunder3) + Win10
2017 13" MacBook Pro Touch Bar + [email protected] (Sonnet Breakaway Box) + Win10

2017 13" MacBook Pro Touch Bar + GTX1070 (debating 2070 upgrade) @32Gbps-TB3 (Razer Core V1) + Win10

2017 13" MacBook Pro Touch Bar + Vega 56 @32Gbps-TB3 (Razer Core V1) + Win10 & macOS 10.14+

---
LG 5K Ultrafine flickering issue fix


ReplyQuote
theitsage
(@itsage)
Famed Member Admin
Joined: 2 years ago
Posts: 3243
April 12, 2018 12:45 pm  

@eightarmedpet Have you installed the latest Intel graphics drivers manually? There are more Energy settings which allows further tuning of the iGPU power consumption. On the 15" MBP, I need to disable the dGPU and attach the Intel iGPU to the internal display. When not connected to a power source, I would experience flickering. This was resolved when I turned off some power saving settings using Intel Graphics Control Panel.

Best ultrabooks for eGPU use

eGPU enclosure buying guide

86 external GPU build guides


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member
Joined: 2 years ago
Posts: 1134

ReplyQuote
SE12897
(@se12897)
Trusted Member
Joined: 2 years ago
Posts: 56
May 6, 2018 1:09 pm  
Posted by: theitsage

@eightarmedpet Have you installed the latest Intel graphics drivers manually? There are more Energy settings which allows further tuning of the iGPU power consumption. On the 15" MBP, I need to disable the dGPU and attach the Intel iGPU to the internal display. When not connected to a power source, I would experience flickering. This was resolved when I turned off some power saving settings using Intel Graphics Control Panel.

maybe this is the panel self refresh power saving feature you are experiencing? I noticed this on my HP and it caused my to think my trackpad was lagging when in fact it was the display slowing down the refresh rate and causing this slight flickering

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member
Joined: 2 years ago
Posts: 1134

ReplyQuote
mac_editor
(@mac_editor)
Noble Member Moderator
Joined: 2 years ago
Posts: 1600
September 9, 2018 4:28 pm  

@eightarmedpet Clear all cookies, caches, etc. for egpu.io - this fixed it for me.

purge-wrangler.shpurge-nvda.shset-eGPU.sh
----
Troubleshooting eGPUs on macOS
Command Line Swiss Knife
----
Multiple Build Guides


ReplyQuote
theitsage
(@itsage)
Famed Member Admin
Joined: 2 years ago
Posts: 3243
September 9, 2018 4:53 pm  

@eightarmedpet Regarding the 400 errors, I've experienced this issue too. It's likely a bug following the forum software update on Friday. We're contacting the developer to remedy this bug.

Best ultrabooks for eGPU use

eGPU enclosure buying guide

86 external GPU build guides


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member
Joined: 2 years ago
Posts: 1134

ReplyQuote
joevt
(@joevt3)
Reputable Member
Joined: 1 year ago
Posts: 283
September 12, 2018 2:06 pm  

I had the problem with 400 errors. Deleting cookies for the egpu website in Safari worked for me.

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote