Enclosure & Hardware Discussions
Mac Pro - Sapphire RX 570 - poor performance
 

[Solved] Mac Pro - Sapphire RX 570 - poor performance  

  RSS

wood_e
(@wood_e)
New Member
Joined: 7 months ago
 

Mods please move if there's a more appropriate area for Mac OS GPU issues.

I bought this RX 570 card off Amazon. It works in Mojave but the performance isn't great at all...
Luxmark: 13636
Heaven 1920x1080, ultra quality, extreme tessellation, 8xAA: 840

Notably, Heaven reports the GPU as Radeon RX 570 (256MB) x1 - system profiler reports as 4096MB

I'm thinking maybe there's a kext file i need to edit. 

This topic was modified 7 months ago

Mac Pro 5,1
32GB RAM
Xeon 3.2 Quad core
Sapphire RX 570 4GB
Mojave


ReplyQuote
itsage
(@itsage)
Famed Member Admin
Joined: 3 years ago
 

The compute performance in Luxmark looks good. We need more information on your system and connection to determine what Unigine Heaven is doing.

Best ultrabooks for eGPU use

eGPU enclosure buying guide


ReplyQuote
wood_e
(@wood_e)
New Member
Joined: 7 months ago
 

Info from System Profiler

https://imgur.com/a/PlE4SsK

Mac Pro 5,1
32GB RAM
Xeon 3.2 Quad core
Sapphire RX 570 4GB
Mojave


ReplyQuote
itsage
(@itsage)
Famed Member Admin
Joined: 3 years ago
 

Everything is working like it’s supposed to. Heaven score is comparable to other RX 570 scores with that settings in macOS. It’s lower compared to Windows but that’s not an issue with the card.

Best ultrabooks for eGPU use

eGPU enclosure buying guide


ReplyQuote
wood_e
(@wood_e)
New Member
Joined: 7 months ago
 

fair enough - thanks!

Mac Pro 5,1
32GB RAM
Xeon 3.2 Quad core
Sapphire RX 570 4GB
Mojave


ReplyQuote