Enclosure & Hardware Discussions
Mac Pro - Sapphire RX 570 - poor perform...
 

[Solved] Mac Pro - Sapphire RX 570 - poor performance  

  RSS

wood_e
(@wood_e)
New Member
Joined: 4 months ago
Posts: 3
Feb 24, 2019 2:30 pm  

Mods please move if there's a more appropriate area for Mac OS GPU issues.

I bought this RX 570 card off Amazon. It works in Mojave but the performance isn't great at all...
Luxmark: 13636
Heaven 1920x1080, ultra quality, extreme tessellation, 8xAA: 840

Notably, Heaven reports the GPU as Radeon RX 570 (256MB) x1 - system profiler reports as 4096MB

I'm thinking maybe there's a kext file i need to edit. 

This topic was modified 4 months ago

Mac Pro 5,1
32GB RAM
Xeon 3.2 Quad core
Sapphire RX 570 4GB
Mojave


ReplyQuote
theitsage
(@itsage)
Famed Member Admin
Joined: 3 years ago
Posts: 4016
Feb 24, 2019 2:37 pm  

The compute performance in Luxmark looks good. We need more information on your system and connection to determine what Unigine Heaven is doing.

Best ultrabooks for eGPU use

eGPU enclosure buying guide

94 external GPU build guides


ReplyQuote
wood_e
(@wood_e)
New Member
Joined: 4 months ago
Posts: 3
Feb 24, 2019 3:14 pm  

Info from System Profiler

https://imgur.com/a/PlE4SsK

Mac Pro 5,1
32GB RAM
Xeon 3.2 Quad core
Sapphire RX 570 4GB
Mojave


ReplyQuote
theitsage
(@itsage)
Famed Member Admin
Joined: 3 years ago
Posts: 4016
Feb 24, 2019 3:31 pm  

Everything is working like it's supposed to. Heaven score is comparable to other RX 570 scores with that settings in macOS. It's lower compared to Windows but that's not an issue with the card.

Best ultrabooks for eGPU use

eGPU enclosure buying guide

94 external GPU build guides


ReplyQuote
wood_e
(@wood_e)
New Member
Joined: 4 months ago
Posts: 3
Feb 24, 2019 4:24 pm  

fair enough - thanks!

Mac Pro 5,1
32GB RAM
Xeon 3.2 Quad core
Sapphire RX 570 4GB
Mojave


ReplyQuote