Notifications
Clear all

Need help with new setup  

 of  2
  RSS

mikethesith200
(@mikethesith200)
Active Member
Joined: 2 years ago
 

Howdy. I am new to all of this as previously mentioned in my first post. I was hoping to get some feedback on an issue I'm having. My setup..

Samsung Notebook 9 Pro 13 (2019)
i7 8565u, 16GB RAM,
512gb NVME SSD  and 2 TB3 4 lane
Aorus RTX2070 Gaming Box with included TB3 cable

This laptop is brand new so there isn't really any support for it . I recieved the egpu the other day and installation was super smooth. Powering the laptop from the gaming box and mouse and keyboard plugged in as well. 

I am not seeing anywhere near the perfomance I expected. With PUBG for example, on both internal and external monitors there are massive frame drops  1080p high to ultra runs great on my GTX 970M, but on the 2070 egpu im going from 60 down to 15 fps randomly. I have tried all kinds of settings and it still happens. When i have it set to 1080p ultra. I will get 60 when there is nothing going on, but the image doesn't look anywhere near as good as my 970m. It is unplayable with the random frame drops  This happens on high settings, even with 720p. I haven't tried any other demanding titles yet. Battlefield 4 and Borderlands 2 are locked at 60 and look great, but those are older games. Also Aorus Gaming Engine will NOT open no matter what I try. 

Any advice would be greatly appreciated. 

This topic was modified 2 years ago

Samsung Notebook 9 Pro 13 (2019)
Aorus RTX2070 Gaming Box


ReplyQuote
Gareth Rees
(@gareth_rees)
Eminent Member
Joined: 2 years ago
 

what are you getting with AIDA64/CUDA benchmark to measure the data transfer?

Dell Latitude 5491 14" BIOS 1.12.1 + Active PCH cooling | Core i7 8850H + liquid metal - https://valid.x86.fr/z6xi8n | 32GB DDR4 2400 | Samsung 500GB 850 EVO | MX130 + liquid metal | Logitech Z-2300 | Razer Death Adder Elite | Corsair K70 Rapdifire | R43SG v1.2 + RX 570 4GB


ReplyQuote
mikethesith200
(@mikethesith200)
Active Member
Joined: 2 years ago
 

Haven't used those before , I think I did it right. 

CUDA-Z Report
=============
Version: 0.10.251 32 bit http://cuda-z.sf.net/
OS Version: Windows AMD64 6.2.9200
Driver Version: 416.34
Driver Dll Version: 10.0 (25.21.14.1634)
Runtime Dll Version: 6.50

Core Information
----------------
Name: GeForce RTX 2070
Compute Capability: 7.5
Clock Rate: 1620 MHz
PCI Location: 0:58:0
Multiprocessors: 36
Threads Per Multiproc.: 1024
Warp Size: 32
Regs Per Block: 65536
Threads Per Block: 1024
Threads Dimensions: 1024 x 1024 x 64
Grid Dimensions: 2147483647 x 65535 x 65535
Watchdog Enabled: Yes
Integrated GPU: No
Concurrent Kernels: Yes
Compute Mode: Default
Stream Priorities: Yes

Memory Information
------------------
Total Global: 4096 MiB
Bus Width: 256 bits
Clock Rate: 7001 MHz
Error Correction: No
L2 Cache Size: 48 KiB
Shared Per Block: 48 KiB
Pitch: 2048 MiB
Total Constant: 64 KiB
Texture Alignment: 512 B
Texture 1D Size: 131072
Texture 2D Size: 131072 x 65536
Texture 3D Size: 16384 x 16384 x 16384
GPU Overlap: Yes
Map Host Memory: Yes
Unified Addressing: No
Async Engine: No

Performance Information
-----------------------
Memory Copy
Host Pinned to Device: 1132.79 MiB/s
Host Pageable to Device: 1072.11 MiB/s
Device to Host Pinned: 2559.89 MiB/s
Device to Host Pageable: 2109.6 MiB/s
Device to Device: 162.598 GiB/s
GPU Core Performance
Single-precision Float: 8309.21 Gflop/s
Double-precision Float: 269.485 Gflop/s
64-bit Integer: 2042.03 Giop/s
32-bit Integer: 8174.7 Giop/s
24-bit Integer: 7643.67 Giop/s

Generated: Fri Apr 26 16:45:34 2019

AIDA64 CPU

Samsung Notebook 9 Pro 13 (2019)
Aorus RTX2070 Gaming Box


ReplyQuote
Gareth Rees
(@gareth_rees)
Eminent Member
Joined: 2 years ago
 

Looks like your laptop has 2 thunderbolt connections running 2 lanes each. Usually stuttering is the result of a discrete GPU still being enabled that is the device host for the TB3 such as a 1060/1050 Ti/MX130/MX150 etc. All yours has is the highest end intel iGPU (UHD620/630 same GPU).

Try this firmware:

https://www.gigabyte.com/Graphics-Card/GV-N2070IXEB-8GC#support-dl-firmware

Default
H2D
zip
2.60 MB
2019/01/24
 
Thunderbolt firmware Improve Host to Device bandwidth version.

 

If that fails try disabling the TB3 port that isn't in use, but it's likely hardwired for 2-lanes each port.

This post was modified 2 years ago

Dell Latitude 5491 14" BIOS 1.12.1 + Active PCH cooling | Core i7 8850H + liquid metal - https://valid.x86.fr/z6xi8n | 32GB DDR4 2400 | Samsung 500GB 850 EVO | MX130 + liquid metal | Logitech Z-2300 | Razer Death Adder Elite | Corsair K70 Rapdifire | R43SG v1.2 + RX 570 4GB


ReplyQuote
mikethesith200
(@mikethesith200)
Active Member
Joined: 2 years ago
 

Thanks for the reply! How can you tell it's 2 lane TB3? Everything pointed to it being 4 lane. I guess I need to return the laptop then. Which really sucks. I will try the firmware. Thank you.

Samsung Notebook 9 Pro 13 (2019)
Aorus RTX2070 Gaming Box


ReplyQuote
Gareth Rees
(@gareth_rees)
Eminent Member
Joined: 2 years ago
 

You might need to do more than that,

Youre effectively getting 9.496 (Gbps) out of a potential 22 which is the maximum IIRC, you likely have one thunderbolt controller diverting into 2 ports. You need a way to kill bandwidth to the other port or maybe it's the firmware. I'm so tired at this point I can't think lol.

Edit- it does have 4-lane PCI-E, however your config is like this:

PCI Express Configurations 1x4, 2x2, 1x2+2x1 and 4x1

4x PCI-E direct through your CPU, 4x PCI-E for the NVMe SSD. Followed other small lanes for misc devices/ports. The MacBook Pro is the ultimate setup since it has the 8850 with a 24  (never mind it uses the HM370 which is 16 lanes too) lane setup and 2 TB3 controllers vs. 16 of your 8565U. This is why I think your ports are diverting traffic.

This post was modified 2 years ago

Dell Latitude 5491 14" BIOS 1.12.1 + Active PCH cooling | Core i7 8850H + liquid metal - https://valid.x86.fr/z6xi8n | 32GB DDR4 2400 | Samsung 500GB 850 EVO | MX130 + liquid metal | Logitech Z-2300 | Razer Death Adder Elite | Corsair K70 Rapdifire | R43SG v1.2 + RX 570 4GB


itsage liked
ReplyQuote
mikethesith200
(@mikethesith200)
Active Member
Joined: 2 years ago
 

I used HWINFO to check.

HWINFO2
HWINFO1
HWINFO2

Samsung Notebook 9 Pro 13 (2019)
Aorus RTX2070 Gaming Box


blawlog liked
ReplyQuote
Gareth Rees
(@gareth_rees)
Eminent Member
Joined: 2 years ago
 

You should have no issues then with the H2D firmware, that's definitely 4x

Dell Latitude 5491 14" BIOS 1.12.1 + Active PCH cooling | Core i7 8850H + liquid metal - https://valid.x86.fr/z6xi8n | 32GB DDR4 2400 | Samsung 500GB 850 EVO | MX130 + liquid metal | Logitech Z-2300 | Razer Death Adder Elite | Corsair K70 Rapdifire | R43SG v1.2 + RX 570 4GB


ReplyQuote
mikethesith200
(@mikethesith200)
Active Member
Joined: 2 years ago
 

Thank god! And thank you!

Samsung Notebook 9 Pro 13 (2019)
Aorus RTX2070 Gaming Box


ReplyQuote
Gareth Rees
(@gareth_rees)
Eminent Member
Joined: 2 years ago
 

My advice is to get throttlestop now and undervolt your CPU as much as possible to maintain good  clocks as that 2070 is very high end

Dell Latitude 5491 14" BIOS 1.12.1 + Active PCH cooling | Core i7 8850H + liquid metal - https://valid.x86.fr/z6xi8n | 32GB DDR4 2400 | Samsung 500GB 850 EVO | MX130 + liquid metal | Logitech Z-2300 | Razer Death Adder Elite | Corsair K70 Rapdifire | R43SG v1.2 + RX 570 4GB


ReplyQuote
 of  2