2011 15" (Dell XPS 15 L502x) Lenovo ThinkPad T530i/Dell E6320 + R9270X@4Gbps-mPCIe2 ( EXP GDC v8.4d) + Win10 [wimpzilla]^ //eGPU Accelerated Internal Display  

 

wimpzilla
(@wimpzilla)
Reputable Member
Joined:1 year  ago
Posts: 333
March 3, 2017 2:01 am  

Hello,

Here the complete “how to” to troubleshot your AMD card, i tested everything with a R9 270 and a EXP GDC v8.4d, so you need to check things yourself if using a R9 3XX series or last AMD RX series. Please ready carefully till the end!

SETUP:

  • Dell XPS 15 L502x@bios and ME firmware mod, allowing me to change the basic advanced options and to overclock a bit the CPU/RAM through Intel XTU.
  • EXP GDC Beast v8.4d mpci-e 1x@2.0.
  • AMD R9 270 2GB@stock UEFI bios TDP 115/130Watt. Once modded stable 1200/1500Mhz@1.25v for 6600pts on Firestike on my desktop, equal to a stock 1050Ti!
  • LiteOn PE-5221 220Watt 12v@14A.
  • Genuine Dell 130Watt power brick.
  • 60/100Ohm resistor to build your own dummy display.
  • Windows 10 fully updated, AMD Crimson 16.11.5 Hotfix.

 

  1. Starting point: Understand your setup, understand what you need to do to achieve your main goal, to get the eGPU installed on your laptop. So to do that, you need first to check if your laptop have only an iGPU like the HDXXXX or have both, an iGPU HDXXXX and a dGPU like a GTX525m. The main issue is to allow the laptop to correctly allocate the resources for your new eGPU. The eGPU will be more easily allocated if you have only a iGPU less easily if you have both. To help the laptop to does so, you need first to perform a DSDT ovveride as Nando4 guide to allocate more easily the eGPU resources, second you need to disable your dGPU if you have one to allow the DSDT override to fully work, third you need that these two things done before windows boots or before the laptop exits from sleep. So there came the major issues, when you can’t achieve one of these things with the basic guides the Nando4 tool works like a charm to help you.
  2. The setup: Before staring with the DSDT and so on, get a first view of you eGPU setup connected, to check the errors given by window if the card is recognized. The setup is important to get a reliable “how to” to troubleshoot the installation process that came after. So reliable power/laptop connections are important.
  3. The eGPU Installation: So if the card is recognized, some paths open to you, the simplest one, the card will allocate readily after driver installation or the card will give an error12 that can be solved with the DSDT override. The DSDT solve two major issues, the TOLUD issue realed to the maximum amount of ram, the fact that the card stay on error12 without resources. The DSDT override must be loaded on boot depending your boot sequence UEFI/MBR. Also the dGPU must be disabled before windows boot through the bios. If you can’t manage to achieve these things eGPU setup take care of it on boot loading the DSDT override file compiled previously and disable the dGPU before windows boot. If everything went fine you will get your card recognized and installed.
  4. AMD Card Clocks and Internal Display: Since there is no OPTIMUS technology to automatically switch between the iGPU and dGPU on AMD side (XConnect exist and work like OPTIMUS but it is less used), usually the AMD cards required an external display. However you can trick the laptop to accelerate the program on a dummy display and then force it to display it back on you main LCD screen. The AMD card even if installed correctly will not show clocks and sensors in GPU-Z, it need a display input to fully boot up. So if you see your card recognized with genuine default clock but no actual clocks, sensors, it is normal. So here i used a simple resistor to build my dummy display plugged on the back DVI connector of the card.

 




 

1./ For this part just understand how it work, read and ask on the forum before build your eGPU setup, depending witch laptop you own, the pci-e link speed it offer, the right eGPU adapter, the right card! Use the threads that already exist to avoid spamming and ask the same thing infinite times. Then open your thread if you need and begin to build your setup. TL:DR: Get the basic knowledge allowing to work and solve eGPU configuration and installation issues!

 

2./ Here i listed all the steps coming from the long hours of work and testing of the eGPU on the pci-e port, please follow carefully the procedure, PLEASE be gentle and careful when working with your mpci-e slot and hardware parts. TL:DR: The mpci-e need to have something plugged on it on boot, hotplugging the eGPU without nothing plugged on the port on boot do not woked for me!

  • If you didn’t use the EXP GDC USB, unmount it, there is a third jumper on pcb called “Slim Line”, switch it to ultra. Put the PTD switch on 155 and put the power ON switch on ALWAY ON. Remount it!
  • Connect your GPU to the adapter, connect the power supply, i used a molex to feed the card 6pin and the cpu molex for the adapter power, like showed in the manual. Connect your HDMI cable. Leave your PSU off for the moment.
  • (If you had a modded bios, enable the HOTPLUG option and Gen2 options for the port you are using. Disable your dGPU, select the primary display on boot iGPU or PCI/external, disable boot on lan. In few word check your bios if it have basic/advanced option that could help the eGPU to work!)
  • Alway boot your laptop with your WIFI card or any hardware plugged on the laptop mini pci-e. It work on both mpci-e WLAN/WWAN as long you hotplug and replace the WIFI card on the slot by your eGPU. Or just add the eGPU on the other free slot, as long the WIFI card was already plugged on boot on the other slot!
  • Press F12/F8 to pass the bios boot but stop before windows boot. Even with the modded bios there is no way that the eGPU boot along the bios, the best i got is to make the Dell logo appear. Otherwise i got a black screen on boot!
  • NOW with windows halted TURN ON YOUR eGPU POWER SUPPLY, the fans should start to spin slowly, remove the WIFI card and replace it plugging your eGPU. The fans should stop few sec and start again slowlyAt this point continue to boot into windows.
  • Check into the device manager if you have a new hardware, if yes install the AMD drivers, atm i’m using the last revision of the december Crimson, i need to test if the last Relive version work.
  • Once the drivers installed, reboot, unplug your eGPU otherwise the XPS will not pass the bios, then replug the eGPU as described before.
  • Then finally check if the new card is installed without error, if yes get GPU-Z and check if it recognize the bios and the default clock along the other basic information. Only the actual clock and sensors should be missing. At this point plug an external monitor and the card should kick in, heard some sound and the image appear on the external.

=> If the card is not readily allocated giving an error12 or whatever, you need to go further and perform the DSDT override!

 

3./ As i said before about the DSDT, seek some help posting in the right thread. Here i will list the “how to” with eGPU setup, this came after you performed the whole DSDT, loaded it, troubleshooted it and it still don’t work. So at this point eGPU setup give us a hand, loading the DSDT and disbaling the dGPU on boot. TL:DR: Ask Nando4 help and support if you need it.

  • Install eGPU setup to get it on boot along windows.
  • When window ask you what to boot, just move the arrow to stop the countdown, then plug your eGPU as described before.
  • At this point boot into eGPU setup, select eGPU setup menu, you should already see your card detected when loading. If not press F5 unplug you eGPU and plug it again, check if recognized. If yes go in the video card tab, show state check if the bios of the eGPU is read by the motherboard. If it is not read the card will be recognized under windows BUT won’t install and stay under error12.
  • If you created a DSDT file following the Nando4 guide you should be able to load it with eGPU setup. Run a PCI compaction excluding the dGPU, choose the 56.3Gb/36bit PCI allocation like end point, when asked for source select eGPU, when asked what allocate select eGPU. Run the compaction, once done come back to the video card tab and disable the dGPU.
  • Now run startup.bat, check if it is ok and your DSDT file is loaded, then chainload it and boot into windows. Now your eGPU should be fully installed at least without error12 after the driver installation.
  •  Try the command bcdedit -set pciexpress forcedisable too.
  • At this point your eGPU should be finally fully installed without the error12!

 

4./ Here is the “how to” to run your programs from the internal LCD screen. Obviously the performances are poor compared to an external display and scales like thread shows, depending witch resolution you use. This because i got only a 1x@2.0 pci-e bandwidth so only 5Gt/s equal to 500Mb/s. This dummy display trick work only IF your card support analog signals on VGA/DVI/HDMI. You can use adapter to these port to build you dummy display. TL:DR: Check if your AMD card support analog signal (VGA signal) through DVI/HDMI!

  • Get your eGPU fully recognized into windows, with good default clocks, bios readings on GPU-Z but wrong actual clocks, sensors and not working CCC.
  • Boot into win with a 60/100Ohm resistor plugged into the back DVI connector, between the pin C2 and C5. Your VGA must support analog signals on DVI, so on AMD cards before the R290, since i have a DVI-I on my 290! Go in the device manager and check if you got a dummy non-Pnp Display, if not scan for new hardware and make it appear.
  • Install Ultramon, lunch i.e Valley benchmark, select your settings and resolution in window mode. Now click right on Ultramon enable secondary display, click right again set primary display 2.
  • At this point the laptop will switch on display 2, so the trick here is to lunch your programs on this screen, hoping they finish on the other main one windowed. So here i lunch the Valley benchmark on the screen 2 and see the window pop out with the sound on the other screen, don’t see anything there but the Valley launcher on the actual screen2!
  • At this point i use the built in Dell shortcut Fn+F1 to come back to may main screen, i do it two times, the first i got a blank screen due to the fact i switch on external only, the second time it came back to the main LCD with my program running accelerated by the eGPU, YOU WIN, you tricked the laptop to force the eGPU to accelerate and display the program on the built in LCD!!!
  • Simply enabling the screen2 is enough to get the CCC and AMD card clock to boot, so when you enable the screen2 the eGPU fully boot allowing the full control as usual from screen1!

 




 

PICTURES:

  • How to build you DVI dummy display using a resistor on C2/C5 pins of the DVI connector!

 

 

  • The whole setup fit into a 15′ laptop bag, my aim since i started to move, travel, now i can work and play everywhere!

 

 

  • The full setup!



  • Pci-e 2x lane mod, couple of pictures of the flash descriptor mod and pci-e Intel ME mod!

=> It died a couple of hours after, could not go further, from a short on the power button riser bend, that opened. My bad i didn’t care much of how old part were during the test.

 



 

  • Performances: Internal HD8xAA, Internal HD, Internal HD 1378*768, External HD8xAA, External HD  (HD8xAA R9 290@1280/1665Mhz, 2600k@4.7Ghz, 16gb@1866mhz, gives 3400pts on my Desktop)

 




 

  • PURCHASE HISTORY (This project aimed to fulfil low cost/high perfs ratio. Each part are second hand bought)

-Dell XPS15 L502x: 180€ (I was lucky on this one even i was honest with the old owner and said he could sell it more if he wanted. He agreed to make me a gift)

-EXP GDC Beast v8.4d mpci-e: 37€ (New on Aliexpress)

-Asus AMD R9 270 DCUII Oc: 55€

-LiteOn PE-5221 220Watt: 10€ (Here too i was lucky on the price, said the same thing to the owner as before. He said it was ok since he had plenty to sell)

-15′ Laptop Bag very good build quality: 10€

-Nando4 eGPU setup tool: 14€

===> TOTAL SPENT: 306€ Less expensive than a console, 2x more perf!

 




 

  • LINKS

L502x Modded Bios

Download XPS 15 Schematics

Dummy Display Blog

Edited: 10 months  ago

2012 13-inch Dell Latitude E6320 + R9 270X@4Gbps-mPCIe (EXP GDC 8.4) + Win10
E=Mc²


3RYL, survfate, nando4 and 1 people liked
ReplyQuote
wimpzilla
(@wimpzilla)
Reputable Member
Joined:1 year  ago
Posts: 333
March 23, 2017 1:12 pm  

SETUP:

  • Lenovo ThinkPad T530i@BIOS v2.67@ME v8.1.70.1590 Mod@i7 2670QM@FHD LCD@8GB 1600mhzC11@SSD 120GB.
  • EXP GDC Beast v8.4d mpci-e 1x@2.0.
  • AMD R9 270 2GB@stock UEFI bios TDP 115/130Watt. Once modded stable 1200/1500Mhz for 6600pts on Firestike on my desktop, equal to a stock 1050Ti!
  • LiteOn PE-5221 220Watt 12v@14A.
  • Genuine Lenovo 65Watt power brick, genuine Dell 130Watt modded power brick.
  • Windows 10 fully updated, last Relive AMD drivers.

 

“So like always, never work on without knowledge, here you can find the laptop schematics: Here”

 

  • The PCB/Schematics: So Lenovo aka IBM board are a bit more complex even been cheaper than the Dell one, same generation. It should not have any sense, but i feel it less user friendly by the way they build up the pcb. In few word to reduce cost, you cut the price on some component by replacing them by your own custom ones, cheaper. If it is done well it should not be an issue, the issue is mainly adding a lot of custom checks and firmware for these EC, that could sometimes hurt performances.
  • The White List: The T530i have issues with white listening mpci-e ports, i tried to swap my old Dell Intel wifi card, laptop refuse to fully boot, saying wifi not supported, lol ok. I thought it would be enough to use eGPU setup to restore ports, like asked in the previous post. But just by plugging the eGPU is enough crash the laptop causing black, white screen, also the sleep trick do not work. If you boot with the v8.4d always on, PTD 15s/7s/OFF the laptop refuse to boot or loop boot or reboot fine but refuse to recognize the eGPU!
  • The EC WLAN Wiring: I tried also to tape almost all unused pins on the v8.4d connector, same result the laptop crash. The issue came from the PERST pin and the WLAN DISABLE pin, imo, resulting in both white listening the port and crashing the signal on QM77 pci-e lane. If you look the schematics, both WLAN DISABLE are connected to the same EC chip along a signal called GLOBAL WL DISABLE. This EC chips seems take care of starting the white list check sequence and care a signal that shut down completely the wifi detection on pcb level i think, since the UEFI bios does not notice any wifi card, it does not trigger the whitelist or so!

 



 

What you need to know to sort it out:

  1. The pci-e wiring scheme seems to use only the lanes 1-4, the lanes 5-8 are unused. Since the laptop is crowded with a lot of stuff connected, only the WLAN slot use a pci-e lane, the WWAN slot instead relies on a sata pci-e lane. So you must connect your eGPU on the WLAN slot and i can’t anymore have both wifi and eGPU working together like on the old Dell, sigh. On WWAN slot it did not worked in my tests.
  2. You need to disable the GLOBAL WL DISABLE switch, in few word disable the laptop wifi through the switch near the usb ports on the left, otherwise it will not work. On laptops that do not have this switch but have the signal on the EC chip, it could be nice to try emulate the same thing. Since it seems that even taping the pins leaving only the PERST crash anyway the laptop. So disabling completely the internal wifi work as trick, as it is wrote on the EXP GDC manual: Lenovo Z470 If you encounter a black boot, turn off the wireless NIC hard switch.
  3. As always go into the bios, disable all the things you need to disable to accommodate your eGPU to boot. Connect the eGPU to the laptop firmly, connect your external display or dummy display, boot the eGPU power always on, boot the laptop. The laptop should boot, hang on a bit, shut down, reboot fine and pass the bios screen.
  4. Lunch eGPU setup and check if the eGPU is recognized, if yes, do your usual stuff then chainload windows. It could work straight anyway, since there is no dGPU, if the TOLUD is not humongous, it should not need a DSDT.

 



 

  • How it look inside, when i was swapping the CPU. Repasted and remounted, the overall T° are not bad, even better than the XPS15. But running actually with a 65Watt power supply, this could explain the lower cpu-z multi-thread score. I feel the case robust and nice to care with, the Dell was beautiful but more fragile, less bulk/compact inside.

  • The die size difference between an i7 and i3, sort out who is the i7 2670QM and who is the i3 3110M.

  • The stuff connected, i had to hold up the connector firmly on the slot, otherwise had detection issues.

  • The laptop running, in this picture you see only the second screen on the laptop 720p LCD, the main one had valley running, similar trick used with the XPS 15 should apply.

  • The overall performances on the external, same score, more or less, i see a bit smoother game play. Will test further with a clean install, again!

 



 

How to circumvent the cold boot with latest Intel ME firmware and old bios revision like, V2.54, latest v8.1.70.1590 ME, atm i wrote the post, with a EXP GDC v8.4d@R9270!

  • Like i said before, i taped each unused pins of the GDC connector without any further success to boot. Meaning that the used ones were creating the issue. I though only the PERST pin could give an issue since it is the only pin related with the detection/link activation. Atpoint, bored i tried to plug the GDC connector or powering up the eGPU randomly on boot. I managed in a clumsy way to get it recognized another time but was not able to repeat the successful boot operation!
  • I sorted out trying again and again and again, with a shit ton of luck i admit! I was very lucky they pinned the 3.3v on shortest pin of the HDMI connector, dunno if it is a basic specification recommendation. I taped all the unused pins, the renaming ones are the fundamental pins to support pci-e link specifications, but the 3.3v pin. I plugged just a bit the HDMI connector into the GDC when i was trying and got the stuff working surprisingly lol! If the 3.3v, that is wired on the EXP GDC connector and feed the GDC, is cut out, it sort out all the boot issues, the laptop boot right the way with the eGPU connected. This along the WLAN switch disable, didn’t tried with the switch enable. If the overall issue is really related the the WLAN EC chip white list at the end, even i was sure to troubleshoot definitely another kind of issue with the stock ME, more than that it was working before the ME patch!
  • Atpoint if you are absolutely unable to boot and hotplug the eGPU on your T530i, try to tape the pin2 aka the 3.3v_RUN of the GDC mpci-e connector like this, it solved all my cold boot issues! So this laptop could be again included into the green list with this bios/ME config.

 



 

  • Internal screen trick!
    • I tried back to use the internal screen, since the game is fairly light and seems run fine on the external. Keep in mind i disabled my HD3000.
    • To get the internal work you only need a dummy resistor and i think the Fn overlay buttons from Lenovo driver.
    • Just boot your eGPU as usual into windows, plug in your dummy resistor, scan for the dummy screen into the device manager.
    • Switch you display mode into Duplicate Screen using the Fn+F7
    • Lunch your game
    • Alt+Tab, change display mode again Fn+F7 and came back on Secondary Display Only or Extended. The primary should be the dummy display.
    • Came back to your game, adjunct full/windowed screen, in my case under RE7 i can go full screen 1600*1200!

 



 

  • PURCHASE HISTORY (This project aimed to fulfil low cost/high perfs ratio. Each part are second hand bought)

-Lenovo ThinkPad T530i: 100€

-SSD 120GB: 40€

-2x4GB Gskill Ripjaws 1600Mhz@CAS11: 50€

===> TOTAL SPENT: 190€

Edited: 10 months  ago

2012 13-inch Dell Latitude E6320 + R9 270X@4Gbps-mPCIe (EXP GDC 8.4) + Win10
E=Mc²


theitsage and nando4 liked
ReplyQuote
wimpzilla
(@wimpzilla)
Reputable Member
Joined:1 year  ago
Posts: 333
March 23, 2017 1:31 pm  
  • SETUP:
    • Got this Dell e6320 from a thrash can, with broken screen, no audio, no HDD, turbo/cpu/general performances issues. Schematics
    • Got a cheap second hand 1378*766 spare screen form 30 bucks with a couple of dead pixels! Added 8GB of  1333Mhz DDR3!
    • Fixed the cpu/turbo issue, modded ME, modded NVRAM under EFI shell. Updated to bios to the A19 revision, ME to the latest Corporate revision!
    • Full win10 creator updated install@UEFI@Dead 500Go 7200Rpm HDD@last AMD Relive drivers.
    • 130Watt genuine Dell power supply.
    • EXP GDC v8.4d@R9 270@Pin 2 taped(isolated)@mpci-e 1x@Gen 2.0!
    • Completely unmounted/cleaned/repasted, modded some heatsink/thermal pads on VRM!

 

  • DIY mods thoughts:
  1. Even with the ME mod, the laptop refuse to have his BCLK changed!!! Dunno how, but this is the first time i mod the ME, even deeper mod under FITC and still the cpu refuse any overclock. Dunno why, tried a lot, with different XTU versions, again atpoint it goes far beyond my knowledge.
  2. Same thing with the NVRAR setup_var EFI bios settings. I dumped the bios, extracted the IFR.txt file, edited the variable settings checking if the EFI shell returned back decent register values. It was the case, i felt the laptop giving me back the right values for the different variable setting! However even if the changes were saved, i did not noticed any changes/improvement under windows, no TDP/MSR unlock! Again i maybe missed something.
  3. The laptop and logic board are well done/packed, Complal inside, the i5 2520M is soldered to the motherboard, coupled to a QM67 chipset and a 5MB corporate Intel ME. With an extended pci-e config, with 3 mpci-e port allowing the 4x pci-e mod. Most interesting part is the EC build, with two SMSC EC instead of the common ITE one. I only suppose the the whole laptop is controlled by these two chip denying any mod, unfortunately also, the EC mod go beyond my knowledge!
  4. I got no luck solving quickly the audio issue, the IDT audio controller is not detected into the device manager, only a basic HD audio device! I suppose the chip itself or something near by is dead. I tried to disconnect a couple of audio related things, nothing. Reflowed a bit the chip, nothing! The laptop run without any issues but sound! I will not leverage the whole audio diagram wiring part!

 

  • eGPU thoughts:
  1. The EXP GDC mpci-e connector have the pin2 isolated/taped
  2. Booting the laptop with the eGPU and EXP GDC v8.4d already powered ON, PDT 15s do not give back any issue!
  3. The bios setting for the gpu boot is set auto into the bioswith extended options that include PCI/External!
  4. The e6320 switch automatically to the mpci-e eGPU, the built in laptop LCD screen stay dark. The windows boot appear on the external monitor only.
  5. The eGPU is recognized straight into windows, the iGPU HD3000 is automatically disabled and not present into the device manager!!!
  6. Install the AMD drivers, reboot, job done!
  7. The build in LCD screen do not work with an eGPU configuration, in my case!!!!
  8. The laptop is clearly fast and responsive, even with an HDD. Show good perfs under CPU-Z benchmark. Overall the laptop feel solid and perform well!

 

  • Result:

 

  • PURCHASE HISTORY (This project aimed to fulfil low cost/high perfs ratio. Each part are second hand bought)

-13.3 second hand LCD screen 1376*768 30€

===> TOTAL SPENT: 30€

 




 

  • EXP GDC v8.4d Cable wiring

HDMI Connector Pinout

  • Just to clarify, i mapped the cable using the continuity mode of a multi-meter, checking carefully each pin/trace on the mpci-e/HDMI connector.
  • I also checked with the impedance mode, to check if i missed some connection due to internal SMD component present, but not visible to me, not visible with the continuity mode.
  • I got the same result in both cases after checking carefully, you should also recheck, because i didn’t opened the cable to look for inside!
  • BEWARE to asses correctly the pin number on the HDMI connector, you will notice that on the pic there is 2 lines with pin number. The upper one is for the HDMI cable connector view, the line under is for the EXP GDC HDMI connector, since when you look at and pug it it invert the pin number. 
    • BUT, i can’t say for sure this is real pinout, so take it at your own risk. I’m not responsible of anything!

 

 

Thanks for read, remember like i wrote before, this thread have DIY/instructive purposed only, i’m not responsible of anything/anyhow you do on your own hardware!

 

Edited: 10 months  ago

2012 13-inch Dell Latitude E6320 + R9 270X@4Gbps-mPCIe (EXP GDC 8.4) + Win10
E=Mc²


ReplyQuote
Siddarth
(@siddarth)
New Member
Joined:11 months  ago
Posts: 1
March 31, 2017 5:56 pm  

Hi, I have the same model L502x and finding about egpu 5 days ago , I’m thinking of going for it . But I have a doubt reagrding bandwidth since you have 4gbps while another member Himansh whose setup I’m thinking of imitiating since he has Nvidia has 2gbps posted . On which factor does it depends  


ReplyQuote
wimpzilla
(@wimpzilla)
Reputable Member
Joined:1 year  ago
Posts: 333
April 1, 2017 1:20 pm  

Hello,

-The main factor is the ability to get a stable pci-e rev2.0 4Gb/s instead of rev1.0 2Gb/s link. So the L502x have a decent chipset (HM67) and decent wiring on pcb. The EXP GDC v8.4d seems support fine the rev2.0 link, where the cable got an update allowing decent 2.0 link. It was not the case with the previous EXP GDC, where the impedance/EM noise shielding of the cable gave some issues with the link stability, downgrading the speed to rev1.0 so 2Gb/s.

-Reliable speed link is gave by decent laptop pci-e wiring, generally they provide decent 1x 2.0 link and decent eGPU adapter, with low impedance cable, shielded from EM noise. PLZ refer to the nando4 guide on the adapter Here.

-Funny story, to make you understand why the cable is so important, i had my washing machine start running within a couple of meters of the laptop/eGPU. The EM noise generated by the running motor was enough to completely corrupt the image on the external, ending by crashing the link and the laptop. Funny!! ^^

-About the Video Adapter, get something not too old that support the pci-e 2.0. Depend what you want to do, but just with the bios mod removing the TDP lock on the cpu coupled with a GTX960/970 if you like nvdia, is enough to procure you some nice 1080p gaming experience. 🙂

I understand why my second lane solder did not worked straight now!

Edited: 11 months  ago

2012 13-inch Dell Latitude E6320 + R9 270X@4Gbps-mPCIe (EXP GDC 8.4) + Win10
E=Mc²


Siddarth liked
ReplyQuote
inxftw
(@inxftw)
Eminent Member
Joined:7 months  ago
Posts: 23
August 29, 2017 8:57 am  

Hi.

Going to try this anti whitelist trick on my e thinkpad. I was also wondering about your CPU swap.

As 3110m only has 35 watts TDP and mentioned i7 has 45, how are temps? My Chrome temps are 40c-48c. While gaming 55c-59c (Overwatch, Tomb Raider 2013).

Did raising TDP by 10 watts throttle CPU? 

update: Pin 2 and pin 20 are not even connected on my adapter. Tried taping pin 22, laptop booted into windows but egpu wouldn’t be detected even out of sleep.

Edited: 6 months  ago

2012 15" Lenovo ThinkPad Edge E531 GT740M + GTX1060@4Gbps-mPCIe2 (PCE164P-N03) + Win10


ReplyQuote
  
Working

Please Login or Register