2016 17" HP ZBook 17 G3 K3000M + Titan Xp@32Gbps-TB3 (AKITiO Node) + Win 7 [burhop]^  

 

burhop
(@burhop)
New Member
Joined:5 months  ago
Posts: 2
October 5, 2017 3:48 pm  

I’ve got an HP ZBook 17, Akito Node and a NVidia Titan XP.   The HP ZBook also has an NVidia Quadro 3000M

Out of the box,  I get the infamous error 12 for the Titan XP driver.   There is a HACKFLAGS registry setting I found here on the Microsoft that allowed it to load and start working (whoo hoo!)  but only at the cost of breaking:

  1. Second SSD Drive –  There is now a driver error.  Interestingly, the SSD dies when I plug in the TB3 with the Titan.
  2. All USB devices on the TB3 HP doc (video ports and power kept working)
  3. Logitech wireless mouse driver dies.
  4. Fan runs all out all the time.

So, the HACKFLAGS thing, like its name implies is a hack 🙁

I uninstalled all Nvidia drivers and started from scratch.  No change.  All HP drivers were updated too (BIOS, TB3, etc.).  I removed the dock from the equation (no change).

I’m now looking though other posts but no joy.  For those with zbooks following in my footsteps, here are at least a few posts that might help you.  I’m guessing my issue is wit the Titan XP.

switch  has a good post here on his zbook 15

delmar has another post here for his zbook 15

Anyone else have ideas on what to try next or URLs on what to try next?

Edited: 3 months  ago

nando4 and theitsage liked
ReplyQuote
nando4
(@nando4)
Noble Member Admin
Joined:1 year  ago
Posts: 1578
October 6, 2017 2:20 am  

The ZBooks tend to have a BIOS option where you can:

1. enable/disable Nvidia Optimus: the software runs a iGPU+dGPU arrangement, the latter runs just a dGPU arrangement
2. set or unset Thunderbolt security.

@Yukikaze had good on a Zbook G2 by disabling Optimus in the BIOS and just allowing the Nvidia eGPU to use the Quadro drivers. Then could get maximum GPU performance from both. If Optimus is enabled then there is an anomoly with a iGPU+Quadro+Geforce drive conflict where disabling the Quadro allows the Geforce to work.

As for error 12, I found disabling, then enabling the eGPU’s TB PCIe upstream and downstream bridges fixed the problem. Please try this:

eGPU Port Bandwidth Reference TableeGPU Setup 1.35


ReplyQuote
burhop
(@burhop)
New Member
Joined:5 months  ago
Posts: 2
October 16, 2017 4:51 pm  

Thanks, nado4.  I think I have a newer version of the ZBOOK as I don’t have anything that mentions Optimus.  There is a bios graphics options I can set to Hybrid/Auto/Off and I’ve tried all 3 with no change.

On the Device manager, I don’t have anything that says “upstream” or “downstream”.  They all say “PCI standard PCI-to-PCI bridge” under the PCI Express Root ports. I tired disabling various combinations similar to what you showed but still no luck.

I did turn the HACKFLAGs option on and saw that when the card is working, it is at IRQ 17 with 3 PCI standard PCI-to-PCI  bridge” connections and 1 PCI Express Root Port #2 A111.   I tried disabling anything extra in IRQ 17 in the non-working mode but still didn’t have any luck.

 

 


ReplyQuote
Yukikaze
(@yukikaze)
Honorable Member Moderator
Joined:1 year  ago
Posts: 600
October 16, 2017 5:07 pm  

I am currently running a ZBook 15 G4 albeit with Win10 (signature has link for the setup), and for what it is worth, the eGPU was completely painless. You mention a TB3 dock: How are you connecting everything together? The eGPU is behind the dock, or is the dock connected to the second TB3 port? Try to not use the dock temporarily, does it make things better (I run a USB hub for peripherals and use the TB3 only for the eGPU, so that might be a hint).

Any reason why you aren’t upgrading to Win10? It has much better eGPU support.

Edited: 4 months  ago

"Dire Wolf II" - HP ZBook 15 G4: Core i7-7820HQ, 32GB, M1200 dGPU, R9 Fury@32Gbps-TB3 (Mantiz Venus) eGPU, HP Z27q (5K) + Dell P2715Q (4K)
"Timber Wolf" - HP Spectre x360: Core i7-8550U, 16GB, GTX1050Ti@16Gbps-TB3>TB2 (AKiTiO Thunder2), Dell U3011
"Stormcrow" - Lenovo T430s: Core i7-3520M, 8GB, GTX750Ti@10Gbps-TB1 (AKiTiO Thunder2) eGPU, Sony 4K TV
"Phoenix Hawk" - Intel NUC 33217CK: Core i3-3217U, 8GB, GTX670@4Gbps-mPCIe2 (PCE164P-N03) + Linux Mint 18.2 (64-bit)

"Always listen to experts. They'll tell you what can't be done, and why. Then do it."- Robert A. Heinlein, "Time Enough for Love."


ReplyQuote
  
Working

Please Login or Register