2013 14" Alienware 14 GTX765M + GTX970@4Gbps-mPCIe2 (EXP GDC 8.4) + Win10 [Steven_Villain]^  


New Member
Joined:9 months  ago
Posts: 2
August 9, 2017 12:48 pm  
Thanks to Nando's help, finally I got my eGPU work! It is amazing that my Alienware revived like a beast. So I just want to share my experience and hopefully it can help others. 
Here is the basic info of the system I am working on:
iGPU: Intel HD4600
dGPU: GTX 765M
eGPU: GTX 970
Driver version: 384.76
OS: Windows 10
BIOS: Unlocked and PCI-e hot plug enabled
Step 1. Disabled dGPU in Device Manager, put Windows into Sleep mode, turned on eGPU, woke up Windows---> eGPU detected with error 12
Step 2. Disabled PCI Express Root Port where my dGPU lives--> eGPU detected and worked properly.
1. The above method does not always work. Sometimes it will lead to BSOD( IRQL not less or equal ERROR), sometimes it will just freeze Windows without any message. Any idea why is that and how to solve it?
2. If I disable PCI Express Root Port(where my dGPU lives) first, then do the sleep/wake trick, the eGPU detected but with error 43( I tried different drivers, all do the same thing). Any ideas why?
3. If I boot system with eGPU turned on, system will remain black screen. I tried different ways: Delay switch on EXP GDC, Isolate Pin #22. Neither way works. Do you know if there is other way to handle it?
Next step
1. Try change Primary Display to PEG, right now it is set to IGFX
2. Maybe you can suggest 🙂
PS: I am using Internal screen....
Anyway, it worked fine last night. Really enjoyed not only the gaming but also the process of making it work.
Edited: 3 months  ago

theitsage liked
Estimable Member
Joined:1 year  ago
Posts: 152
August 9, 2017 4:39 pm  

@Steven_Villain do not change to PEG or you'll end up with black screen and you'll have to take your laptop apart to remove the CMOS battery (i learned that the hard way trust me).PEG is only present on desktop PC's.Keep IGFX(optimus works at it's best with it).Avoid messing with GRAPHICS OPTIONS if at all possible!!!

Edited: 7 months  ago

ASUS A53SV: i7-2860QM, 16GB DDR3 running WINDOWS 10 Enterprise LTSB 2016
eGPU: EVGA GTX 1080 FTW+ PE4C V3.0(mPCIe)+EVGA 650 G3 PSU (internal display ONLY)

New Member
Joined:4 months  ago
Posts: 1
November 26, 2017 2:08 pm  

Hi Steven, were you able to figure anything out with your issue(s)?  I'm interested in getting an eGPU to work on my alienware 14 as well--there doesn't seem to be any compatible eGPU's available... which eGPU did you use?  Thanks, friend!

New Member
Joined:2 months  ago
Posts: 2
January 9, 2018 4:15 pm  

I'm upping the subject, which type of egpu adapter did you use ?

Edited: 2 months  ago

New Member
Joined:2 months  ago
Posts: 2
February 24, 2018 9:43 pm  

Hey Steven,

I have the exact same configuration as you but I've been struggling for several days. I would really love to have more information about your bios mod and what's your configuration in the setup 1.35


Please Login or Register