late-2016 15" Macbook Pro RP460 + GTX1080Ti-FE@32Gbps-TB3 (AKiTiO Node Pro) + WIN 10 Pro [koorelle]  

 

koorelle
(@koorelle)
New Member
Joined:9 months  ago
Posts: 4
December 21, 2017 4:48 am  

System specs

 

Late-2016 15″ MacBook Pro | i7-6920HQ  | 16GB RAM | 2TB SSD  |  RP460

Windows 10 Pro (64-bit)

OS Build 15063.786

Ver.1703

teamviewer start at login

 

 

eGPU hardware

 

    AKiTiO Node Pro + GTX 1080Ti FE

 

Display HW

 

     Left MBP 15″ x8 pcie type C port + 50cm TB3 type c cable —->  NODE PRO type C port

      LG Ultra Fine 5K + 1m TB3 type c cable ——> NODE PRO another type C  port

       GTX 1080 Ti + DELL 2716D (EDID Emulator) ——- > NODE PRO 4 lane PCI Express 3.0 compliant interface

 

I can confirm success (by click bootcamp volume on Mac Startup Manager then plug in eGpu quickly)

You can get NODE Pro to work at first boot or two it doesn’t matter

When the Window Circle spin to hold it is a good sign for successful activating Nvidia Driver

just wait for it.

 keynote:

you can acquire your self a reboot via disconnect GTX1080 Ti and reconnect it in the devices manager under win 10.

Hardware pictures

IMG 0493

    

Benchmarks

 

2017 12 21
2017 12 20 (7)

2017 12 20
2560 1440 FFXIV
2017 12 20 (8)
2017 12 21 (1)

 

Edited: 2 months  ago

Flint Ironstag, goalque, Linfeng Zhao and 1 people liked
ReplyQuote
(@linfeng_zhao)
New Member
Joined:2 months  ago
Posts: 1
December 23, 2017 11:47 am  

That’s great! I’m planning to buy one.

By the way, do you have any test of using internal display? I have an UltraFine 4K display but sometimes maybe I will just use internal display.

Also,  does Node Pro support macOS? I’d like to use deep learning framework, which is mostly done in macOS.

Thanks a lot 🙂


ReplyQuote
koorelle
(@koorelle)
New Member
Joined:9 months  ago
Posts: 4
December 23, 2017 12:35 pm  

macOS do work as long as you follow in 

csrutil disable / enable procedure

[SCRIPT]

automate-eGPU.sh

macOS eGPU installation tool 

by goalque

 

And something like this.

https://github.com/KhaosT/tb3-enabler

 

chmod +x drag your own tb3-enabler.py

sudo drag your own tb3-enabler.py apply

 

when you complete implementation

then

most important of all

shutdown your mac and disconnect eGPU

1.NML boot into your macOS with nvidia driver enabled

2.log out

3.plug in your eGPU

4.wait

5.when display ready you will know

OR AT THE VERY MOMENT

hot re-plug egpu to initial system failure restart

force mbp to recognize your egpu

6.log in 

7.if something weird teamviewer is your option

 result new by AUTO CPU fan speed

Edited: 2 months  ago

ReplyQuote
NocturnusAnime
(@nocturnusanime)
New Member
Joined:2 months  ago
Posts: 1
December 29, 2017 8:10 pm  

Did you have to do anything before plugging the egpu in such as the efi boot thing or was it straight plug and play into bootcamp? Another question I have is that can you plug anything into the other usb c ports and not cause windows to reboot into Mac? That happens with my Sonnet Breakaway where I can use my egpu (1080ti) plug and play style but as soon as I plug anything else into another port (an external ssd on my Mac or usb hub) windows crashes and reboots into MacOS. My MBP is the same as yours completely up to date. I just intend to use the egpu when I’m on external display as I don’t care about internal display until apple patches that in since the whole efiboot thing can actually void your warranty. I’m only interested in using the egpu for boot camp since I don’t have an external AMD card for MacOS since AMD works better for Macs.


ReplyQuote
Flint Ironstag
(@flint-ironstag)
Estimable Member
Joined:12 months  ago
Posts: 144
December 31, 2017 3:36 pm  

@koorelle thanks for the post.  How’s the noise on this?

MP 6,1 | 4c | d700
MP 6,1 | 6c | d500


ReplyQuote
koorelle
(@koorelle)
New Member
Joined:9 months  ago
Posts: 4
January 1, 2018 8:04 pm  

I use all port of my mbp 2016 

Right Side 4x pcie type c

CASA Hub A01 USB 3.1 Type C 6 port

Akitio Thunderbolt 2 Dock

 

Left Side 8x pcie type c

Akitio Node Pro

CalDigit Thunderbolt Station 3

 

When I want to reboot BootCamp  ( It means the whole system  work before, you got Nvidia driver installed and so on  )

(The recent portable Windows KB4056891 security update 

  It reboot with no action needed )

1. ShutDown MBP

    Disconnect Node Pro

     ( external display was connected to graphic card aka 1080 Ti)

     let the others port on MBP plugged  

     LG Ultra Fine was disconnect from Node Pro at this point

 

2. Hold Alt key to get into Boot Disk Selection  Menu      

      

3.  click BootCamp drive and plugin Node Pro 

       in one sec 

4. if you can see the window circle spin to hold

     it is a good sign for loading Nvidia Driver

5. wait for it 

6.  if nothing happened 

      login teamviewer to check 

 

7…The new approch will be something like ……

( Recommend Use Teamviewer to operate below )

The initial condition in mind     

  1. Boot camp control panel select bootcamp start disk  

   2. Teamviewer work

    3. You can on /off  GTX 1080 Ti  driver in Device manager

     4. You can on / off  Radeon Pro 460 driver in Device manager

     5. In 

          Control Panel \ Hardware and Sound\Power Options\System Settings\

          Change settings that are currently unavailable—–>

     unclick  Turn on fast startup

 

 NOTE    #1 :  recognize  GTX 1080 Ti  first

( LG Ultra Fine unplugged  as mentioned )

                       If GTX 1080 Ti was already work ( which means the external display  plug in 1080Ti work  )

   Click OFF  Radeon Pro 460 driver ONLY

                                                and go to step  #2 B

                          A.   In Device Manager  

                       Click off    GTX 1080 Ti  driver

                      Click off     Radeon Pro 460 driver    

                        Click   ON    GTX 1080 Ti  driver   

( System want  you to reboot  ,      Fine  reboot it   Because yo got good chance       with GTX 1080 Ti  fuctional   as it should be )            

               If  GTX 1080 Driver Not Show up And Nvidia Control Panel Not show up on Desktop

     It will again need to restart from Boot Disk select menu  and plug in Node Pro Again ( In one sec )

        Because Radeon Pro 460 Driver Now is Off you can’t see build in screen and LG Ultra fine which unplugged

 

                             #2 :  recognize LG Ultra Fine later

                       B.   Plug In LG Ultra Fine to Node Pro ( Windows will restart )

                        COn Windows Desk Top  to check Nvidia control panel whether or not show up again

                        D. In Device Manager Click On  Radeon Pro 460 driver  ( LG Utra Fine should work at this point )

                                             

 

 

Edited: 1 month  ago

ReplyQuote
koorelle
(@koorelle)
New Member
Joined:9 months  ago
Posts: 4
January 1, 2018 8:51 pm  

Graphic Card noise it depend

As for the Node Pro because its fans were under the chassis so noise of  

Node Pro

doesn’t really concern me.

 

Edited: 2 months  ago

ReplyQuote
ethanx94
(@ethanx94)
New Member
Joined:1 month  ago
Posts: 4
January 11, 2018 9:39 pm  

I’m having the same reboot issue. According to this guy on YouTube the usb devices need to be plugged in prior to booting. However I don’t have to disable any downstream thunderbolt ports like he did. If I plug in prior to booting it freezes. If I plug in while it’s booted it crashes and reboots.

youtu.be/69p1nlAU5nQ

Edit: Following his video again I was able to make progress.

This time I’m using the lower left TB3 for the Node Pro, while the upper right is going to my monitor which acts as a 4 port USB hub. I have a keyboard, mouse, and SSD plugged in with no issue. If I unplug from my hub there are no reboots.

I had to make sure I disabled two downstream ports in the device manger for this also. (See attached)

I guess they are the ones with no dropdown arrows.

 

Edited: 1 month  ago

ReplyQuote
Eightarmedpet
(@eightarmedpet)
Honorable Member
Joined:1 year  ago
Posts: 489
February 15, 2018 11:20 am  

More pics please! What happens with this set up in macOS? Have you tried to get the 1080 working on the LG 5K?

2017 13" MacBook Pro Touchbar + GTX1060@32Gbps-TB3 (AKiTiO Thunder3) + Win10
2017 13" MacBook Pro Touch Bar + GTX1070@32Gbps-TB3 (Sonnet Breakaway Box) + Win10


ReplyQuote
  
Working

Please Login or Register