mid-2014 15" MacBook Pro GT750M + GTX1050Ti-4GB@16Gbps-TB2 (AKiTiO Thunder2) + macOS10.12&Win7 [Confaderal]^  

 

Confaderal
(@confaderal)
Active Member
Joined:10 months  ago
Posts: 14
May 27, 2017 3:49 pm  

Hi all,

There’s nothing new about my build except that it is on windows 7. But I hope it can help out anyone who is having trouble getting it to work for windows 7(for those who are still on it). Thanks to @Nando4 for also pointing out that the build is unique in the sense that it uses a bios boot instead of the usual UEFI boot users in this thread usually do. Things like LCD brightness control and audio adjustments work with the system.

First of all, I must thank the egpu community here for if it wasn’t for you. I wouldnt know where to begin. The fast responses and the amount of helpers here are immense. I also happen to be a noob in egpu builds so this is my best attempt of explaining. I also went through some other workarounds before I had to use diy egpu setup 1.35, so there might be a combination of things that helped.

Please do give this threads a read. As they are the journey i went through to get this to work. Also shout-out to @mac_editor for giving me a headstart.

https://egpu.io/forums/implementation-guides/late-2013-15-macbook-pro-gt750m-gtx106016gbps-tb2-akitio-thunder2-win10-offline/#post-4966

…And this video.

 

My macbook specs:

Macbook pro retina 15″ Mid 2014 16gb ram gt750m(discrete) with intel iris pro
Running macOS Sierra and Windows 7 Home Edition

 

My egpu items:

– AKiTiO Thunder2 enclosure

-220W Dell DA-2 adapter(modded with a 2.5 barrel and a 6 pin PCIe)

-Zotac GT1050Ti 4gb

 

I am not really script or tech savvy and my reason for staying on windows 7 is because my tb-gigabit ethernet & G-drive mobile tb items work without kinks on windows 7(i tried it on windows 10 but with varied stability).

 

My Processes:

– I started with the most easiest way to start of my building. I followed this video to a tee.

but instead of using an atx psu, I just used modded a Dell Da-2 power supply as I might move to other gpus that need and external source to power it up too besides it being pcie bus powered.

1. I started to install windows 7(again) on my bootcamp. There’s different version drivers for different windows version on different macbooks. Please see this site: https://support.apple.com/en-us/HT205016

I was using a cd, so I had to first make it into an iso for usb(yeah all my stuff happens to be legacy items). Once done, go to bootcamp and make a bootable usb stick and use the bootcamp drivers as recommended by apple support. In bootcamp also installed windows(as per normal).

2. Once on windows, I inserted my tb devices to let it detect and update. I refrained from installing any updates from windows updater. So as not to detect my gt750m. At this point my display was the standard vga one.. I shutdown and boot into windows(my mbpr goes straight into windows) this time with my egpu plugged in from start. After a few tries, I got it to detect my 1050ti, I updated it through device manager. On next boot, it popped up a code 12 error. Somehow windows sucessfully updates itself after trying to block it and the 750m pops up. So now I have 1050ti(code 12) and 750m.

Before you try my method below, at this point perhaps you can do some other workarounds. see this: https://egpu.io/forums/mac-setup/2016-macbook-pro-solving-egpu-error-12-in-windows-10/#post-709

3. Tried everything except 1,2,6,8. So, I Installed DIY egpu setup 1.35 and after some advice, got pass my code 12 through the aforementioned software. My steps are:

  • Plug egpu into MBPr( if it doesnt work, plug into the other tb port and try again)
  • Boot into windows and install the GT750M MBP configuration steps to eGPU Setup 1.35 (nando4 will help you with this;))
  • Restart
  • At Windows boot menu choose DIY egpu setup 1.35 >> DIY eGPU Setup 1.35 -> automated startup via startup.bat (default option 2). 
  • Then on second appearance of Windows boot menu, choose Windows
  • It will boot into windows and both egpus will be detected

 

4. Just go to nvidia control panel> Configure surround, physx> Change to gt1050ti.

Done, you can play titles which used to be non-accessible to you. Enjoy the freedom!:)

 

Edited: 3 months  ago

mid-2014 15" MacBook Pro GT750M 16GB + GTX1050Ti-4GB@16Gbps-TB2 (AKiTiO Thunder2 & Corsair RM650w PSU) + Win7
Working on DIY EGPU Setup 1.35. Nvidia Physx changed to GTX1050Ti.


nando4 liked
ReplyQuote
mac_editor
(@mac_editor)
Honorable Member Moderator
Joined:11 months  ago
Posts: 556

ReplyQuote
  
Working

Please Login or Register