mid-2017 13" Macbook Pro + GTX1080@32Gbps-TB3 (Aorus Gaming Box) + macOS 10.13.2 [ragulka]  

 

ragulka
(@ragulka)
New Member
Joined:2 months  ago
Posts: 4
December 21, 2017 7:09 am  

System specs 

Mid-2017 13″ Macbook Pro running Mac OS High Sierra 10.13.2 

eGPU hardware  

Aorus Gaming Box GTX 1080  

Installation steps (what did you do to get it all going?)

1. Followed the steps on  https://egpu.io/forums/mac-setup/wip-nvidia-egpu-support-for-high-sierra/  

2. Reboot into Recovery Mode and disable SIP, and keep it disabled. Otherwise the external GPU was not recognized.

3. Success:

Comments 

It works when connected before booting up the Mac, external display is 4K @ 60Hz. I can play The Long Dark at 4K with Ultra settings – yay! 🙂

There are some issues I have noticed:

  • Hot unplugging crashes the Mac
  • Clamshell mode does not work – if I close the laptop lid, the internal screen is turned off, but it’s still attached as a desktop – so if you have some apps on your internal screen desktop, they will still stay there, and you can accidentally “lose” your mouse pointer by moving it to the internal screen, which you can’t see anymore. I am wondering if anybody else is also experiencing this and whether this is an issue with AMD cards as well…
  • Putting the Mac to sleep does not put the Aorus Gaming Box to sleep – it just keeps on running and spinning the vents… which is pretty annoying considering that the only way to turn it off is to disconnect the TB3 cable from Mac, which will crash it…
  • When waking the Mac from sleep, the external display is not instantly recognized. I have found that when I press a key to wake the map from sleep, I will have to click Cancel or press Esc and the press any key again – only then is the external display recognized and turned on.
  • After shutting the Mac down and starting it up again, the external display isn’t recognized – I need to unplug the DP cable and plug it back in for it to be recognized.
  • HDMI does not seem to work – the display is kind of recognized, but the screen just stays black
  • Audio over DP to monitor is not supported (I’ve read it works fine on Windows/bootcamp)

If anybody knows a fix for any of the above, I’m all ears 🙂 I’m also interested if these issues happen with AMD cards, or nvidia cards inside other enclosures. 

Edited: 2 months  ago

nando4 liked
ReplyQuote
Eightarmedpet
(@eightarmedpet)
Honorable Member
Joined:1 year  ago
Posts: 489

ReplyQuote
  
Working

Please Login or Register