Troubles with Vive on 2017 MBP 15" [FIXED]  

 
torncanvas
(@torncanvas)
Eminent Member

I successfully got a dual boot setup with macOS 10.13.4 beta and Windows 10 and an Apple eGPU dev kit, but I've had a lot of trouble getting a good configuration for my Vive. For some reason, my headset is not being detected with a 108 error, which is often a USB problem. I'm using an Apple USB C to USB A female adapter and I've tried connecting it to different ports. Are there any other common things I should try?

I also have it working in High Sierra 10.13.4 b1, but performance is terrible in Unity, although I played Blobby Tennis and it seemed fine. Is the issue maybe that Unity is trying to use the built-in AMD card? The level of performance I'm getting would match up with that card. Is there a way to force eGPU usage in Unity?

ReplyQuote
Posted : February 3, 2018 11:13 pm
torncanvas
(@torncanvas)
Eminent Member

Just wanted to follow up to say I have a friend with a Windows laptop who was able to get it working just fine, so my concern is I have a USB 3 chipset issue, but I'm just concluding that because of the 108 error.

ReplyQuote
Posted : February 4, 2018 6:46 pm
torncanvas
(@torncanvas)
Eminent Member

Well I still don't understand what happened, but I redid the entire eGPU TB3 guide to reinstall Windows 10, except I made a couple changes, and now everything works fine. Weird... FWIW one of the changes is to disable the built-in AMD card before installing the AMD drivers for the RX 580. The driver installer would not detect my eGPU to enable installation otherwise.

ReplyQuote
Posted : February 6, 2018 1:17 am
Juan C. Yunis
(@juan_c_yunis)
Estimable Member

@torncanvas yeah, i don't have a vive but if you have a MBP with radeon graphics, it could create conflict with AMD eGPUS, I have to disable mine with the PCI-Express lane too in order to be able to install my VEGA FE. I think this info should be marked as important.

2017 MBP 15″ RP560 + Mantiz Venus + AMD Radeon Pro VEGA Frontier Edition

ReplyQuote
Posted : February 6, 2018 1:21 am