2012 MacBook Pro with Razer core X and amd RX Vega 56
 
Notifications
Clear all

2012 MacBook Pro with Razer core X and amd RX Vega 56  

  RSS

gunnar
(@gunnar)
New Member
Joined: 9 months ago
 

just got my egpu setup yesterday!

my Mac is the mid 2012 model with i7 processor 16gb ram and a 240gb ssd.

i have the Razer core x and a amd Radeon RX Vega 56 sapphire.

the tb3-tb2 adapter and a thunderbolt 2 cable 2.0m. 

I started by following the beginners guide where I was told to disable SIP in step one! Instructions are easy just follow them.

once that was done I opened the terminal to install purge wrangler. Copy and pasted it into the terminal and hit enter! Made it to the purge wrangler menu and hit 1. To setup egpu. During the countdown I plugged in my tb2 cable to my Mac. 

the first time detecting the hardware it didn’t detect properly so I uninstalled and started the process over again. This time it detected the Vega 56 card properly. I then connected my external display and it was black. For some reason I thought purge wrangler ran purge.nvda on its own so I was confused. After sitting and thinking and googling for a while I decided to run purge.nvda. I copied and pasted the script into terminal and hit enter. I then chose option 1, let it complete and I was done. Yay, external display now working! 

tested by loading FF14 which is a pretty heavy graphics usage game and it was much smoother than before. I maxed at 70-90fps and in towns where there were a lot of people it would dip to about 40-50 sometimes thirties. Even in e crowded areas it runs much better than without the egpu. 

I’ll add more detailed notes on what settings I was using and resolution when I get home. All in all I’m pretty happy with how it works. I’m going to run this for a while then see about using boot camp to run Windows to play some other games like valorant etc.

 

Many thanks for providing this solution and making it so simple Smile

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
ozzy
 ozzy
(@ozzy)
Estimable Member
Joined: 4 years ago
 

Congrats! If you do try to use Bootcamp with that Mac and that graphics card it is a bit of a hassle to get working. It definitely works, but you can't use the bootcamp assistant and it is much more involved. You have to manually create and install the bootcamp partition following a bunch of manual steps so that it installs in UEFI mode rather than MBR mode (which is the default for that Mac). This post has links to a bunch of the resources I followed to get this to work for me:

https://egpu.io/forums/mac-setup/automate-egpu-efi-egpu-boot-manager-for-macos-and-windows/paged/68/#post-58874

2012 15" MacBook Pro Retina (GT650M) [3rd,4C,Q] + GTX 1070 @ 10Gbps-TB1>TB3 (AKiTiO Node) + macOS 10.13 & Win10 [build link]  

ReplyQuote
joevt
(@joevt)
Noble Member
Joined: 3 years ago
 

@ozzy, Winclone has an option to convert a Legacy BIOS Windows install to UEFI. I would have a backup copy of the EFI partition contents to make sure it doesn't change anything I don't want it to.

 

Mac mini (2018), Mac Pro (Early 2008), MacBook Pro (Retina, 15-inch, Mid 2015), GA-Z170X-Gaming 7, Sapphire Pulse Radeon RX 580 8GB GDDR5, Sonnet Echo Express III-D, Trebleet Thunderbolt 3 to NVMe M.2 case


ReplyQuote
gunnar
(@gunnar)
New Member
Joined: 9 months ago
 

all,

 

how do I get my Nvidia graphics card back once I've uninstalled purge wrangler and purge.nvda?

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote