Setup & Software Discussions
2016 13" MBP + RX480 + Sonnet III-D + OS X 10.12.2
 

2016 13" MBP + RX480 + Sonnet III-D + OS X 10.12.2  

  RSS

Mark
 Mark
(@mark)
Eminent Member
Joined: 3 years ago
 

Hi everyone,

After getting stupid issues with 4k video on my Titan I decided to try to jump over to AMD and purchased an RX 480.

However, I couldn't get acceleration on the eGPU at all. There's screen output but it was laggy. It's connected to a Dell P2415Q at 4k resolution.

I still have a couple more days to test this before I make the decision whether to return the RX 480.

My Setup is:

2016 MacBook Pro with touchbar

Apple TB3 -> TB2 adapter

Sonnet III-D

MSI RX 480

OS X 10.12.2

 

I used goalque's current automate-egpu script (0.9.9). I have also modified the AMDRadeonX4100 file to include to device ID.

 

I was wondering how people got this to work? Thank you!

2016 13" MBP with Touch Bar
Sonnet III-D modified with Sonnet SE1 TB3 Upgrade Card and 600W PSU
MSI RX Vega 56 Air Boost OC
OS X 10.12.4


ReplyQuote
nando4
(@nando4)
Noble Member Admin
Joined: 3 years ago
 

ikir got his RX480 to work on Jan-5-2017 using a beta automate-eGPU.sh v1.0.0 script. It’s “coming soon”, quoted from his thread at https://egpu.io/forums/mac-setup/macbook-pro-13-2016-touchbar-with-akitio-thunder3-radeon-rx480-work-in-progress/

eGPU Setup 1.35    •    eGPU Port Bandwidth Reference Table


ReplyQuote
Mark
 Mark
(@mark)
Eminent Member
Joined: 3 years ago
 

Oh okay, In that case I probably will return the RX 480 as I don't know when he will release the script.

2016 13" MBP with Touch Bar
Sonnet III-D modified with Sonnet SE1 TB3 Upgrade Card and 600W PSU
MSI RX Vega 56 Air Boost OC
OS X 10.12.4


ReplyQuote
goalque
(@goalque)
Noble Member Admin
Joined: 3 years ago
 

@Mark, script's home at GitHub is the best source of information:

https://github.com/goalque/automate-eGPU/issues/46

automate-eGPU EFIapple_set_os.efi
--
2018 13" MacBook Pro + Radeon [email protected] + Win10 1809


ReplyQuote
ikir
 ikir
(@ikir)
Prominent Member
Joined: 3 years ago
 

Version 1.0 is out!


MacBook Pro 2018 Touch Bar i7 quad-core 2.7Ghz - 16GB RAM - 512GB PCIe SSD
my Mantiz Venus extreme mod with Sapphire Nitro+ RX Vega 64


ReplyQuote
goalque
(@goalque)
Noble Member Admin
Joined: 3 years ago
 

Acceleration works now with the RX 480 but unfortunately Apple's TB3 to TB2 adapter produces blank buttons.

Better get a Node.

resolutions

automate-eGPU EFIapple_set_os.efi
--
2018 13" MacBook Pro + Radeon [email protected] + Win10 1809


ReplyQuote
Mark
 Mark
(@mark)
Eminent Member
Joined: 3 years ago
 
Posted by: goalque

 

Acceleration works now with the RX 480 but unfortunately Apple's TB3 to TB2 adapter produces blank buttons.

Better get a Node.

resolutions

   

I tried out your script and followed the AMD instructions (i.e. ran the script twice and had a USB-C dongle connected to the same side as the eGPU, as well as having -a mode activated). I have also enabled the Baffin script as well. I have not had any issues like this so far, and this seems to have solved the jerky 4k playback problem (which I'm still waiting to hear from itsage if he's had any trouble with his 980Ti+Node). The only thing I miss now is the 40-45% performance cut going from a Titan to an RX480. Someone also reported about FCPX 10.3 crashing, I haven't had a problem like that yet either.

I have already set up a return RMA for this item, and I only have like a week or so to go. My Node is due to come in a month. If itsage has problems playing 4k video with his Node then, as I suspected, it could be a compatibility issue with Nvidia drivers, which are unlikely to be solved seeing as they are not even releasing Pascal drivers.

Anyway, I am using the MSI 8GB one with stock clocks, as well as the MBP with touchbar. I also wonder if having a multi-slot enclosure has something to do with it as well?

EDIT: The new script didn't fix my 4k issue with the Titan, I tried it on straight after the 480. (by uninstalling then reinstalling the script), which didn't really surprise me!

EDIT2: I did NOT use the tb3-enabler script, because I thought that it would be unnecessary as this isn't a TB3 enclosure!

Screen Shot 2017 01 16 at 16.50.36

2016 13" MBP with Touch Bar
Sonnet III-D modified with Sonnet SE1 TB3 Upgrade Card and 600W PSU
MSI RX Vega 56 Air Boost OC
OS X 10.12.4


goalque liked
ReplyQuote
itsage
(@itsage)
Famed Member Admin
Joined: 3 years ago
 

@Mark I tried playing 4K videos this past week but did not get around to post an update. It was dog poo on my Node + 980 Ti using VLC. Tried with both the 13″ and 15″, with and without eGPU. What surprised me is the 15″ with Radeon Pro 450 couldn’t handle playing the 4K videos.

Best ultrabooks for eGPU use

eGPU enclosure buying guide


Mark liked
ReplyQuote
goalque
(@goalque)
Noble Member Admin
Joined: 3 years ago
 

@Mark: Nice to hear that you didn’t see any blank buttons with your RX 480 & 4K monitor.

When you do your 4K tests, uncheck “Displays have separate spaces” in Mission Control and keep all the windows on the eGPU screen.

If doesn’t help, set the internal screen to disabled:

https://github.com/Eun/DisableMonitor

automate-eGPU EFIapple_set_os.efi
--
2018 13" MacBook Pro + Radeon [email protected] + Win10 1809


ReplyQuote
Anchoricex
(@anchoricex)
Trusted Member
Joined: 3 years ago
 

wait no fcpx 10.3 issues with the rx480? This is a new development, no? I'm pretty sure everyone else is having issues with this card and FCPX/iMovie.

 

And yeah it's too bad FCPX isn't optimized for Nvidia cards, I'm probably going to go with the maxed out 15" touchbar so I can have the 4gb AMD card internally for FCPX, but run a Titan externally for everything else (Adobe, Resolve, etc)

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ikir liked
ReplyQuote
Mark
 Mark
(@mark)
Eminent Member
Joined: 3 years ago
 

@itsage Thank you for the update! It's a shame that you are also having issues with 4k playback on both your machines! It's help with my suspicion that Nvidia cards aren't playing too well with either the hardware or Sierra itself!

@goalque Sorry that I forgot to mention that I have done both of those as well with the Titan, and I still had no luck whatsoever.

@Anchoricex I knew people were having problems and I'm actually expecting it to crash at some point because I haven't used it a lot just yet. Conversely, with my 2013 15" + Titan setup I was getting crashes getting Premiere Pro to use the GPU.

2016 13" MBP with Touch Bar
Sonnet III-D modified with Sonnet SE1 TB3 Upgrade Card and 600W PSU
MSI RX Vega 56 Air Boost OC
OS X 10.12.4


ReplyQuote
goalque
(@goalque)
Noble Member Admin
Joined: 3 years ago
 

VLC for Mac supports only H.264 video decoding acceleration:

https://wiki.videolan.org/VLC_GPU_Decoding/

Some samples at 4ksamples.com use H.265 codec. H.264 worked pretty well.

automate-eGPU EFIapple_set_os.efi
--
2018 13" MacBook Pro + Radeon [email protected] + Win10 1809


ReplyQuote