2019 15" MacBook Pro (under macOS) + Razer Core X Chroma + USB Audio card + acti...
 
Notifications
Clear all

2019 15" MacBook Pro (under macOS) + Razer Core X Chroma + USB Audio card + active Speakers ans Subwoofer : NOISE ISSUE  

  RSS

Nadstaky
(@nadstaky)
Eminent Member
Joined: 1 year ago
 

Hello all,

As explained in the title, I have an USB audio card (PreSonus Studio 1810, plugged in the right MBP's side) with active subwoofer and speakers.

 

Since a few days, I noticed some noise when doing nothing with my MBP. Searched where it comes from : the noise is from my Subwoofer 🙁

When I play music, noise is still here.

 

The ONLY way to get rid of this ANNOYING noise is to plug the USB card in one USB port of the Chroma X BUT... Audio stutters when I move mouse, when I type on the keyboard (In Safari for example), or, still with Safari, when I browse web pages and so on...

SO, PLUGGING THE USB CARD IN ONE USB PORT OF THE CHROMA X IS UNUSABLE !!!

What I did :

- Changed the USB cable of the sound card : still noisy

- Plugged the USB Audio card in other Thunderbolt 3 ports : still noisy

- Changed USB adapter : still noisy

- Changed the Thunderbolt 3 cable : still noisy

- Tried with my second Razer X Chroma (for BootCamp, Nvidia card) : still noisy.

 

It used to work fine before (I think... ), and I'm SURE it was OK with my Razer Core X.

 

I need your help you gurus !

 

Thanks,

Eric

 

 

2019 15" MacBook Pro Radeon Pro R560X Core i9 2.3 GHz 16GB RAM
Razer Core X Chroma + AMD RX 5700 XT 50th Anniversary (macOS Catalina)
Razer Core X( v2) + Aorus RTX 2080 Ti (Windows 20 1909)
Dell UltraSharp U3818DW


ReplyQuote
joevt
(@joevt)
Noble Member
Joined: 3 years ago
 

Use a USB hub or dock or Thunderbolt dock?

Mac mini (2018), Mac Pro (Early 2008), MacBook Pro (Retina, 15-inch, Mid 2015), GA-Z170X-Gaming 7, Sapphire Pulse Radeon RX 580 8GB GDDR5, Sonnet Echo Express III-D, Trebleet Thunderbolt 3 to NVMe M.2 case


ReplyQuote
Nadstaky
(@nadstaky)
Eminent Member
Joined: 1 year ago
 

Hello,

I forgot to mention that I did give a try with that : still noise.

 

As soon as I disconnect the external GPU in macOS, the noise stops...

If any of you have ideas, please let me know.

 

2019 15" MacBook Pro Radeon Pro R560X Core i9 2.3 GHz 16GB RAM
Razer Core X Chroma + AMD RX 5700 XT 50th Anniversary (macOS Catalina)
Razer Core X( v2) + Aorus RTX 2080 Ti (Windows 20 1909)
Dell UltraSharp U3818DW


ReplyQuote
JamesDev
(@jamesdev)
Active Member
Joined: 7 months ago
 

Have you resolved it? I got the same issue with external DAC - Focusrite 2i2

My rigs: MacBook Pro 13" 2018 - Razer Core X + Asus STRIX 5700 XT


ReplyQuote
Nadstaky
(@nadstaky)
Eminent Member
Joined: 1 year ago
 

@jamesDev

I have resolved the issue : I have a ground switch on my SubWoofer : I removed ground and now no noise anymore

2019 15" MacBook Pro Radeon Pro R560X Core i9 2.3 GHz 16GB RAM
Razer Core X Chroma + AMD RX 5700 XT 50th Anniversary (macOS Catalina)
Razer Core X( v2) + Aorus RTX 2080 Ti (Windows 20 1909)
Dell UltraSharp U3818DW


ReplyQuote