5700XT + 2017 15 inch Macbook Pro - Issue waking up from sleep (Catalina 10.15.1...
 
Notifications
Clear all

5700XT + 2017 15 inch Macbook Pro - Issue waking up from sleep (Catalina 10.15.1)  

 of  2
  RSS

kizmiaz
(@kizmiaz)
Active Member
Joined: 3 years ago
 

Hey guys,

I recently got myself a Sapphire Nitro+ 5700XT so i could finally upgrade to macOS Catalina (I was previously on High Sierra as I had an Nvidia 1080Ti). The setup was super easy and the 5700XT eGPU was basically plug and play. 

However, I started noticing that when I wake my MacBook from sleep, all my screens remain black but simply start flickering (almost like an infinite cycle of connecting and disconnecting all my displays). None of my displays show the login screen (to log back in after waking up from sleep).

FYI I have 3 external monitors attached to my 5700 XT and my eGPU is connected to the top-left thunderbolt port on my MacBook Pro.

My only solution at the moment:

Disconnecting the eGPU thunderbolt cable from my mac suspends the flickering and allows my MacBook to finally awake from sleep and show the login screen on my MacBook Pro's display. Reconnecting the eGPU after logging in results in all my screens working fine again. This is obviously quite inconvenient, as it also rearranges all my windows (and I usually have quite a few open as I'm a software developer).

I just cannot seem to wake my laptop on from sleep with the eGPU connected.

Does anyone else have this issue? Could it be possible to troubleshoot myself or is this an Apple/AMD problem?

 

Thanks in advance!

 

 

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 4 years ago
 

What type of cables are you using for the external monitor from the eGPU?

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2013 Mac Pro (FP D500 x2) [3rd,12C,E] + RX 5700 XT @ 16Gbps-TB2>TB3 (Mantiz Saturn Pro) + macOS 11 [build link]  


ReplyQuote
mac_editor
(@mac_editor)
Famed Member Moderator
Joined: 4 years ago
 

@kizmiaz

Are you using clamshell mode? There is a bug with Navi eGPUs that I noticed when system is sleeping in clamshell mode - when there's a new notification, external display lights up to show said notification (normal), but does not go back to sleep (stays pitch black, but on with mouse present).

Some troubleshooting steps could be to try resetting NVRAM and SMC, check cable as recommended above, but it sounds like a driver issue (which Apple should clean up - not sure what they are up to in their spaceship these days).

purge-wranglertbt-flashpurge-nvdaset-eGPU
Insights Into macOS Video Editing Performance

Master Threads:
2014 15-inch MacBook Pro 750M
2018 15-inch MacBook Pro

 
2019 13" MacBook Pro [8th,4C,U] + RX Vega 64 @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.14.6 & Win10 [build link]  


ReplyQuote
craftsman
(@craftsman)
Estimable Member
Joined: 1 year ago
 

Can confirm I have the same bug with 5700 XT Anniversary Edition over DisplayPort.

Immediately after you experience this bug can you please send a bug report using Feedback Assistant (find it with Spotlight) and email public-outreach@apple.com about it.

2019 16" MacBook Pro (RP5500M) [9th,8C,H] + RX 5700 XT @ 32Gbps-TB3 (Razer Core X Chroma) + macOS 10.15.1 [build link]  

ReplyQuote
waubers
(@waubers)
New Member
Joined: 2 years ago
 

I have a Gigabyte 5700 XT in a Razer Core X that does the exact same thing.  Trying out disabling turning off displays to see if that prevents the issue.

2018 15" MacBook Pro (RP560X) [8th,6C,H] + RX 5700 XT @ 32Gbps-TB3 (Razer Core X) + macOS 10.15.1 + Win10 [build link]  

ReplyQuote
mac_editor
(@mac_editor)
Famed Member Moderator
Joined: 4 years ago
 

Can confirm that this happened with my setup as well. Still an issue as of macOS 10.15.2 Beta 2.

purge-wranglertbt-flashpurge-nvdaset-eGPU
Insights Into macOS Video Editing Performance

Master Threads:
2014 15-inch MacBook Pro 750M
2018 15-inch MacBook Pro

 
2019 13" MacBook Pro [8th,4C,U] + RX Vega 64 @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.14.6 & Win10 [build link]  


ReplyQuote
Sebastian Krampe
(@megaseppl)
Eminent Member
Joined: 2 years ago
 

I'm using a Mac mini 2018 with 5700 XT in Razer Core X. Always when I try to use sleep, the Mac crashes and restarts. 
It worked (as far as I remember, have only tested once) when there was a screen on the Mac itself, but now (all three screens are connected to the egpu via DP) the Mac tries to sleep, after ~20 seconds the eGPU fans spins loudly and the Mac restarts.

Mac mini 2018 i7, Razer Core X with PowerColor Red Devil 5700 XT


ReplyQuote
Topher
(@topher)
Active Member
Joined: 10 months ago
 

@megaseppl

I had the same problem with my MacBook Pro.  The problem is Catalina, I believe.  The crashing after sleep only happened when I upgraded to Catalina for the sole reason that it supported the 5700 XT.   On Mojave, I used an AMD 580 with the Razer Core X and never once had the problem.  Catalina, unfortunately, is a buggy mess.  I would suggest downgrading to Mojave but then your 5700 XT would no longer work. At least, it didn't for me.  Really sucks.

This post was modified 10 months ago

Lenovo Yoga C940 | Razer Core X | AMD Radeon 5700 XT

 
2019 14" Lenovo Yoga C940 [10th,4C,G] + RX 5700 XT @ 32Gbps-TB3 (Razer Core X) + Win10 1909 [build link]  


ReplyQuote
he lv
(@he_lv)
New Member
Joined: 6 months ago
 

same issue here with 10.15.3!still waiting for apple respond and hoping 10.15.4 will sove

This post was modified 6 months ago

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
hck3
 hck3
(@hck3)
New Member
Joined: 6 months ago
 

Hey everyone, I just wanted to say I have the same problem as Sebastian, I'm using a Mac Mini with a Radeon RX 5700, there is currently no way for me to restart, sleep or shutdown the computer without issues arising where I need to hold the power button down to do a hard shutdown and restart.

I am pretty annoyed as this was I read a recommended graphics card to work.

One other major issue is that I can't disconnect it through the UI, when I try to do this, it says it is disconnecting but then nothing happens.

Really hoping a solution will be around the corner for this, or if anyone has any ideas as to how I can work from day to day with out having to resort to doing hard restarts please let me know!

This post was modified 6 months ago

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
 of  2