5700XT + CORE X Randomly gets Blank Green Screen on External Monitor
 
Notifications
Clear all

5700XT + CORE X Randomly gets Blank Green Screen on External Monitor  

 of  2
  RSS

(@configuration_nine)
New Member
Joined: 2 months ago
 

Anyone experienced this ? Works fine in loopback using macbook display. When i use it with my external display connected via HDMI to a 4k Monitor, it will just turn green sometimes and stay green (much like the BSOD in windows), however I can still hear sound. I usually have to turn off and On my Macbook when this happens, sometimes I can turn off power to the enclosure and my laptop screen recovers. It happens when i open games or programs or even sometimes when im browsing my applications. At my wits end 🙁 All help greatly appreciated.

 

My system:

Powercolor Red Devil RX5700XT

Razer Core X Enclosure

-

2019 Macbook Pro I9 560x Internal Card

Mac OS 10.15.4 Catalina 

Mid 2019 15" Macbook Pro
2.3 GHz 8-Core Intel Core i9
Mac OS 10.15.4
-
Razer Core X
Power Color RX5700XT Red Devil


ReplyQuote
(@configuration_nine)
New Member
Joined: 2 months ago
 

Hi, AN Update : Green is when i use a HDMI Cable, When i use a Displayport cable, same thing, but black screen isntead of Green

Mid 2019 15" Macbook Pro
2.3 GHz 8-Core Intel Core i9
Mac OS 10.15.4
-
Razer Core X
Power Color RX5700XT Red Devil


ReplyQuote
(@malthe_emil_blichfeldt)
Active Member
Joined: 2 years ago
 

@configuration_nine, I have the exact same problem with mine, so im just gonna follow here and try different stuff myself.

I have also tried it in boot camp with windows, and I get the same result with the green screen after just 10-30 sek. of playing a game. HDMI-connection --> green screen and freeze. Have to restart the whole thing. (haven't tried with Display port yet).

Mid 2019 15" Macbook Pro
2.9 GHz 6-Core Intel Core i9
Mac OS 10.15.4
-
Razer Core X
Power Color RX5700XT

 

 

Mid 2019 15" Macbook Pro
2.9 GHz 6-Core Intel Core i9
Mac OS 10.15.4
-
Razer Core X
Power Color RX5700XT


ReplyQuote
(@configuration_nine)
New Member
Joined: 2 months ago
 

Sorry to hear that 🙁 . Mine works absolutely fine in Bootcamp and has been for days, but when i plug it into my macbook in Mac OS it just goes to that black screen. 

Mid 2019 15" Macbook Pro
2.3 GHz 8-Core Intel Core i9
Mac OS 10.15.4
-
Razer Core X
Power Color RX5700XT Red Devil


ReplyQuote
(@malthe_emil_blichfeldt)
Active Member
Joined: 2 years ago
 

@configuration_nine, so i just tested the cable and tried out a DisplayPort cable - i now get the black screen instead of the green, just like you. i have tried overclocking / undervolting the graphics card and changed all the cables, to see if it is some kind of hardware issue, but with no luck so fare... I will let you know, if i figure something out, and i would love to hear from you, if you somehow manage to find the issue Smile

 

 

Mid 2019 15" Macbook Pro
2.9 GHz 6-Core Intel Core i9
Mac OS 10.15.4
-
Razer Core X
Power Color RX5700XT


ReplyQuote
(@alessandro_lusi)
New Member
Joined: 1 month ago
 

Hi guys, any news about the green screen problem? I have the same issue in a MBP 13" 2019 + Razer core x + xfx 5600 xt. During gaming sessions randomly the screen appears green and the mac restart with the fan spinning at max for few seconds. In particular It happens when I start Cod: warzone after the disclaimer of setting the suggested graphic settings. 

Could it caused by driver? I am using April bootcamp driver red edition. 

MBP 15" 2019 + Razer Core X + XFX 5600 Xt (vbios updated) on Catalina 15.4 and Windows 10 1903


ReplyQuote
(@malthe_emil_blichfeldt)
Active Member
Joined: 2 years ago
 

@alessandro_lusi, Exactly the same symptoms as mine - black/green screen depending on the cable, max fan for a second or two and then it restarts. I am not sure if it is a driver issue or hardware, but I might se if a can change the card to another rx5700xt - I’m using the Powercolor right now. I have tried the red April, the January and the 2019 driver but same problem with all of them. I also get random black screen flickers In the top of the screen right before it happens... the black flickering also happens when I’m booted up I Mac OSX, but not the restart really. Could be the Mac-driver being more stable then the boot camp drivers(?) I’m honestly lost here... I’ll get back when I have a new rx5700xt - if the problem persists, then we can probably rule out hardware issues...

// update //_________________

So i just tried Unreal Heaven benchmarks in Mac OS on ultra settings, and sadly: black screen followed by quick/powerful fan spin from mac and then crash/restart. I'm beginning to think this is faulty hardware. I'm going to return the rx5700xt for another rx5700xt to see if this is a problem with my card. I'll get back in a week or so with the result of the new card... 

 

This post was modified 1 month ago

Mid 2019 15" Macbook Pro
2.9 GHz 6-Core Intel Core i9
Mac OS 10.15.4
-
Razer Core X
Power Color RX5700XT


ReplyQuote
(@malthe_emil_blichfeldt)
Active Member
Joined: 2 years ago
 
["SOLVED"]

Okay, so I went to the store and changed the Powercoler rx5700xt to an ASUS rx5700xt (a little more expensive but the only rx5700xt they had in the store left) and IT SEAMS TO HAVE FIXED IT! I have only tried it out for an hour so far, but have run the usual benchmarks that was sure to crash the Powercoler rx5700xt i had before, but now it just spins like a kitten. So my conclusion on this whole jurney of glitching/black screen/restart in both mac OS and windows is, that is was a faulty card. I described the problems to the dude in the store and he said that it very much sounded like a faulty power chip to him.

To future readers: if you are having these issues, this might very well be a faulty card and not a driver issue. If you are getting CPU kernel panics, that could be because your card disconnects for a split second due to faulty headware. I have spend about two weeks tweeking drivers, cables, clockspeed, fanspeed and Satan knows what, so if you feel like you are stuck with tweeking - definitly consider the possibility of faulty hardware.

Good luck guys *flies away in 4K 195FPS*

 

Mid 2019 15" Macbook Pro
2.9 GHz 6-Core Intel Core i9
Mac OS 10.15.4
-
Razer Core X
Power Color RX5700XT


ReplyQuote
(@malthe_emil_blichfeldt)
Active Member
Joined: 2 years ago
 

@alessandro_lusi and @configuration_nine see my reply - i have changed my card to a new rx5700xt and now it works. I believe is was a faulty card :-/

 

This post was modified 1 month ago

Mid 2019 15" Macbook Pro
2.9 GHz 6-Core Intel Core i9
Mac OS 10.15.4
-
Razer Core X
Power Color RX5700XT


ReplyQuote
(@alessandro_lusi)
New Member
Joined: 1 month ago
 

@malthe_emil_blichfeldt, thanks for your quote. 

I think that it was different from my problem. I never got a flickering black corner before green screen and now I realize that the latter happens only when I put the manual setting on the tuning configuration on Amd Software, If I leave all to default it doesn't occur. So Happy to hear that you resolve your problem. And let me know if it happens again. 

PS: I updated the driver to the official 20.4.2 April from Amd's website, and it is a little more stable than bootcamp edition, maybe it is a first impression. I let you know about any updates. 

 

MBP 15" 2019 + Razer Core X + XFX 5600 Xt (vbios updated) on Catalina 15.4 and Windows 10 1903


ReplyQuote
 of  2