5700XT + CORE X Randomly gets Blank Green Screen on External Monitor
 
Notifications
Clear all

5700XT + CORE X Randomly gets Blank Green Screen on External Monitor  

 of  3
  RSS

Malthe Emil Blichfeldt
(@malthe_emil_blichfeldt)
Active Member
Joined: 2 years ago
 

@alessandro_lusi, i actually just tried to tweak the settings on the new card in wattman to replicate your problem and it crashed. It’s been stable besides that, so I am pretty certain that the new card is better, but I’m just gonna leave the settings on auto since this is stable like yours... I’ll try to update the drivers later as well, but for now I am satisfied with the non glitcy screen and trouble less gaming Smile good luck!

 

Mid 2019 15" Macbook Pro
2.9 GHz 6-Core Intel Core i9
Mac OS 10.15.4
-
Razer Core X
Power Color RX5700XT


ReplyQuote
NEWTOALLTHIS
(@newtoallthis)
New Member
Joined: 1 month ago
 

@malthe_emil_blichfeldt, Hi I am having the same issue as you were having. Is your issues resolved with the new card? This is the one I have in a raxer x gpu

 

https://www.amazon.com/gp/product/B07ZP5QZX2/ref=ppx_yo_dt_b_asin_title_o00_s01?ie=UTF8&psc=1

 

 

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Ryan Ruel
(@ryan_ruel)
Active Member
Joined: 3 months ago
 

@newtoallthis, I've been having the same green screen lockups with an MSI 5700XT.

I feel like we can't all have bad hardware 🙁

I have a Razer Core X Chroma + MSI 5700XT Gaming.

I have had the green screen lockup issue with both a Mac mini 2018 as well as a 2015 MacBook Pro (running Thunderbolt 2 and purge wrangler).  So I know it's not the machine or cables.

The instability is extremely frustrating and I'm thinking about just selling the eGPU setup and moving on.

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Marius Fanu
(@marius_fanu)
Active Member
Joined: 2 weeks ago
 

Hi guys, did you manage to solve this issue?

I’m getting the same green screen and mac restart, and it’s really annoying 🙁 

 

My hardware is 

- Mac Mini 2018

- PowerColor Red Devil XR 5700 XT

- Razer Core X

Mac mini - 2018
MacBook Pro 15" - 2017
Lenovo IdeaPad 720s - 2017
---
Razer Core X
Sapphire Nitro+ RX 5700 XT


ReplyQuote
Ryan Ruel
(@ryan_ruel)
Active Member
Joined: 3 months ago
 

I swapped out my MSI 5700XT Gaming for a Sapphire 5700XT Pulse, and the problems went away.

The eGPU has been stable ever since.

(The Ethernet and USB hub feature of the Core X Chroma, on the other hand, are still not reliable enough to use.  Ugh.).

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Marius Fanu
(@marius_fanu)
Active Member
Joined: 2 weeks ago
 

Interestingly, I've connected the eGPU to a Lenovo laptop, running Windows 10 and AMD drivers, and tested it out for 1-2 hours... It worked flawlessly.

I'm curious if this is a macOS issue... 🤔

 

Mac mini - 2018
MacBook Pro 15" - 2017
Lenovo IdeaPad 720s - 2017
---
Razer Core X
Sapphire Nitro+ RX 5700 XT


ReplyQuote
Mini i5
(@mini-i5)
Reputable Member
Joined: 12 months ago
 

@marius_fanu

Update to Mac OS 10.15.6. 

 

2018 Mac Mini i5 / 6-core 3.0-4.1 Ghz / 32GB / 256GB / Intel UHD 630 / PowerColor Gaming Station / PowerColor dual-fan RX5700 XT / Mac OS 10.15.6 Catalina / Windows 2004 😏 / Dual LG 27" 4K displays


ReplyQuote
Malthe Emil Blichfeldt
(@malthe_emil_blichfeldt)
Active Member
Joined: 2 years ago
 

@newtoallthis, yes the new card fixed it.

but I could replicate the issue with the new card also, by booting up in windows via bootcamp, and tweaking the wattman settings for the card (Overclocking it). Then is got the black screen/green screen again. It seams to me like the Mac has a problem handling some of the cards.

honestly I spend two full weeks trying to figure it out, but I couldn’t isolate the problem. I don’t think it’s a driver problem, since it’s crashing with 3 different driver (both Mac OS and windows). 

my advise: try exchanging the card, sadly that’s the only thing that worked for me.

good luck!

 

Mid 2019 15" Macbook Pro
2.9 GHz 6-Core Intel Core i9
Mac OS 10.15.4
-
Razer Core X
Power Color RX5700XT


ReplyQuote
Marius Fanu
(@marius_fanu)
Active Member
Joined: 2 weeks ago
 

@mini-i5, I'm actually running macOS Big Sur beta 3 (developer) so that might also be the issue...

 

Mac mini - 2018
MacBook Pro 15" - 2017
Lenovo IdeaPad 720s - 2017
---
Razer Core X
Sapphire Nitro+ RX 5700 XT


ReplyQuote
Mini i5
(@mini-i5)
Reputable Member
Joined: 12 months ago
 

@marius_fanu

Maybe it’s more helpful for members here if you start a new Big Sur BETA SOFTWARE thread, as this isn’t necessarily a developer-specific forum. 

Also, the Red Devil cards are overclocked too high for their design, which is the issue.

I’ve haven’t seen anyone on this site recommended the Red Devil. 

If you ask for a recommendation, I’m sure someone would give you a better option to consider.

 

 

2018 Mac Mini i5 / 6-core 3.0-4.1 Ghz / 32GB / 256GB / Intel UHD 630 / PowerColor Gaming Station / PowerColor dual-fan RX5700 XT / Mac OS 10.15.6 Catalina / Windows 2004 😏 / Dual LG 27" 4K displays


ReplyQuote
 of  3