5700XT + CORE X Randomly gets Blank Green Screen on External Monitor
 
Notifications
Clear all

5700XT + CORE X Randomly gets Blank Green Screen on External Monitor  

 of  4
  RSS

chenyangh
(@chenyangh)
Active Member
Joined: 5 months ago
 

@newtoallthis, Hi, thanks for sharing your experience. I am using PowerColor RX 5700 XT Red Devil, it gives me random black screen issues from time to time. It is not too frequent, but like at least once in two days. So you experience with ASUS RX 5700 XT STRIX turns to be good, I would consider swapping my cards as well. As you can see from the forums that many folks have the same issues. As one has pointed out, we can't all have faulty cards. So I think a more likely explanation is that current Mac OS on mac mini is very picky on 5700xt cards (not necessarily faulty), which means different cards may have different frequency of crashing, perhaps 0 crashing if you are lucky. It is better to wait for a few days to see if you would see random crashes then let us know. If lucky, then we may all jump to ASUS cards. Cool   Thanks.

 

This post was modified 4 months ago

Mac Mini (2018, i7, 32GB)
Razer core x chroma
Sapphire Nitro+ 5700 XT


ReplyQuote
Mini i5
(@mini-i5)
Honorable Member
Joined: 1 year ago
 

Red Devils are overclocked too high. It’s easy to see from reading the specs.

I haven’t seen anybody ever recommend one.

2018 Mac Mini i5 / 6-core 3.0-4.1 Ghz / 32GB / 256GB / Intel UHD 630 / PowerColor Gaming Station / PowerColor dual-fan RX 5700 XT / Mac OS 10.15.6 Catalina / Windows 2004 😏 / Dual LG 27" 4K displays


ReplyQuote
chenyangh
(@chenyangh)
Active Member
Joined: 5 months ago
 

@mini-i5, Yeah. I actually put it in quiet mode. So my preference for the cards is those which have 3 DP ports, and quiet. So far this Red Devil works very well in this regard. So I still have two weeks to decide whether or not to keep this card. Other alternatives are Sapphire RX 5700 XT Pulse and ASUS RX 5700 XT STRIX. 

 

Mac Mini (2018, i7, 32GB)
Razer core x chroma
Sapphire Nitro+ 5700 XT


ReplyQuote
Marius Fanu
(@marius_fanu)
Active Member
Joined: 4 months ago
 

@mini-i5, I tried it out, hooked to my MacBook Pro, on the latest Catalina and it crashed in 10-15 min. It doesn't seem to be a Big Sur issue. 

If you have any good recommendation, I'd be happy to give it a try so that I can get rid of these annoying issues.

Cheers

 

Mac mini - 2018
MacBook Pro 15" - 2017
Lenovo IdeaPad 720s - 2017
---
Razer Core X
Sapphire Nitro+ RX 5700 XT


ReplyQuote
Mini i5
(@mini-i5)
Honorable Member
Joined: 1 year ago
 

@marius_fanu

The Saphire Nitro + and the XFX THIIC III ultra are overclocked models being used successfully in Mac OS by other members here. 

I've been running my PowerColor non-overclocked card (model AXRX 5700 XT 8GBD6-3DH) everyday for many months without any issues in Catalina and Windows. It's been completely trouble-free. But it is not overclocked.

I've never seen anybody recommend the Red Devil or the Red Dragon though. (Red-Flag should be the model name)

 

2018 Mac Mini i5 / 6-core 3.0-4.1 Ghz / 32GB / 256GB / Intel UHD 630 / PowerColor Gaming Station / PowerColor dual-fan RX 5700 XT / Mac OS 10.15.6 Catalina / Windows 2004 😏 / Dual LG 27" 4K displays


ReplyQuote
Marius Fanu
(@marius_fanu)
Active Member
Joined: 4 months ago
 

@mini-i5, thanks for the suggestion. I went with the Sapphire Nitro+ version and it's been almost a week without any issues now, it feels really stable. Thanks again! 🚀

Also I think there might have been an issue with that Red Devil, or a batch of them, because my brother has one hooked with the Razer Core X and he doesn't have any issues.

Anyway super happy with the Nitro+. Cheers!

 

Mac mini - 2018
MacBook Pro 15" - 2017
Lenovo IdeaPad 720s - 2017
---
Razer Core X
Sapphire Nitro+ RX 5700 XT


Mini i5 liked
ReplyQuote
Cookie Monster
(@cookie_monster)
New Member
Joined: 1 month ago
 

Thanks everyone, this is a very interesting thread.

 

I also am experiencing similar issue with a Mac mini (2018), Razer Core X Chroma, PowerColor RedDevil Radeon RX5700XT.

 

Display configuration is 4 x 27" (2560x1440): 3 displays connected to egpu, 1 display connected to mini

 

All three egpu displays will freeze up and turn green or black.  If I quickly turn off the egpu power switch, the mac will continue to run without issue on the display connected directly to the mini.  If the egpu remains turned on the whole system eventually restarts.

 

I am curious if there is a way to reduce the clock-speed on the RedDevil RX5700XT?

 

Anyone have luck fixing this without buying a different GPU?

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Marius Fanu
(@marius_fanu)
Active Member
Joined: 4 months ago
 

@cookie_monster, did you manage to find a fix?

For me replacing the card with the Sapphire Nitro+ fixed the issue, nothing else seed to work with the my Red Devil 😞

My brother has a Red Devil and it just works, he didn't have any problems. We both got them from Amazon.

Hopefully you found a fix, or if you can you can return it and get a Sapphire.

Good luck! 🚀 

 

Mac mini - 2018
MacBook Pro 15" - 2017
Lenovo IdeaPad 720s - 2017
---
Razer Core X
Sapphire Nitro+ RX 5700 XT


ReplyQuote
Cookie Monster
(@cookie_monster)
New Member
Joined: 1 month ago
 

Hi @marius_fanu, I have discovered that the Powercolor Red Devil 5700 XT ships overclocked relative to the AMD spec GPU.  I suspect that the overclocking is the cause of the freezes.

 

That said, the Powercolor has a "dual" BIOS... one BIOS configured for overclocking, one BIOS configured for silent operation (which is slightly under-clocked).  There is a physical switch to toggle between the two modes on the card itself.  The switch is on the top of the card, towards the side with the ports.  Mine had a little sticker next to it on the non-fan side that said OC/Silent.

Here is a picture of the location:

image

There is a more detailed discussion of the card modes here (performance, power and noise impact):

https://www.kitguru.net/components/graphic-cards/dominic-moass/powercolor-rx-5700-xt-red-devil-review/all/1/

 

I have changed to "Silent" mode and hope it resolves the issue.  Fingers crossed, I will revert back in a week or so with an update.

 

Cheers.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Cookie Monster
(@cookie_monster)
New Member
Joined: 1 month ago
 

Switching to Silent mode appears to have resolved the issue.  I have not had any GPU freezes since changing over.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
 of  4