Setup & Software Discussions
MacBook Pro 2017 + HP OMEN Accelerator with Mojave not working
 

MacBook Pro 2017 + HP OMEN Accelerator with Mojave not working  

  RSS

Amiga3000D
(@amiga3000d)
Active Member
Joined: 11 months ago
 

Got a 2017 2 TB Macbook Pro 13" with a HP OMEN Accelerator plugged in. It's equipped with a Sapphire R7 370 Nitro and is recognized in the Hardware Info as "Display" and AMD  (0x1002) Device.

Installing the Patch of Purge Wrangler didn't work, its still not recognized correct. I'm running MacOS Mojave 10.14.

Is this card not compatible or where's the issue?

Done:

Disabled SIP, installed PW 4.2.4 as mentioned and enabled the Patch, double checked the status of the patch.

 

Tested with Sapphire R7 370 Nitro and R9 255 (2GB), both are not working BUT if i unplug them, the message warning about the not proper disconnected GPU is shown.

Macbook Pro 13" 2017 (2 Thunderbolt Ports), Intel Iris 640
HP OMEN Accelerator


ReplyQuote
Amiga3000D
(@amiga3000d)
Active Member
Joined: 11 months ago
 

Downgraded to Mac Os 10.13.6 and installed WR again - no luck.

R9 255: recognized, eGPU Symbol appears in title (thus displaying "no gpu"), black screen and freeze with Kernel Panik (tested 3 Cards)

R7 370: recognized, no Symbol, Displayed as "Display" and AMD  (0x1002) Device in Hardware Info (tested 2 cards)
W4100: recognized, no Symbol, Displayed as "Display" and AMD  (0x1002) Device in Hardware Info (tested 1 card)
V3900: recognized, no Symbol, Displayed as "Display" and AMD  (0x1002) Device in Hardware Info (tested 1 card)
V3800: recognized, no Symbol, Displayed as "Display" and AMD  (0x1002) Device in Hardware Info (tested 1 card)
W2100: recognized, no Symbol, Displayed as "Display" and AMD  (0x1002) Device in Hardware Info (tested 2 cards)

 

all as "Display" recognized cards get the "eject gpu first" message warning when Thunderbolt cable is pulled.

Macbook Pro 13" 2017 (2 Thunderbolt Ports), Intel Iris 640
HP OMEN Accelerator


ReplyQuote
UnixSu
(@unixsu)
New Member
Joined: 10 months ago
 

Did you ever get this working?

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
(@guillermo_casanova)
New Member
Joined: 10 months ago
 

I dont know if I'm too late, maybe I am, but for anyone reading this, you should check out the list of compatible graphics cards here:

https://www8.hp.com/us/en/campaigns/omenaccelerator/overview.html

It doesnt matter if you dont have a compatible laptop, as long as it has thunderbolt, but the list of compatible GPUs is really important, and as you can see, the R7 series is not supported, that might be your problem, I recommend picking up a used rx 480 for $100 on ebay.

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote