Ableton Live 10 issue w/ NVIDIA eGPU  

  RSS

DannyVegas
(@dannyvegas)
Active Member
Joined: 6 months ago
Posts: 8
June 6, 2018 11:45 pm  

I'm using a late '13 MBP running 10.13.4 w/ a Razer Core and a 1080 based card. I got everything working, to the extent that it works, with the PurgeWrangler script. I mostly use my eGPU with my Windows machine, but I have a Mac I use for music applications and here is where I'm running into the issue. 

The weird issue I am running into is that when I try to use Ableton Live 10 with this setup, the application windows are empty. For example, the loading splash box, the main application window, and the configuration windows all come up, but they are just empty gray boxes without any graphical or text content, and the actual widgets and controls don't appear at all. My guess is that this has something to do with their implementation of GPU acceleration in the UI or perhaps something to do with the way they handle scaling in the new version of Live. On Windows, I think there are some settings you can change for each program to turn on/off GPU acceleration for each application, but I don't know as much about the Mac. Previously, I had Ableton Live 9 working with the eGPU setup. But I had since re-imaged my computer and had mostly been using it without the GPU. It kind of sucks, since running Ableton Live on a dual 4k monitor rig was my main objective here 🙂

Anyway, I know it's probably an obscure question since the number of people with a TB2 mac, trying to run an unsupported NVIDIA eGPU, and Ableton Live 10 is probably pretty small. I'm really just looking for any insights or suggestions anyone might have. 

Thanks!

MBP, Retina, 15-inch, Late 2013 (Iris Pro & Nvidia GT 750 M)
Razer Core,
1080 based card


ReplyQuote
MessyMass
(@messymass)
New Member
Joined: 3 months ago
Posts: 1
September 27, 2018 4:59 pm  

I have exactly the same problem. Updated to Mojavewhich but unfortunately Nvidia hasn't made webdrivers for the GTX 970 yet, so the Ableton UI turns up with gray application windows. If anyone knows a way to bypass the scaling/graphics accelleration for certain program like Ableton in OSX, I'd love to know as well!

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
zipp0rsch
(@zipp0rsch)
Active Member
Joined: 2 months ago
Posts: 13
October 15, 2018 7:56 am  

Are there any updates to the issue? Might be worth getting in contact with Ableton to see if there are any known issues with eGPUs.

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
13ue
 13ue
(@13ue)
New Member
Joined: 2 years ago
Posts: 1
October 18, 2018 8:06 pm  

Hola, had the same problem.

Try to set the internel monitor as main monitor and then start Ableton 🙂
This works for me, MBP 15 late 2013  with dgpu, gtx 1070 in akitio t2. goalque 1.0.3 EFI/Hybrid on 10.13.6.

Hope it will help you, too!

Ah f*ck, nvm... it remains it total zoom then..

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
zipp0rsch
(@zipp0rsch)
Active Member
Joined: 2 months ago
Posts: 13
October 19, 2018 5:35 am  
Posted by: 13ue

Hola, had the same problem.

Try to set the internel monitor as main monitor and then start Ableton 🙂
This works for me, MBP 15 late 2013  with dgpu, gtx 1070 in akitio t2. goalque 1.0.3 EFI/Hybrid on 10.13.6.

Hope it will help you, too!

Ah f*ck, nvm... it remains it total zoom then..

Thanks for chiming in @13ue. I am a bit confused now, does it work or does it not work? 🙂

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
zipp0rsch
(@zipp0rsch)
Active Member
Joined: 2 months ago
Posts: 13
October 30, 2018 8:57 am  

I got an eGPU myself and I am not having any issues with Live 10. Setup is nMP, Akitio Thunder2, RX 460. I only have one monitor connected to the eGPU, the integrated GPU is not used. Maybe this makes a difference? Or maybe it is the Nvidia cards?

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote