Akitio Node Pro + AMD Radeon Pulse RX 580 8GB GDDR5 (Saphire)
 
Notifications
Clear all

Akitio Node Pro + AMD Radeon Pulse RX 580 8GB GDDR5 (Saphire)  

  RSS

(@lucas_do_amaral_saboya)
Active Member
Joined: 3 years ago
 

Heya, how's it going everyone?

I'm having a weird issue running my setup in here:

When I plug in only the Akitio Node Pro (without the GPU in it), the laptop recognizes the e-gpu and passes though everything it has, power, daisy chains another dock's ports and it's great. When I plug in the e-gpu with that GPU in it, MacOS stops responding. The only thing I can do is move the mouse cursos around (and I witnessed that the GPU fans aren't spinning anymore, only when I plug it in. If I pull the cable (without stopping the GPU via MacOS cause everything is frozen), it'll panic and reboot.

What am I missing here?

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
itsage
(@itsage)
Founder Admin
Joined: 5 years ago
 

Is the Sapphire RX 580 Pulse new? If not, flash the vBIOS back to its original to make sure there's no compatibility issue.

LinkedIn | Twitter | Facebook | Youtube | Instagram
 
external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2021 13" ASUS ROG Flow X13 (RTX3050Ti) [R5K,8C,H] + RTX 3080 @ 64Gbps-XG (XG Mobile) + Win10 20H2 [build link]  


ReplyQuote
(@lucas_do_amaral_saboya)
Active Member
Joined: 3 years ago
 
Posted by: itsage

Is the Sapphire RX 580 Pulse new? If not, flash the vBIOS back to its original to make sure there's no compatibility issue.

Heya @itsage, how's it going?

Yeah, the GPU is brand new, I just got it from Amazon (that very same link I've posted before).

Do you happen to know where can I find more info on flashing it?

How to do it and which firmware and where I should get it?

Thanks for the response, btw!

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
mac_editor
(@mac_editor)
Famed Member Moderator
Joined: 5 years ago
 

@Lucas_do_amaral_saboya Those symptoms are identical to what I had on a defective RX480 (down to the pulling the cable and KP). Get a replacement.

"Desultory reading is delightful, but to be beneficial, our reading must be carefully directed." — Seneca

Author: kryptonitepurge-wranglertbt-flashpurge-nvdaset-eGPU
Insights Into macOS Video Editing Performance
Launching Apps on Specific (e)GPUs on macOS

Master Threads:
2014 15-inch MacBook Pro 750M
2018 15-inch MacBook Pro

 
2019 13" MacBook Pro [8th,4C,U] + RX Vega 64 @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.14.6 & Win10 [build link]  


itsage liked
ReplyQuote
(@lucas_do_amaral_saboya)
Active Member
Joined: 3 years ago
 
Posted by: mac_editor

@Lucas_do_amaral_saboya Those symptoms are identical to what I had on a defective RX480 (down to the pulling the cable and KP). Get a replacement.

Got in touch w/ Amazon customer service/support and got a new GPU shipped. Will update here when it gets here.

In that regard, is there ANYTHING that needs to be done when it arrives? Or is it really just plug & play?

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
its_dy1an
(@its_dy1an)
New Member
Joined: 3 years ago
 

@Lucas_do_amaral_saboya Any update? Thx!

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
(@lucas_do_amaral_saboya)
Active Member
Joined: 3 years ago
 

Got a replacement GPU and indeed, everything works like a charm:
https://imgur.com/a/KEgvvVE

Even Akitio's daisy chaining works out of the box!
https://imgur.com/a/LEs1Q3J

Thanks @mac_editor, you've saved me days of debug and headache!
and Thanks to Amazon pristine customer support.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

mac_editor and itsage liked
ReplyQuote
blerghcity
(@blerghcity)
Eminent Member
Joined: 3 years ago
 


@Lucas_do_amaral_saboya What docking station did you use for daisy chaining? Have you noticed any reduced GPU performance when using the dock? 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
(@lucas_do_amaral_saboya)
Active Member
Joined: 3 years ago
 

Heya, @blerghcity, 

I'm using an OWC Thunderbolt 3 Dock, here's an amazon link for it (but it seems to be out of stock): 
https://www.amazon.com/gp/product/B01N51P3BB/ref=ppx_yo_dt_b_asin_title_o08__o00_s00?ie=UTF8&psc=1

There's a new version being sold, with a couple more ports in it: 
https://www.amazon.com/dp/B07JM3S5SJ/ref=twister_B07JLRS22F?_encoding=UTF8&th=1

I haven't seen a performance drop while using it. In my set up, everything but the monitors are hooked up to this OWC dock: USB mic, 4K webcam, USB Keyboard, ethernet, a smaller 4port USB3 extending it to my desk  and Logictech's Unify Receiver for my mouse. Super happy with the outcome of this setup.

I don't game on this rig, so performance might be a little suboptimal for all I care. I could run a benchmark took if you'd like, just point me to it and I'll do it.

Cheers and thanks for all the feedback and support guys, you rock!

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote