Setup & Software Discussions
AMD Radeon RX Vega eGPU support in macOS High Sierra 10.13
 

AMD Radeon RX Vega eGPU support in macOS High Sierra 10.13  

 of  2
  RSS

itsage
(@itsage)
Famed Member Admin
Joined: 3 years ago
 

The Mantiz team got a hold of an RX Vega and tried it with Mantiz Venus in 10.13 Beta 5. Looks like Apple will have eGPU support for multiple AMD cards. 😀

20708431 348042062318185 4232228836211291030 n
20663830 348042058984852 661566813042999677 n

Best ultrabooks for eGPU use | eGPU enclosure buying guide


SheldonTung, goalque, mac_editor and 5 people liked
ReplyQuote
RianGray
(@riangray)
Active Member
Joined: 2 years ago
 

Thank goodness. I was worried that Mac eGPU may suffer from up/down in cryptocurrency mining practice.

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
mac_editor
(@mac_editor)
Famed Member Moderator
Joined: 3 years ago

ReplyQuote
itsage
(@itsage)
Famed Member Admin
Joined: 3 years ago
 

We’ve also made suggestions to Gigabyte and AMD to team up for an AORUS Radeon RX Vega Gaming Box. That would be a perfect macOS-friendly alternative to the current GTX 1070 Gaming Box.

Best ultrabooks for eGPU use | eGPU enclosure buying guide


ReplyQuote
wukakuki
(@wukakuki)
New Member
Joined: 3 years ago
 

Does amd Vega frontier support in macOS High Sierra 10.13 now? How to make egpu work with lg Ultrafine 5k display?

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member
Joined: 3 years ago
 

Funilly, I've just read a thread all about the Ultrafine, and sadly its not good news....

 

https://egpu.io/forums/mac-setup/lg-ultrafine-5k1080tiawful-performance-game-benchmarks/#post-17467

 

I had wanted to grab one myself but sounds like they won't really work (which contradicts what I had heard previously but its first hand and extensive tests).

2017 13" MacBook Pro Touch Bar
GTX1060 + AKiTiO Thunder3 + Win10
GTX1070 + Sonnet Breakaway Box + Win10
GTX1070 + Razer Core V1 + Win10
Vega 56 + Razer Core V1 + macOS + Win10
Vega 56 + Mantiz Venus + macOS + W10

---

LG 5K Ultrafine flickering issue fix


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member
Joined: 3 years ago
 

I usually find PC components pretty ugly but I have to say those Vega cards look fantastic, hopefully miners buying them all won't be an issue as it is currently wit h5xx cards (I have had one on back order for about 3 months).

2017 13" MacBook Pro Touch Bar
GTX1060 + AKiTiO Thunder3 + Win10
GTX1070 + Sonnet Breakaway Box + Win10
GTX1070 + Razer Core V1 + Win10
Vega 56 + Razer Core V1 + macOS + Win10
Vega 56 + Mantiz Venus + macOS + W10

---

LG 5K Ultrafine flickering issue fix


ReplyQuote
Stormbreaker
(@stormbreaker)
Eminent Member
Joined: 2 years ago
 

I've been seeing a whole bunch of articles saying the new Vega cards are extremely powerfull for mining :/

tbMBP 13" 2016 + RX580 (Mantiz Venus) + macOS 10.14 + Windows 10

Monero mining guide for AMD GPUs


ReplyQuote
mac_editor
(@mac_editor)
Famed Member Moderator
Joined: 3 years ago
 
Posted by: Stormbreaker

I've been seeing a whole bunch of articles saying the new Vega cards are extremely powerfull for mining :/

FFS is all I can say 🙁

purge-wrangler.shpurge-nvda.shset-eGPU.shautomate-eGPU EFI Installer
2018 MacBook Pro 15" RP560X + RX 5700 XT (Mantiz Venus)


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member
Joined: 3 years ago

ReplyQuote
BMW2017
(@bmw2017)
Eminent Member
Joined: 2 years ago
 

I'm waiting to setup my '16 MBP 15" + VEGA RX 64 + Mantiz-02... Hopefully it is plug n play under High Sierra. Hopefully High Sierra is released on the 12th!

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
ikir
 ikir
(@ikir)
Prominent Member
Joined: 3 years ago
 
Posted by: BMW2017

I'm waiting to setup my '16 MBP 15" + VEGA RX 64 + Mantiz-02... Hopefully it is plug n play under High Sierra. Hopefully High Sierra is released on the 12th!

As far I know Vega drivers have still issues. Let’s hope for final release!


MacBook Pro 2018 Touch Bar i7 quad-core 2.7Ghz - 16GB RAM - 512GB PCIe SSD
my awesome Radeon VII eGPU
my Mantiz Venus extreme mod with Sapphire Nitro+ RX Vega 64


BMW2017 liked
ReplyQuote
BMW2017
(@bmw2017)
Eminent Member
Joined: 2 years ago
 

Tried running the RX 64... System kept freezing up on me... Narrowed it down to the GPU, as the High Sierra external SSD was just fine without it.

 

https://egpu.io/forums/mac-setup/egpu-high-sierra-vega-rx-64-4k-anyone-tried-it-yet-2/#post-19348

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
Sky11
(@sky11)
Reputable Member
Joined: 3 years ago
 
Posted by: BMW2017

Tried running the RX 64... System kept freezing up on me... Narrowed it down to the GPU, as the High Sierra external SSD was just fine without it.

 

https://egpu.io/forums/mac-setup/egpu-high-sierra-vega-rx-64-4k-anyone-tried-it-yet-2/#post-19348

1. Can you plug your laptop's power supply to ensure that eGFX box does not provide power to the laptop?

2. Can you try a bigger power supply for the GPU? Simply open the eGPU box, unplug the factory PSU and plug a bigger (750W+) regular power supply?

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
BMW2017
(@bmw2017)
Eminent Member
Joined: 2 years ago
 

I tried plugging in the Apple PSU to the MBP and starting in High Sierra... Everything seemed fine at first, but as soon as I launched an application, cursor froze for 5-10 seconds... Kept doing it. So, nothing changed. Do you think the smaller PSU has anything to do with it freezing/unfreezing? Wouldn't it just power down completely? Now what?

I wish I could replace the PSU, but that would void the warranty.

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
BMW2017
(@bmw2017)
Eminent Member
Joined: 2 years ago
 

When you say issues, what are they experiencing? The freezing/unfreezing like I am?

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
ikir
 ikir
(@ikir)
Prominent Member
Joined: 3 years ago
 

Usually insufficient power freeze the os.


MacBook Pro 2018 Touch Bar i7 quad-core 2.7Ghz - 16GB RAM - 512GB PCIe SSD
my awesome Radeon VII eGPU
my Mantiz Venus extreme mod with Sapphire Nitro+ RX Vega 64


ReplyQuote
goalque
(@goalque)
Noble Member Admin
Joined: 3 years ago
 

AMD cards tend to freeze at low power conditions, especially via TB2.

I've not experienced any system freeze in normal use yet with the Vega 64 + HL23T. Some Metal accelerated games still freeze but drivers are not ready.

automate-eGPU EFIapple_set_os.efi
--
2018 13" MacBook Pro + Radeon [email protected] + Win10 1809


ikir liked
ReplyQuote
BMW2017
(@bmw2017)
Eminent Member
Joined: 2 years ago
 

I experience freezing with just Safari open... It comes and goes... Some times there is a lot of time in-between freezes and sometimes not... Very random.

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
goalque
(@goalque)
Noble Member Admin
Joined: 3 years ago
 

Please try on Windows 10 - if still the same, the cause is either Mantiz enclosure or your XFX Vega 64. Not macOS. 

automate-eGPU EFIapple_set_os.efi
--
2018 13" MacBook Pro + Radeon [email protected] + Win10 1809


ReplyQuote
Sky11
(@sky11)
Reputable Member
Joined: 3 years ago
 

With OS installed on SSD inside of enclosure, all bets are off. 

If I understand correctly, the SSD is actually connected to USB3 hub (please correct me if I am wrong!), and it is meant only for storage.

Only PCIe storage (which is plugged instead of GPU) is suitable for OS installation; USB and GPU data traffic are essentially sharing the same pipe, so with the current firmware some hickups are possible. Please confirm with Mantiz if installation of OS on internal SSD is supported (by Intel) scenario.

 

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
goalque
(@goalque)
Noble Member Admin
Joined: 3 years ago
 

@Sky11: Yep, good point.

I could test USB3.1 Gen2 (10Gbps) SSD installation with my HL23T setup, from the second TB3 port.

automate-eGPU EFIapple_set_os.efi
--
2018 13" MacBook Pro + Radeon [email protected] + Win10 1809


ReplyQuote
Wunair
(@wunair)
Eminent Member
Joined: 2 years ago
 

I've installed the public beta High Sierra (not sure which version of the beta this is) and was excited to try it with my newly acquired RX Vega 64. It saddened me that it was extremely buggy. As soon as I tried something more graphically intense than showing a webpage, like loading a video, it would freeze for 10-20 seconds and crash. On random times, I would be able to get playing videos to work. Is this because my MacBook was fully charged (I usually leave it on the charger, so it should've be on full charge)?

I also experienced a crash that kind of freaked me out. The external monitor went black and the Vega card went to 100% fan speed. Logging out didn't resolve the issue. I couldn't even shut down my MacBook, it just went to a black screen after I tried it. I had to forcefully shut it down.

I'm now doubting whether it's the lack of mature drivers in High Sierra or it's my card. When I have the time, I'm going to try the card on Windows.

I really do hope the drivers for the Vega will be better when the official High Sierra comes out, but I fear this will take a while.

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
BMW2017
(@bmw2017)
Eminent Member
Joined: 2 years ago
 

Yup, I had a really bad freeze today with the RX 64 as well... Now I'm trying the RX 56 to see what it does... So far, the only issue with the 56 is under Google Chrome... Refuses to work with Chrome, constant freezing. I've noticed big spikes in CPU load as well.

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
BMW2017
(@bmw2017)
Eminent Member
Joined: 2 years ago
 

Still freezing and not going into Clamshell mode. I am running High Sierra off an SSD installed into the Mantiz, might be part of the issue?

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
ikir
 ikir
(@ikir)
Prominent Member
Joined: 3 years ago
 

GM is out, I've tested just Valley and gfx distortion with AA are still here.


MacBook Pro 2018 Touch Bar i7 quad-core 2.7Ghz - 16GB RAM - 512GB PCIe SSD
my awesome Radeon VII eGPU
my Mantiz Venus extreme mod with Sapphire Nitro+ RX Vega 64


ReplyQuote
acantril
(@acantril)
Eminent Member
Joined: 2 years ago
 

I just posted this on another thread but ...

 

I have the strangest bug with a vega64 + EGPU Enclosure + macOS High Sierra (GM Candidate).

SO I have my 13 inch, 2017 MacBook Pro connected to a mantis Venus with the Vega 64 in.

Connected to the Vega 64 … 3 x DP -> 3 x 4k screens.

lets say I have an safari window open … on a forums… tons of links (thread titles) – same is true for chrome.

If I move my mouse up and down over those links … the mouse pointer slows down… like 1/3 of the speed of how quickly it moves over the desktop with the same mouse/speed settings.

This also happens on the internal screen … with the eGPU setup connected.

With the GPU/eGPU not connected… I don’t see the above at all.

it’s driving me nuts…..

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
mac_editor
(@mac_editor)
Famed Member Moderator
Joined: 3 years ago
 
Posted by: acantril

I just posted this on another thread but ...

 

I have the strangest bug with a vega64 + EGPU Enclosure + macOS High Sierra (GM Candidate).

SO I have my 13 inch, 2017 MacBook Pro connected to a mantis Venus with the Vega 64 in.

Connected to the Vega 64 … 3 x DP -> 3 x 4k screens.

lets say I have an safari window open … on a forums… tons of links (thread titles) – same is true for chrome.

If I move my mouse up and down over those links … the mouse pointer slows down… like 1/3 of the speed of how quickly it moves over the desktop with the same mouse/speed settings.

This also happens on the internal screen … with the eGPU setup connected.

With the GPU/eGPU not connected… I don’t see the above at all.

it’s driving me nuts…..

Try disabling Displays have separate spaces setting for Mission Control...

purge-wrangler.shpurge-nvda.shset-eGPU.shautomate-eGPU EFI Installer
2018 MacBook Pro 15" RP560X + RX 5700 XT (Mantiz Venus)


goalque and itsage liked
ReplyQuote
BMW2017
(@bmw2017)
Eminent Member
Joined: 2 years ago
 

Have you gotten any system freezes with that setup?

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
acantril
(@acantril)
Eminent Member
Joined: 2 years ago
 
Posted by: BMW2017

Have you gotten any system freezes with that setup?

None at all ... in bootcamp its 100% stable (but poor-ish performance v's what i expected)

OS is stable.. with this one exception.

Will try and spaces thing.

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
dburkland
(@dburkland)
Active Member
Joined: 2 years ago
 

Couple of observations after setting up my system (2016 15" MBP w/ AMD 460 running latest GM candidate, 2 x 27" 4k LG 27UDP69 Displays connected via displayport, 1 x AMD Vega 56 yesterday:

 

  • The eGPU minus the ethernet driver was recognized out of the box and hot plug seems to work just fine
  • One display shows 4k @ 30hz and the other 4k @ 60hz so not sure if this is a driver or GPU issue.
    • I am going to plugin one of the displays via HDMI to see if that resolves the issue later today.
  • 4k video playback is a bit laggy but again I blame this on drivers vs the eGPU hardware...
  • Clamshell mode doesn't seem to work even if I boot the machine up with the lid closed immediately
  • Disabling "Displays have separate spaces" setting for Mission Control resolves the pointer speed issue for me

 

I am going to try to setup bootcamp + Windows later tonight to see how the performance goes as I'm interested to get back into some gaming. Overall for the software being in beta I am pretty happy, it can only get better from here right? 🙂

Cheers,

Dan

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
BMW2017
(@bmw2017)
Eminent Member
Joined: 2 years ago
 

You've had no freezing with the Vega 64 and High Sierra?

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
acantril
(@acantril)
Eminent Member
Joined: 2 years ago
 

I wonder if im hitting limits with the 13-inch 2017 MacBook Pro.

I've read that with an EGPU connected, and external displays - that the external displays are driven by the iGPU - unless using a full screen 3d app - or something specifically selecting the GPU.

The MacBook Pro 13 is officially rated to support 2 x 4k external screens - and I'm running 3 via the EGPU.

wonder if this is the cause of the weird issues (mouse lag, tracking speed slowdowns etc)

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
ikir
 ikir
(@ikir)
Prominent Member
Joined: 3 years ago
 
Posted by: acantril

I wonder if im hitting limits with the 13-inch 2017 MacBook Pro.

I've read that with an EGPU connected, and external displays - that the external displays are driven by the iGPU - unless using a full screen 3d app - or something specifically selecting the GPU.

The MacBook Pro 13 is officially rated to support 2 x 4k external screens - and I'm running 3 via the EGPU.

wonder if this is the cause of the weird issues (mouse lag, tracking speed slowdowns etc)

Have you selected the external display an main one?


MacBook Pro 2018 Touch Bar i7 quad-core 2.7Ghz - 16GB RAM - 512GB PCIe SSD
my awesome Radeon VII eGPU
my Mantiz Venus extreme mod with Sapphire Nitro+ RX Vega 64


ReplyQuote
BMW2017
(@bmw2017)
Eminent Member
Joined: 2 years ago
 

Installed High Sierra on the internal SSD and the RX 580... Zero issues! About this Mac does not report the exact card however.

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ikir liked
ReplyQuote
ikir
 ikir
(@ikir)
Prominent Member
Joined: 3 years ago
 
Posted by: BMW2017

Installed High Sierra on the internal SSD and the RX 580... Zero issues! About this Mac does not report the exact card however.

Yes it is not an issue, everything will work ok


MacBook Pro 2018 Touch Bar i7 quad-core 2.7Ghz - 16GB RAM - 512GB PCIe SSD
my awesome Radeon VII eGPU
my Mantiz Venus extreme mod with Sapphire Nitro+ RX Vega 64


ReplyQuote
 of  2