[APP] automate-eGPU.kext by Goalque (AMD only)
 
Notifications
Clear all

[Closed] [APP] automate-eGPU.kext by Goalque (AMD only)  

 of  13
  RSS

mgarito
(@mgarito)
New Member
Joined: 3 years ago
 

Sadly, the OS still locks up on 10.13.2 Beta Version 2 (17C67b).

 

Sonnet eGFX Breakaway Box w/ Radeon Pro WX7100 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

goalque
(@goalque)
Noble Member Admin
Joined: 4 years ago
 

I have no plans to keep this workaround up to date. Feel free to look at the plist.

I am not a guy who likes patchwork quilts. I just wanted to point out that Apple is likely going to add a larger variety of AMD cards that allow easy eGPU use, natively.

Everything is still in the beta stage and software developers are required to reflect changes in Metal API.

automate-eGPU EFIapple_set_os.efi

Mid 2015 15-inch MacBook Pro eGPU Master Thread

 
2018 13" MacBook Pro [8th,4C,U] + Radeon VII @ 32Gbps-TB3 (ASUS XG Station Pro) + Win10 1809 [build link]  


itsage liked
w xsong
(@w_xsong)
New Member
Joined: 3 years ago
 

How to solve the fan's full speed?

Mac Pro (2013) OS X 10.13.2, Sonnet eGFX Breakaway Box, Radeon RX Vega 56

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ikir
 ikir
(@ikir)
Prominent Member
Joined: 4 years ago
 

Any update on this?


MacBook Pro 2020 Touch Bar i7 quad-core 2.3Ghz - 16GB RAM - 1TB PCIe SSD
my awesome Radeon VII eGPU
my Mantiz Venus extreme mod with Sapphire Nitro+ RX Vega 64

 
2018 13" MacBook Pro [8th,4C,U] + Radeon VII @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.15 [build link]  


FrankW
(@frankw)
New Member
Joined: 3 years ago
 

Sorry for perhaps asking a dumb question, but I couldn't find any definite info in the forums. I have an AMD Radeon 280X (Tahiti family, same driver as AMD 7970 which is stated to be supported by the automate-eGPU script). Is that right? Does it work in High Sierra with the script? Thanks

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

DANgerous25
(@danfalconar)
Estimable Member
Joined: 4 years ago
 

Hi guys, according to the original post this script doesn't support Vega FE [air + liquid]. In theory these should be natively supported in the latest HS, but for some reason my Vega FE liquid isn't detected and I know of at least one other person with the same issue.

Is it possible to modify automate-eGPU to make it work with this card? At present I can't install the script because it doesn't detect the card.

2017 27" iMac Pro (Vega64) [7th,10C,W] + GTX 1080 Ti @ 32Gbps-TB3 (AKiTiO Node) + macOS 10.13.2 [build link]  

mortifer
(@mortifer)
Active Member
Joined: 3 years ago
 

Sadly, this is broken on 10.13.4 combo update with the RX 560. 10.13.4 recognizes the Sonnet Breakaway 550w, but does not see the RX 560.

Ironically, deleting the kext and booting into recovery mode, macOS recognizes the eGPU and uses the external display. But normal boot it doesn't. Why in the world would recovery mode work and not a normal boot?

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

benr
 benr
(@benr)
Eminent Member
Joined: 4 years ago
 

I imagine it's because beginning with 10.13.4, macOS has full native support for AMD eGPUs.

Your Sonnet box is now officially supported by macOS, although the RX 560 does not quite make the official list. (Can anyone speak as to whether the RX 560 should work under 10.13.4 without hacks?)

I suspect that Recovery Mode is behaving as would a clean install of macOS 10.13.4, hence the different behavior. For supported AMD GPUs on macOS 10.13.4, all previously required hacks on this forum should probably be considered obsolete, and be removed from your system.

For AMD at least, it's a brave new world of official Apple support for eGPU.

EDIT:
IMPORTANT NOTE
: With 10.13.4 and official support, Apple have unfortunately chosen to drop support for all Macs without native Thunderbolt 3 ports.

For now this means that 2013 Mac Pros, many iMacs, and MacBook Pros with TB2 or TB1 which have worked well with solutions found on this forum may stop working with 10.13.4.

Certain parties have already begun to petition Apple to remove what seems to be an artificial limitation on the eGPU support.

Since we on this forum have demonstrated many times that TB2 and even TB1 are completely viable connections for eGPU use, we should probably turn our attention to this issue, and hopefully encourage Apple to allow certain older Macs to be supported for eGPU use.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

itsage liked
mortifer
(@mortifer)
Active Member
Joined: 3 years ago
 
Posted by: benr

I imagine it's because beginning with 10.13.4, macOS has full native support for AMD eGPUs.

Your Sonnet box is now officially supported by macOS, although the RX 560 does not quite make the official list. (Can anyone speak as to whether the RX 560 should work under 10.13.4 without hacks?)

I suspect that Recovery Mode is behaving as would a clean install of macOS 10.13.4, hence the different behavior. For supported AMD GPUs on macOS 10.13.4, all previously required hacks on this forum should probably be considered obsolete, and be removed from your system.

I'm sorry that I miscommunicated. I was stating that I even tried everything without the automate-egpu.kext installed. So when I was saying I booted normal, it was without.

Apple is recognizing it in recovery mode but rejecting the drivers in normal boot without the "hacks".

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

mortifer
(@mortifer)
Active Member
Joined: 3 years ago
 

Besides that mentioned in my previous reply, System Information does show the RX 560 listed under PCI devices. However, it states that the driver is not installed. So, this too leads me to believe Apple has purposefully not allowed the RX 560 even though it works natively with macOS.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

 of  13