Audio from Mac mini via EGPU Display / HDMI
 
Notifications
Clear all

Audio from Mac mini via EGPU Display / HDMI  

 of  2
  RSS

kamilkamien
(@kamilkamien)
Active Member
Joined: 3 years ago
 

Hello!
I have a problem. I would like to connect my mac mini with eGPU and with monitor which has speakers. Is there an option to let EGPU sound through HAMI / Display cables? The mac mini has a broken headphone jack and I can not connect the jack-jack monitor. Can someone help me out? In settings I can not see an external audio source. It looks like the eGpu did not send out an audio signal. Is it going to work or is there a speaker built into the "mini"?

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
jim_survak
(@jim_survak)
Eminent Member
Joined: 3 years ago
 

 There should be a speaker built into the Mac mini. It's not a very powerful speaker, but it's there.

Are you able to send us a screenshot of your System Preferences > Audio settings?

2018 Mac mini: Core i3, 8GB RAM, Sonnet 350 (aftermarket 550w PSU)+XFX Radeon RX-480 8GB Black Edition
2012 Mac mini: Core i7, 16GB RAM, Toshiba 1TB SSD, Seagate 1TB HDD
Custom: Ryzen 7 1700, 16GB Corasir DDR4-3200MHz RAM, 2x Corsair 500GB Neutron SSD, Seagate 3TB SSD, EVGA Nvidia 980Ti
YT:


ReplyQuote
Chippy McChipset
(@chippy-mcchipset)
Reputable Member
Joined: 3 years ago
 

Whether your eGPU allows audio to pass through to a display via HDMI may depend on the eGPU implementation itself. Thunderbolt 3 is designed to work with DisplayPort natively. So if that monitor of yours and the GPU has a DP port, I would skip the HDMI and try it that way. Still not sure if it will work but you're taking out a potential compatibility concern by not having a non-DP display try to communicate with your host via TB3.

Thunderbolt 3 Macs, Sonnet and OWC eGPUs, 4K Displays, etc


ReplyQuote
simdao
(@simdao)
New Member
Joined: 3 years ago
 

I have the similar issue, the audio cannot passthrough via display port in MacOS (Cannot see the monitor in sound output) but Windows 10 is no problem. I am wondering if there any missing driver in MacOS. I am still searching anyone have similar issue with solution.

Configuration:

Macbook Pro 15" 2016

eGPU - Mantiz MZ-02 + 1070

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Dude
 Dude
(@dude)
Active Member
Joined: 3 years ago
 

I imstalled my Mantiz with a 1080 yesterday using a DisplayPort cable into both the 1080 and the monitor and I have this problem too. In MacOS I don't have the monitor audio anymore, just the built-in output. 

So, no clam shell mode, no audio. Starting to believe I should just give up on the egpu idea.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
kamilkamien
(@kamilkamien)
Active Member
Joined: 3 years ago
 

So I thought it was just me who could not handle the problem. The sound of the built-in speakers does not satisfy me. My Mac is too old to sell and repair is unprofitable so unfortunately I'm waiting, maybe someday there will be a change

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
shadethegrey
(@shadethegrey)
Active Member
Joined: 3 years ago
 

I'm running a Sonnet 350 and an XFX RX580 on a mac mini, and I can get sound through my monitor.  The monitor shows up under the Sound preference pane and I can use it as output, does your monitor show up there as a device under output?  My monitor has an audio out that I hook to speakers.  I'm using an HDMI cable from the XFX to the monitor, so I do know it works.  Can you get sound through the monitor by unhooking the egpu and hooking it straight to the mac?  That would eliminate the egpu as a problem, or show it as otherwise.

6th Gen X1 Carbon + MSI Air Boost Vega 56 +Sonnet Breakaway 550 on Pop! OS Linux

 
2018 14" Lenovo Thinkpad X1 Carbon Gen 6 [8th,4C,U] + RX Vega 56 @ 32Gbps-TB3 (Sonnet Breakaway 550) + Linux Pop! OS [build link]  


ReplyQuote
taaaco
(@taaaco)
New Member
Joined: 3 years ago
 

Just setup the aorus 1080 box on my 15' 2016 460 machine and encountering the same problem.

 

using a usb c to display port adapter worked and let me send audio out, but that option is gone now. 

 

Works just fine in windows

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
ed_co
(@ed_co)
Reputable Member
Joined: 3 years ago
 

+1

I thought I read some HDMI alternative driver. Maybe this could be modified to make it work via DisplayPort? @nando, @itsage, @Rastafabi, @goalque maybe they know...

2017 15" MacBook Pro (RP560) [7th,4C,H] + GTX 1080 Ti @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.13 & Win10 [build link]  

ReplyQuote
TrDA
 TrDA
(@trda)
Active Member
Joined: 3 years ago
 

https://egpu.io/forums/mac-setup/wip-nvidia-egpu-support-for-high-sierra/paged/16/#post-23975

early-2015 13″ MBA + Akito Thunder 2 + GTX1050ti + external display 1080p + macOS10.13.3 & Win10
late - 2011 17″ MBP + Akito Thunder 2 + GTX1050ti + external display 1080p + macOS10.13.3 & Win10

 
2015 13" MacBook Air [5th,2C,U] + GTX 1050 Ti @ 16Gbps-TB2 (AKiTiO Thunder2) + macOS 10.13 & Win10 [build link]  


ReplyQuote
 of  2