automate-eGPU EFI - eGPU boot manager for macOS and Windows
 
Notifications
Clear all

[Solved] automate-eGPU EFI - eGPU boot manager for macOS and Windows  

 of  108
  RSS

Eightarmedpet
(@eightarmedpet)
Noble Member Moderator
Joined: 3 years ago

ReplyQuote
mac_editor
(@mac_editor)
Famed Member Moderator
Joined: 3 years ago
 

@eightarmedpet Please re-run. Was a little mistake.

Also, I haven't added the Ti82 patch to this. I'll do later on as well so people can have unlocked Ti82 enclosures by default.

purge-wranglertbt-flashpurge-nvdaset-eGPU
Insights Into macOS Video Editing Performance

Master Threads:
2014 15-inch MacBook Pro 750M
2018 15-inch MacBook Pro

 
2019 13" MacBook Pro [8th,4C,U] + RX Vega 64 @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.14.6 & Win10 [build link]  


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member Moderator
Joined: 3 years ago
 

That worked, but has killed my LG 5K... I was booting just fine with the previous version - any ideas?

2017 13" MacBook Pro Touch Bar
GTX1060 + AKiTiO Thunder3 + Win10
GTX1070 + Sonnet Breakaway Box + Win10
GTX1070 + Razer Core V1 + Win10
Vega 56 + Razer Core V1 + macOS + Win10
Vega 56 + Mantiz Venus + macOS + W10

---

LG 5K Ultrafine flickering issue fix

 
2017 13" MacBook Pro [7th,2C,U] + RX 5700 XT @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.15.4 & Win10 2004 [build link]  


ReplyQuote
mac_editor
(@mac_editor)
Famed Member Moderator
Joined: 3 years ago
 

@eightarmedpet The installer is basically just downloading and unzipping the file to the pen drive, just as anyone would do manually. If you made some other adjustments to the config.plist, you will have to add them manually still.

The installer also checks file integrity using a SHASUM so the installation is exactly the same as the file hosted on the forum.

purge-wranglertbt-flashpurge-nvdaset-eGPU
Insights Into macOS Video Editing Performance

Master Threads:
2014 15-inch MacBook Pro 750M
2018 15-inch MacBook Pro

 
2019 13" MacBook Pro [8th,4C,U] + RX Vega 64 @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.14.6 & Win10 [build link]  


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member Moderator
Joined: 3 years ago
 

That's the thing - I didn't? Could it be something to do with

  • Updates the configuration for NVIDIA or AMD, the latter based on system thunderbolt version.

 

?

2017 13" MacBook Pro Touch Bar
GTX1060 + AKiTiO Thunder3 + Win10
GTX1070 + Sonnet Breakaway Box + Win10
GTX1070 + Razer Core V1 + Win10
Vega 56 + Razer Core V1 + macOS + Win10
Vega 56 + Mantiz Venus + macOS + W10

---

LG 5K Ultrafine flickering issue fix

 
2017 13" MacBook Pro [7th,2C,U] + RX 5700 XT @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.15.4 & Win10 2004 [build link]  


ReplyQuote
mac_editor
(@mac_editor)
Famed Member Moderator
Joined: 3 years ago
 

@eightarmedpet If you chose NVIDIA no changes were made.

A good idea could be to retry doing it manually like you first did to re-check if the Ultrafine works then.

purge-wranglertbt-flashpurge-nvdaset-eGPU
Insights Into macOS Video Editing Performance

Master Threads:
2014 15-inch MacBook Pro 750M
2018 15-inch MacBook Pro

 
2019 13" MacBook Pro [8th,4C,U] + RX Vega 64 @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.14.6 & Win10 [build link]  


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member Moderator
Joined: 3 years ago
 

I chose AMD, this bootloader has finally got me past error 12 and I am running a 570 while I wait for my Vega to arrive! Massive thanks for this btw... best part fo a year trying to get AMD working in Bootcamp with the pesky 5K compounding the issue!

2017 13" MacBook Pro Touch Bar
GTX1060 + AKiTiO Thunder3 + Win10
GTX1070 + Sonnet Breakaway Box + Win10
GTX1070 + Razer Core V1 + Win10
Vega 56 + Razer Core V1 + macOS + Win10
Vega 56 + Mantiz Venus + macOS + W10

---

LG 5K Ultrafine flickering issue fix

 
2017 13" MacBook Pro [7th,2C,U] + RX 5700 XT @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.15.4 & Win10 2004 [build link]  


ReplyQuote
mac_editor
(@mac_editor)
Famed Member Moderator
Joined: 3 years ago
 

@eightarmedpet I saw your guide! Happy to hear things finally go your way. Enjoy the Vega 56. I have a 64 on the way too.

So when choosing AMD, essentially it does nothing on Thunderbolt 3 Macs, because on macOS AMD is supported natively (so the patch finds some set of characters and replaces it with the same set of characters = no changes at all). To verify this, you can remove items in the config.plist KextsToPatch section. The 5K issue is rooted somewhere else likely (maybe apple_set_os.efi IDK).

Also, thank you for testing even though you had a working setup before. Really appreciate it.

purge-wranglertbt-flashpurge-nvdaset-eGPU
Insights Into macOS Video Editing Performance

Master Threads:
2014 15-inch MacBook Pro 750M
2018 15-inch MacBook Pro

 
2019 13" MacBook Pro [8th,4C,U] + RX Vega 64 @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.14.6 & Win10 [build link]  


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member Moderator
Joined: 3 years ago
 

It's the least I could do.. without you guys I wouldn't have my AMD card working!
apple_set_os.efi could be the issue, it was before, but I never got passed error 12 previously.

Best I keep the previous version safe. I'll try a manual instal tomo or next week sometime and see what happens...

2017 13" MacBook Pro Touch Bar
GTX1060 + AKiTiO Thunder3 + Win10
GTX1070 + Sonnet Breakaway Box + Win10
GTX1070 + Razer Core V1 + Win10
Vega 56 + Razer Core V1 + macOS + Win10
Vega 56 + Mantiz Venus + macOS + W10

---

LG 5K Ultrafine flickering issue fix

 
2017 13" MacBook Pro [7th,2C,U] + RX 5700 XT @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.15.4 & Win10 2004 [build link]  


ReplyQuote
goalque
(@goalque)
Noble Member Admin
Joined: 4 years ago
 
Posted by: jya
Posted by: goalque

If you're using internal display ports of the MBP, you can't. The only way is to disconnect, and then iGPU is available (apple_set_os.efi + MuxSetting=1).

What do you mean by internal display ports?
This MBP isn't connected to anything. The only screen is the internal display. While the iGPU is indeed appearing as available once apple_set_os.efi is loaded with MuxSetting=1, it is non-functional. It appears in the Device Manager as working, but it isn't. See my earlier post with screen captures attached.

"under the System Information utility -> Graphic/Displays , both the internal display and the external display (an Apple TB display) are showing under the Radeon Pro 560X"

so I expected it was connected to the Apple TB display. I meant you shouldn't connect any display directly to the MBP, no matter whether you are on macOS or Windows. As to Windows, maybe you haven't installed Intel drivers?

automate-eGPU EFIapple_set_os.efi

Mid 2015 15-inch MacBook Pro eGPU Master Thread

 
2018 13" MacBook Pro [8th,4C,U] + Radeon VII @ 32Gbps-TB3 (ASUS XG Station Pro) + Win10 1809 [build link]  


ReplyQuote
 of  108