automate-eGPU EFI - eGPU boot manager for macOS and Windows
 
Notifications
Clear all

[Solved] automate-eGPU EFI - eGPU boot manager for macOS and Windows  

 of  121
  RSS

NavilleZhang
(@navillezhang)
Trusted Member
Joined: 3 years ago
 
Posted by: uchlee

Hi,
Somehow with this app, I can boot Mac OS X but not Windows 10. It just hung if I chose 'Load Windows'. It doesn't matter if my eGPU is connected or not. 🙁

I can boot Windows 10 if I bypass this app. But I have to hot plug the eGPU when dots are spinning, which I hope that this app would fix.

I had similar experience. It will take a while if the USB disk you are using is slow. I suggest turn on debug mode and wait patiently for a while. I had to wait several minutes once

RTX 2080Ti
2016 15' Macbook Pro with RP460
Akitio Node Pro


ReplyQuote
uchlee
(@uchlee)
Eminent Member
Joined: 5 years ago
 

@NavilleZhang, Thanks for the reply. How can I turn on the debug mode?

iMac Retina 4K, 21", Late 2015, Mojave, iGPU 6200
MBP Retina, 13", Early 2015, Mojave, iGPU 6100
Aorus Gaming Box GTX1080


ReplyQuote
goalque
(@goalque)
Noble Member Admin
Joined: 5 years ago
 
Posted by: mac_editor
Posted by: goalque

AFAIK, firmware/EFI updates are persistent. Once done, you can't go back.

This used to be possible.  https://forums.macrumors.com/threads/guide-how-to-get-back-old-efi-after-downgrade-from-yosemite.1803934/

And downloads up to the Mid-2014 MBP (2015's firmware are available) from Apple's website. As we know, we don't have the firmwares for the newer devices (unless someone dumped and saved them) but it would seem, technically, that it is possible. Anyhow, irrelevant here but worth noting Smile

Yes, used to be possible. Not anymore.

https://egpu.io/forums/mac-setup/automate-egpu-sh-is-reborn-with-amd-polaris-fiji-support-for-macos/paged/3/#post-6151

All EFI executables are available from macOS installation packages.

Apple removed the sentence ”macOS Internet Recovery (Option-Command-R) installs the version that originally came with your Mac”. A real factory reset (including the firmware) is not possible anymore.

https://egpu.io/forums/mac-setup/10-12-2-trying-to-downgrade-to-10-12-1/#post-701

automate-eGPU EFIapple_set_os.efi

Mid 2015 15-inch MacBook Pro eGPU Master Thread

 
2018 13" MacBook Pro [8th,4C,U] + Radeon VII @ 32Gbps-TB3 (ASUS XG Station Pro) + Win10 1809 [build link]  


ReplyQuote
uchlee
(@uchlee)
Eminent Member
Joined: 5 years ago
 
Posted by: uchlee

Somehow with this app, I can boot Mac OS X but not Windows 10. It just hung if I chose 'Load Windows'. It doesn't matter if my eGPU is connected or not. 🙁

I can boot Windows 10 if I bypass this app. But I have to hot plug the eGPU when dots are spinning, which I hope that this app would fix.

@goalque, Can you please advise me on this? I left it for 10 mins after choosing Windows but nothing changed.

iMac Retina 4K, 21", Late 2015, Mojave, iGPU 6200
MBP Retina, 13", Early 2015, Mojave, iGPU 6100
Aorus Gaming Box GTX1080


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Famed Member Moderator
Joined: 5 years ago
 

Been using this work around for a week now and its been perfect (the version prior to the auto USB build - I may start my own thread to try and discuss/work out whats changed and why it works differently on my set up). Can now boot in both macOS and Windows with EVERYTHING plugged in from the start, no hot plugging, no plugging my monitor in after boot, no standing on one foot, no winking at a magpie, it just works... thanks again guys, Vega arrived yesterday but haven't had time to swap it out, fingers crossed. Actually looking forward gaming in macOS as over 50% of my Steam Library is macOS.

Whats this I read about 10.14.1 breaking eGPU support? Is it just rEFInd based work arounds or?

2017 13" MacBook Pro Touch Bar
GTX1060 + AKiTiO Thunder3 + Win10
GTX1070 + Sonnet Breakaway Box + Win10
GTX1070 + Razer Core V1 + Win10
Vega 56 + Razer Core V1 + macOS + Win10
Vega 56 + Mantiz Venus + macOS + W10

---

LG 5K Ultrafine flickering issue fix

 
2018 Mac Mini [8th,6C,B] + RX 580 @ 32Gbps-TB3 (AKiTiO Node Lite) + Win10 20H2 [build link]  


ReplyQuote
NavilleZhang
(@navillezhang)
Trusted Member
Joined: 3 years ago
 
Posted by: uchlee
Posted by: uchlee

Somehow with this app, I can boot Mac OS X but not Windows 10. It just hung if I chose 'Load Windows'. It doesn't matter if my eGPU is connected or not. 🙁

I can boot Windows 10 if I bypass this app. But I have to hot plug the eGPU when dots are spinning, which I hope that this app would fix.

@goalque, Can you please advise me on this? I left it for 10 mins after choosing Windows but nothing changed.

Can you try debug mode and attach the log?

RTX 2080Ti
2016 15' Macbook Pro with RP460
Akitio Node Pro


ReplyQuote
uchlee
(@uchlee)
Eminent Member
Joined: 5 years ago
 
Posted by: uchlee

@NavilleZhang, Thanks for the reply. How can I turn on the debug mode?

I do not know how to turn on the debug mode and I searched it but failed to find it.

iMac Retina 4K, 21", Late 2015, Mojave, iGPU 6200
MBP Retina, 13", Early 2015, Mojave, iGPU 6100
Aorus Gaming Box GTX1080


ReplyQuote
NavilleZhang
(@navillezhang)
Trusted Member
Joined: 3 years ago
 
Posted by: uchlee
Posted by: uchlee

@NavilleZhang, Thanks for the reply. How can I turn on the debug mode?

I do not know how to turn on the debug mode and I searched it but failed to find it.

EFI/CLOVER/config.plist, there is something like

```

<key>Debug</key>
<false/>

```

change false to true and you are ready to go.
Try again booting, wait a while. Force reboot into macOS, the log should be called "debug.log" under EFI/CLOVER/misc/

RTX 2080Ti
2016 15' Macbook Pro with RP460
Akitio Node Pro


ReplyQuote
jya
 jya
(@jya)
Trusted Member
Joined: 4 years ago
 
Posted by: itsage

I updated my 2016 15" MacBook Pro to 10.14.2 beta. The new Boot ROM is 250.0.0.0.0. Nothing changed regarding eGPU Boot Camp and @goalque's EFI Boot Manager. The PCI Express x16 Controller - 1901 to Radeon Pro 450 dGPU has been disabled for a while now and I can still switch back and forth between Windows and macOS. It works well with only the Intel HD Graphics 530 iGPU driving the internal display.

I wonder if disabling the PCIe express bus rather than the 560X dGPU would get better result with the Intel, or if that would also lead to a dark screen under windows.
What do you think?

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
uchlee
(@uchlee)
Eminent Member
Joined: 5 years ago
 

@NavilleZhang, Here's the log file. Thanks,

iMac Retina 4K, 21", Late 2015, Mojave, iGPU 6200
MBP Retina, 13", Early 2015, Mojave, iGPU 6100
Aorus Gaming Box GTX1080


ReplyQuote
 of  121