[SCRIPT] automate-eGPU.sh v1.0.1 - macOS eGPU installation tool
 
Notifications
Clear all

[SCRIPT] automate-eGPU.sh v1.0.1 - macOS eGPU installation tool  

 of  32
  RSS

ikir
 ikir
(@ikir)
Prominent Member
Joined: 5 years ago
 

 

All ok here! Very happy!

 

Better result than my "old" GTX 780Ti from 42 to 48 fps in 4k

Schermata 2017 04 11 alle 20.42.01
Schermata 2017 04 11 alle 20.49.40


MacBook Pro 13" 2020 Touch Bar M1 8-core CPU 8-core GPU - 16GB unified memory - 512GB PCIe SSD
MacBook Pro 13" 2020 Touch Bar i7 quad-core 2.3Ghz - 16GB RAM - 1TB PCIe SSD

my awesome Radeon VII eGPU
my Mantiz Venus extreme mod with Sapphire Nitro+ RX Vega 64

 
2018 13" MacBook Pro [8th,4C,U] + Radeon VII @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.15 [build link]  


itsage liked
ReplyQuote
Inotna
(@inotna)
Eminent Member
Joined: 5 years ago
 

 

MacBook Pro 13" Touch Bar with 1060 6GB

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ikir and callil liked
ReplyQuote
greg
 greg
(@greg)
Active Member
Joined: 4 years ago
 

Not really working for me. MacBook Pro 2016 with touchbar. 1060 in Akitio Node. I successfully installed the forewarn update on boot camp windows, the automate-egpu script ran without a problem and installed the drivers, the system dialog shows the gtx 1060 similar to ikir's screenshot BUT the benchmarks suck. I am getting like 10 fps and a 400 score in the same benchmark you guys ran. The fan of the 1060 also wasn't spinning at all...

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
khrizer39
(@khrizer39)
New Member
Joined: 4 years ago
 

Hi guys, I was wondering why my MacBook pro 13 inch mid 2012 can't detect my ogpu setup, which is Evga 1060 alirio thunder2. It works flawlessly on Windows, but when it comes to MacOS, it only detects the video card as "display". I have the latest Nvidia drivers and Sierra 10.12.4. I have been reading the thread a lot but everything just seems not to be working in my case. I would appreciate any help.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

laszlogo liked
ReplyQuote
laszlogo
(@laszlogo)
Active Member
Joined: 4 years ago
 
Posted by: khrizer39

 

Hi guys, I was wondering why my MacBook pro 13 inch mid 2012 can't detect my ogpu setup, which is Evga 1060 alirio thunder2. It works flawlessly on Windows, but when it comes to MacOS, it only detects the video card as "display". I have the latest Nvidia drivers and Sierra 10.12.4. I have been reading the thread a lot but everything just seems not to be working in my case. I would appreciate any help.

   

I got the same issue! only with an Akitio Thunder3 and a gtx 1050 Ti SC, no luck so far 🙁

MacBook Pro 13 (2016) Touch Bar - i7 3,3Ghz - 8GB RAM - 256GB PCIe SSD
AKiTiO Thunder3 PCIe Box + 120W PSU
MSI Radeon RX 560 Aero ITX OC 4GB


ReplyQuote
khrizer39
(@khrizer39)
New Member
Joined: 4 years ago
 

As far as I know, you need to execute sudo ./automate-eGPU.sh -a once done with sudo ./automate-eGPU.sh 

That might work in your case but not on mine D:

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
netkas
(@netkas)
New Member
Joined: 4 years ago
 

About firmware downgrade, I would take a look here - Re: Nmp firmware updates might break egpu

in the past i was able to downgrade from b20 to b17 on nmp, however, once can downgrade only to previous version of fw. so from b20 only to b17, not to b16.

But it looks like apple blocked this with b21 for nmp, can't downgrade. I keep my nmp at b17 by updating it throw target disk mode using the mini.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

itsage liked
ReplyQuote
itsage
(@itsage)
Founder Admin
Joined: 5 years ago
 

 @netkas Thank you for your insights and workaround to prevent the force firmware update. Is Target Mode via an older Mac the only option? Would there be implications if that hosting Mac has a firmware update?

LinkedIn | Twitter | Facebook | Youtube | Instagram
 
external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2018 Mac Mini [8th,4C,B] + RX Vega 56 Nano @ 32Gbps-TB3 (Gigabyte Gaming Box) + macOS 12.0 & Win11 [build link]  


ReplyQuote
ficklepony
(@ficklepony)
Active Member
Joined: 4 years ago
 

Run the sudo ./automate-eGPU.sh and show

"Thunderbolt device is connected, but no external GPUs detected."

What's Problem? 

______________________

MacBook Pro 2016 Touchbar + AKiTiO Node + GTX1070

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Rapunzel
(@rapunzel)
Eminent Member
Joined: 4 years ago
 

Update regarding 10.12.5 Beta and RX 460 4GB with Thunder3:

  • works with acceleration using a Thunderbolt 1/2 Mac with Thunderbolt adapter
  • does not work with acceleration with Macbook Pro 2016 NTB with Thunderbolt 3 connection

 

I am lacking another adapter:

Could anyone try to use MBP-TB3-TB2-TB3-Thunder3 and report the results?

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
 of  32