Black screen on external monitor - Gigabyte Gaming box
 
Notifications
Clear all

Black screen on external monitor - Gigabyte Gaming box  

  RSS

kevin612
(@kevin612)
New Member
Joined: 11 months ago
 

Hi all,

My first post here.
I recently bought the Gigabyte Gaming Box RX580.
I tried both macbook pro 15" 2016 and mac mini 2012 (TB3->TB2 Adapter) , all HDMI and DP ports cannot make the external monitor works.
The macbook pro detect the box straightaway after plugged in
Mac Mini installed purge-wrangler and able to detect the box after installation  

What else do I need to do in order to make the external monitor works?
As I would like to output to 4k for photo editing  

Thanks everyone
Kevin

Mac mini 2012
- Intel Core i7 2.3Ghz
- 16GB RAM
- Sandisk 250GB SSD
Gigabyte Gaming Box RX 580
AOC U2790VQ 4k Monitor


ReplyQuote
kevin612
(@kevin612)
New Member
Joined: 11 months ago
 

Hi all,

Just realised that there is no activity running and I cannot use any software to force use eGPU.
Anyone can suggest any solution?
Should I clean install my Mac mini?

Thanks
Kevin

Mac mini 2012
- Intel Core i7 2.3Ghz
- 16GB RAM
- Sandisk 250GB SSD
Gigabyte Gaming Box RX 580
AOC U2790VQ 4k Monitor


ReplyQuote
Suwit Suriyasriwan
(@suwit_suriyasriwan)
Active Member
Joined: 9 months ago
 

Did macOS recognize your device well? if not try to update your firmware to the lastest first.

2018 15″ MacBook Pro i7-8850H/Radeon Pro 560X dGPU/16GB RAM/512GB SSD; RTX 2070 Super & ROG XG STATION 2

 
2018 15" MacBook Pro (RP560X) [8th,6C,H] + RTX 2070 Super @ 32Gbps-TB3 (ASUS XG Station 2) + Win10 [build link]  


ReplyQuote
PascalB
(@pascalb)
Active Member
Joined: 9 months ago
 

Did you try to connect your external monitor to the MB / Mac mini  instead of eGPU display port ?

iMac 27" i7 - mid 2013 (dGPU : NVIDIA GeForce GTX 780M 4 Go) with 2 TB1 ports - TB1 Port #2 : eGPU : Sonnet eGFX Breakaway Box 650 OC + Gibabyte Radeon VII - TB1 Port #1 : Akitio Thunder3 RAID Station + Akitio Thunder D3 with SSD inside - External display (NEC Spectraview 27" PW272W connected to Atikio Thunder3 RAID Station Display port (direct connection to eGPU Display port is not supported : black screen)

 
2013 27" iMac (GTX780M) [4th, 4C,] + Radeon VII @ 10Gbps-TB1>TB3 (Sonnet Breakaway 650) + macOS 10.15.1 [build link]  


ReplyQuote
yorkie
(@yorkie)
New Member
Joined: 9 months ago
 

@kevin612

had same thing with a razer core x after Mac update it was monitor that needed an update ,connect Mac to a tv or other monitor and download update for original monitor, that fixed it for me

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote