Can't Boot with eGPU attached on Mac Mini  

 

RianGray
(@riangray)
Active Member
Joined:1 year  ago
Posts: 9
April 26, 2018 12:59 pm  

I haven't had a chance to test this on other Macs, so I'm really open for all tries and errors here.
I'm not even sure if this is really a glitch or by design at this point. 

Whenever I boot up Mac mini (late 2014) with eGPU(TB2) attached, I don't get nothing on my displays, no signals nothing.
I've checked both Mac Mini's and eGPU's HDMI output, but it appears neither of them have it.
Only thing I've noticed was that it chimes twice as it boots; I'm guessing it reboots itself.
I've checked the kernel panic logs, but there were none stored (/Library/Logs/DiagnosticReports). 

My remedy at this point is to boot it up without eGPU, (so HDMI connected to mini)
and then connect the eGPU and switch the display over as well.

Is this how it's supposed to be on all Macs? If not, any suggestions?


ReplyQuote
jazzyy
(@jazzyy)
Eminent Member
Joined:9 months  ago
Posts: 20
May 13, 2018 5:37 pm  

This has also been my experience with a TB3 enclouser (Aorus Gaming Box 1070) over TB3<->TB2 adapter to my Macbook Pro Retina Early 2015 (i7 variant). I mostly tried Bootcamp and was able to hotplug during/a second before boot and that worked fine on 8.1/10. However, I've only tried macOS with latest build + the nvidia and tb2 enabler script here and that was fairly plug and play once booted, but you can't leave it plugged in on boot.

It seems like the macOS firmware disables the iGPU when there is an eGPU attached?

Early 2015 13" Macbook Pro + GTX1070@16Gbps-TB2 (Aorus Gaming Box via TB3 to TB2 adapter) + Win10
2016 15" Thinkpad P50 M1000M + GTX1070@32Gbps-TB3 (Aorus Gaming Box) + Win10
2018 14" Thinkpad T480s + GTX1070@16Gbps-TB3 (Aorus Gaming Box) + Win10 [jazzyy]


ReplyQuote