Notifications
Clear all

Clamshell mode & bootcamp?  

  RSS

dinosaysrawr
(@dinosaysrawr)
Active Member
Joined: 2 years ago
 

Hi all, I just got my 1080 and sonnet 550w, and I'm having some issues with my setup.

I have: 2017 MBP 15" with radeon 560 (10.13.5 & bootcamp), Sonnet Breakaway Box 550+ GTX1080, Samsung 4k monitor connected to 1080.

I ran fr34k's script, and it seems to have installed fine.

Issues on the macOS side:
I followed these steps to get 1080 to power my external monitor: boot without egpu, plug in egpu without monitor, log out, plug in monitor, sign in. This leads to my 1080 powering my external monitor (verified by running Heaven benchmark), but the internal monitor of my MacBook Pro is completely black. Ideally, I would use my mac in clamshell mode with my external monitor powered by 1080 as my only screen, can anyone tell me how I can achieve this?

Issues on the Bootcamp side:
Because I have the 2017 15" mbp, 1080 worked as hot plug. However, I can't change the resolution of the external monitor to 4k (stuck at internal monitor's resolution even when not duplicating), and I can't go into clamshell mode without having the mbp going to sleep and kernel panic-ing. Does anyone have a solution to use bootcamp in clamshell mode with egpu setup?

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
LeoLeal
(@leoleal)
Eminent Member
Joined: 3 years ago
 

For windows It is easy: Press WIN+P and select Only Secondary Display and configure in "power options" the "close the lid" action to do nothing. There you go. Clamshell on Windows with internal display out of the game.

For MacOS. Im having a different problem. Clamshell wont turn the internal display off. I dont know how to solve It.
Windows support for eGPUs seems far better. Even Hot Unplug works for me on Windows.

Macbook Pro Late 2013 (dGPU GT 750m) + Akitio Thunder 2 + GTX 970


ReplyQuote
Gnim
 Gnim
(@gnim)
Active Member
Joined: 2 years ago
 
Posted by: LeoLeal

For windows It is easy: Press WIN+P and select Only Secondary Display and configure in "power options" the "close the lid" action to do nothing. There you go. Clamshell on Windows with internal display out of the game.

For MacOS. Im having a different problem. Clamshell wont turn the internal display off. I dont know how to solve It.
Windows support for eGPUs seems far better. Even Hot Unplug works for me on Windows.

I got exactly the same problem! It seems the 3 video cards are conflicting with each other.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote