Setup & Software Discussions
Dual Rx480 on nMP
 

Dual Rx480 on nMP  

  RSS

exam23
(@exam23)
Trusted Member
Joined: 2 years ago
 

I am seeking for some user experience for I have been using the dual rx480 setup for several weeks now.  

 

1.) How often do you guys encounter MAC Lockup, where you have to perform a hard reboot?

2.) Is hard reboot/lock-up part of the eGPU user experience?

3.) If not, can someone please provide some guidance?

 

Overall, the system runs fine.  Just some little quirks here and there.  

My main purpose is to use it for FCPX, which has been GREAT as far.  Other than the Lock-up/hard reboot.

 

Thank you in advance!

 

Best,

 

Exam23

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
itsage
(@itsage)
Famed Member Admin
Joined: 3 years ago
 

I recently acquired a nMP and will add an eGPU to it so that I can cover more bases. I remember you mentioned your two AKiTiO Thunder2 enclosures are powered by one PSU. Is this still the case? If so, I would try powering these enclosures with separate power supplies.

When I was running the AKiTiO Thunder2 RX 470 eGPU with a Mac mini, things were working smoothly without issues. It stayed on for almost 10 days when I moved onto to another project.

Best ultrabooks for eGPU use

eGPU enclosure buying guide

109 external GPU build guides


ReplyQuote
exam23
(@exam23)
Trusted Member
Joined: 2 years ago
 

Thank you, I must ask.  My PSU is 1000w.  Do you believe I should power two separate PSU?

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
itsage
(@itsage)
Famed Member Admin
Joined: 3 years ago
 

I don't think your setup lacks power. It's the fluctuations in terms of power delivery to the enclosures and GPUs that's the culprit. I've seen one Mac Pro tower user who powered his RX 480 with an external PSU instead of the internal one. He had random freezes all the time until he switched to using the internal PSU.

Best ultrabooks for eGPU use

eGPU enclosure buying guide

109 external GPU build guides


ReplyQuote
exam23
(@exam23)
Trusted Member
Joined: 2 years ago
 

It's crazy, but I believe I found the issue.  Actually, stumble upon the solution.  It sounds crazy, but it was caused by one of the extensions in Safari...  I turned off a majority of the extensions, and it is fine as of current.  I will keep you posted.  Thanks!

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


itsage liked
ReplyQuote
exam23
(@exam23)
Trusted Member
Joined: 2 years ago
 

It was just wishful thinking....  I ran one of the rx480 by itself and it seems to still have the issue.  Something in my system doesnt like the rx480 setup. i just can't pin point.   Anyone know if I may be able to just perform a clean install and get a fresh start, but if it doesnt work out.  Can i just use timemachine to restore back to where I am currently?

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
mac_editor
(@mac_editor)
Noble Member Moderator
Joined: 2 years ago
 

If you're talking about running one RX 480 setup and are experiencing a freezing issue - I have noticed the following observations about them on my build:

- They don't occur on macOS.

- When they do occur in Windows, the card was under heavy load or overclocked - AMD WattMan restores settings automatically and notifies on next boot into Windows - saying an "unknown error" occurred.

I know you are using macOS, but is it possible that heat is an issue? When do these freezes occur? Under heavy load only?

purge-wrangler.shpurge-nvda.shset-eGPU.shautomate-eGPU EFI Installer
----
Troubleshooting eGPUs on macOS
Command Line Swiss Knife
eGPU Hardware Chart
Multiple Build Guides
----
Current: MacBook Pro RP560X + 480/R9 Fury/Vega 64 | GTX 780/1070
Previous: 2014 MacBook Pro 750M + 480/R9 Fury | GTX 780/980 Ti/1070


ReplyQuote
exam23
(@exam23)
Trusted Member
Joined: 2 years ago
 

It's just sporadic. Like you have mentioned, I am only in macOS.  It definitely happens when I have iMessage on.  I do not believe its a heat issue. To share full transparency, the way this MacPro was setup was thru a system migration and not a completely clean install.  While this shouldn't really matter, it seems to have had some connectivity issues from day 1, example.  Not being able to use google remote desktop.  

But this latest eGPU thing has gotten me completely stumbled.  

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
itsage
(@itsage)
Famed Member Admin
Joined: 3 years ago
 

@exam23 I remember you mentioned the CPU was upgraded to a 12-core. What was the origin of that CPU? I've done plenty of CPU upgrades on Mac Pros and while it's rare, the CPU may be the culprit if your system hasn't been reliable.

Best ultrabooks for eGPU use

eGPU enclosure buying guide

109 external GPU build guides


ReplyQuote
exam23
(@exam23)
Trusted Member
Joined: 2 years ago
 

It was an upgrade, but it has been super reliable up to the eGPU project.  As for the Google remote desktop, I know for a fact it's my settings.  LOL  I switched out with someone else internal SSD just to try.  

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
itsage
(@itsage)
Famed Member Admin
Joined: 3 years ago
 

Gotcha. The last resort is a clean macOS install if you determine it's a software issue. As long as you have an up-to-date Time Machine backup you can do a full restore later.

Best ultrabooks for eGPU use

eGPU enclosure buying guide

109 external GPU build guides


ReplyQuote
exam23
(@exam23)
Trusted Member
Joined: 2 years ago
 

Perfect, that is what I needed to confirm...  

 

I will ensure a full back up and go from scratch.  And if it doesn't work out, then I will just return it back to the original state. Thank you...

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
exam23
(@exam23)
Trusted Member
Joined: 2 years ago
 

Question, have you ever had 2-amd egpu and a gtx egpu running at the same time?   I am thinking if I am gonna go full load on a clean install.  

Thoughts? 

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
exam23
(@exam23)
Trusted Member
Joined: 2 years ago
 

Clean install did the trick...  Thanks!

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote