Early performance results of RX Vega 64 on 2017 MacBook Pro 15  

  RSS

Edwardcrow
(@edwardcrow)
New Member
Joined: 2 years  ago
Posts: 2
September 30, 2017 6:34 am  

Hi Everyone. With the High Sierra been launched earlier this week, I've finally got the chance test the performance of this eGPU setup. As for my setup, I'm currently using the Sapphire RX Vega 64 on the 2017 MacBook Pro 15 (with Redeon Pro 560) though Akitio Node. With the, early but official, support of eGPU on High Sierra, we are getting lots of ex citing features like hot-plug. I will show my test result along with some problems I encountered. Hope this is helpful.

1. Geekbench 4

On geekbench, and most other applications, the RX Vega was recognized as the Vega10 Prototype, but the results are good.

 

I'm getting 139036 on the geekbench OpenCL test whereas the integrated Radeon Pro 560 scores 43065, and probably due to the immature driver support for the Vega, we are still losing some performance compare to the theoretical results.

 

2. Final Cut Pro X

The first thing I want to mention is that Final Cut Pro X itself has some problem running in High Sierra even without the eGPU and I'm still waiting for the software update. One of the problem is that Final Cut Pro X crashes immediately running in clamshell mode. I was little worried before using the eGPU for Final Cut but the result is actually lot better than I expected. Although I didn't have the time to run tests like BruceX or some kind and give you guys a specific time difference, but I noticed a significant speed boost with the RX Vega plugged in. Both rendering and exporting did run lot faster without any issues as far as I could notice. I will keep posted for any future changes but as for now, I am more than happy with the result.

Updated:

By installing SwitchResX and disable the internal display manually, I am able to get Final Cut Pro X working, similarly, in clamshell mode. However, some other apps don't work that well in this method. 

 

3. Unreal 4 

One of the biggest announcement from the High Sierra event was the full support of Unreal 4 engine and VR headset. As I'm working in a VR company and most of the works require using Unreal 4, I figured I should run some testing with the Unreal engine. Unfortunately, both 4.17 and 4.18 preview, which will support Mac with eGPU setup according to Epic, crashed upon opening up the scene. And not just normal crash, it caused my Akitio node completely shut down. I don't know if the Unreal 4 engine or the PSU inside Node caused this shut down, but believe it is more of a unsupported driver problem than a hardware one.

4.Other applications

By the moment I post this thread, there are some minor issues like twisted wallpapers and some temporary freeze on the system, but mostly the system runs stable and it's okay for normal everyday works. By disabling the internal display with the switchResX, I successfully run my setup in a clamshell mode and, once again, no critical issues for now. 

 

5.What to expect next

Although the system works okay with the RX Vega, I'm definitely dying for some upcoming driver updates since I didn't get the RX Vega just for web browsing and dealing with emails. Pro apps' could vary from different situations, some could gain improvements from this setup, some may be completely unusable. I will be updating this thread as I get more results from my setup.

 


ReplyQuote
BMW2017
(@bmw2017)
Eminent Member
Joined: 1 year  ago
Posts: 25
October 2, 2017 6:20 pm  

I got this with the RX 580, Mantiz, and '16 MBP 15" Touch Bar... 


Edwardcrow liked
ReplyQuote
theitsage
(@itsage)
Famed Member Admin
Joined: 2 years  ago
Posts: 2899
October 2, 2017 6:53 pm  

The PSU inside the AKiTiO Node is not sufficient to handle the RX Vega series. The system crashes are likely due to power spikes. When I tried the RX Vega 56 with a Mac Pro tower, I noticed system crashes as well when I ran benchmarks.

Best ultrabooks for eGPU use

eGPU enclosure buying guide

74 external GPU build guides


Edwardcrow and Sky11 liked
ReplyQuote
Sky11
(@sky11)
Reputable Member
Joined: 2 years  ago
Posts: 309
October 2, 2017 7:24 pm  

You definitely need much beefier power supply. Single 12V rail, high maximum current on +12V rail


Edwardcrow and theitsage liked
ReplyQuote
Edwardcrow
(@edwardcrow)
New Member
Joined: 2 years  ago
Posts: 2
October 18, 2017 2:12 am  

Thanks guys! Since the Unreal 4 in macOS is basically unusable at the moment, I've installed Windows 10 in Boot Camp and had the same crashing problem. I figured it could be the PSU bottlenecking the system so I've already ordered the Corsair SF450 power supply and hopefully it will work. Otherwise, with the Wattman set to power-save, Unreal 4 works pretty well. 


ReplyQuote
ikir
 ikir
(@ikir)
Prominent Member
Joined: 2 years  ago
Posts: 751
October 18, 2017 6:22 am  

My RX Vega 56 is working great inside Mantiz Venus, naturally with all the software issue due to immature beta drivers

eGPU.it | LG 34" 4K 34UC88 curved ultrawide display
MacBook Pro 2018 Touch Bar i7 quad-core 2.7Ghz - 16GB RAM - 512GB PCIe SSD --> my Mantiz Venus extreme mod with Sapphire Nitro+ RX Vega 64


ReplyQuote
mois
 mois
(@mois)
Trusted Member
Joined: 7 months  ago
Posts: 70
August 4, 2018 5:53 pm  

(@theitsage subsequently got a second PSU for the XG Station Pro, equivalent with the first one, and then a special Y cable made by Asus, and that made the Vega 64 work. https://egpu.io/forums/builds/2018-hp-spectre-13-radeon-vega-fe32gbps-tb3-asus-xg-station-pro-win10-1803-theitsage/ )


ReplyQuote