[Solved] egpu eject no longer works  

  RSS

(@gavin_sun)
New Member
Joined: 4 weeks ago
Posts: 1
May 22, 2019 10:39 am  

Setup: MBP 13 late 2013, macOS Mojave 10.14.6 Beta (18G29g), Razer Core X, RX590 Sapphire Nitro+, connected with TB2>TB3 adapter

Problem started after update of OS and reinstallation of purge-wrangler

On the GUI side the symbol is just permanently frozen into place regardless of the presence of egpus, un-interactable

In terminal "SafeEjectGPU Eject" throws an error starting with:

2019-05-22 12:24:32.331 SafeEjectGPU[1854:57202] -[BronzeMtlDevice location]: unrecognized selector sent to instance 0x10c507000
2019-05-22 12:24:32.332 SafeEjectGPU[1854:57202] *** Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '-[BronzeMtlDevice location]: unrecognized selector sent to instance 0x10c507000'

purge-wrangler has always worked on previous macOS beta builds

I know I'm running beta OS but maybe someone has seen similar behaviour? 

MBP 13 late 2013, Razer Core X, RX590 Sapphire Nitro+


ReplyQuote
theitsage
(@itsage)
Famed Member Admin
Joined: 3 years ago
Posts: 4000
May 22, 2019 12:07 pm  

It's a bug in 10.14.6 Beta (18G29g).

Best ultrabooks for eGPU use

eGPU enclosure buying guide

94 external GPU build guides


Gavin sun liked
ReplyQuote