Setup & Software Discussions
eGPU suddenly doesn't work on Mojave
 

[Solved] eGPU suddenly doesn't work on Mojave  

  RSS

Espionage724
(@espionage724)
Active Member
Joined: 1 month ago
 

Edit: Solved seemingly after I rebuilt kext cache and rebooted, although I'm not sure why that would have been the problem.

Specs in signature are up-to-date. I had this eGPU set-up for about 2 days now; out-the-box it worked fine with macOS with automate EGPU EFI. Did some macOS and Linux reinstalls, and on maybe the 2nd or 3rd macOS reinstall, the eGPU doesn't work anymore.

Works fine from Linux with a quick LiveUSB boot though, and both the eGPU and GPU power on still. I tried automate eGPU EFI via manual install and script install, both from a USB and SD card. I've cleared PRAM and NVRAM. macOS is up-to-date. I've tried both TB2 ports on both the eGPU and MacBook.

Under system info, the RX 580 shows up under PCI. Neither it nor my external display (connected to the GPU) show up under Graphics/Displays. The Thunder2 eGPU shows up under Thunderbolt, shows firmware versions for both the cable and enclosure, and shows that it's connected (upstream, 20 Gb/s 1x).

My previous macOS installs were from Internet Recovery (latest supported macOS version), always with a freshly-wiped SSD (hdparm/blkdiscard). This time, I installed from a backup HDD (made with createinstallmedia from 10.14.6 downloaded from the App Store). Nothing about the installer when booted looked any different though.

The only difference I think I notice is that briefly after selecting the boot for automate EGPU EFI, there's several lines of text shown that flashes on the screen before displaying the main menu; I don't recall seeing all of that text before, but could be mistaken. I visually can't see it before it disappears, and I'm doubtful I can capture it on a camera even in slow-mo before the autofocus can focus since it happens so fast.

This topic was modified 1 month ago

MacBook Pro (Retina, 13-inch, Mid 2014)
AKiTiO Thunder2
XFX Radeon RX 580
macOS Mojave 10.14.6
Fedora Workstation 30


ReplyQuote