Setup & Software Discussions
eGPU + USB Audio woes
 

eGPU + USB Audio woes  

  RSS

elan
 elan
(@elan)
New Member
Joined: 1 week ago
Posts: 1
Jun 10, 2019 8:44 pm  

Mac Mini late 2018
eGPU: BlackMagic eGPU Pro
Version: 10.14.5 (but also tried in beta 10.15)
DAC: Tried various, but mostly Cambridge Audio DACMagic 100

When the eGPU is being used, the USB sound engine is reset every few minutes, resulting in an audio dropout. Example logs:

default 09:01:46.518108 -1000 kernel USB Sound assertion (Resetting engine due to error returned in Write Handler) in /BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleUSBAudio/AppleUSBAudio-315.6/AppleUSBAudioDevice.cpp at line 6520
default 09:03:06.124181 -1000 kernel USB Sound assertion (Frame Difference is greated than expected) in /BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleUSBAudio/AppleUSBAudio-315.6/AppleUSBAudioStream.cpp at line 5208
default 09:03:06.321054 -1000 kernel USB Sound assertion (Resetting engine due to error returned in Write Handler) in /BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleUSBAudio/AppleUSBAudio-315.6/AppleUSBAudioDevice.cpp at line 6520
default 09:03:06.321067 -1000 kernel USB Sound assertion (Resetting engine due to error returned to Feedback) in /BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleUSBAudio/AppleUSBAudio-315.6/AppleUSBAudioDevice.cpp at line 6528

I've tried different USB cables, different USB ports, and plugging the USB DAC into:

- Internal USB port.
- eGPU USB port.
- Totally separate MiniDock's USB on separate Thunderbolt bus.

None of this seems to make a difference.

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
Topic Tags