Having trouble getting my eGPU to Macbook pro
 
Notifications
Clear all

Having trouble getting my eGPU to Macbook pro  

  RSS

Ning Zhao
(@ning_zhao)
New Member
Joined: 1 month ago
 

Hey guys, please help!

I have a 2017 Macbook pro and  OS is Big Sur 11.3.1 .

I just bought the Node TiTan eGPU and put in a Sappire Pluse Radeon RX 580 2048sp graphics card in the eGPU 

Whenever I plug it in there is no egpu icon appears at the top right corner of my screen .

There is the issue picture link : https://ibb.co/wcm2SvB

The eGPU is not appearing in the activity monitor

 

Can someone please help me get the eGPU working?

Thank you!

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Eightarmedpet
(@eightarmedpet)
Famed Member Moderator
Joined: 4 years ago
 

Very odd. 
this is a plug and play combo so I’m wondering if there is a hardware or install issue. 
have you tested the card in a pc?

can you upload pics of how it’s installed?

2017 13" MacBook Pro Touch Bar
GTX1060 + AKiTiO Thunder3 + Win10
GTX1070 + Sonnet Breakaway Box + Win10
GTX1070 + Razer Core V1 + Win10
Vega 56 + Razer Core V1 + macOS + Win10
Vega 56 + Mantiz Venus + macOS + W10

---

LG 5K Ultrafine flickering issue fix

 
2018 Mac Mini [8th,6C,B] + RX 580 @ 32Gbps-TB3 (AKiTiO Node Lite) + Win10 20H2 [build link]  


ReplyQuote
Ning Zhao
(@ning_zhao)
New Member
Joined: 1 month ago
 

Thank you for your help!

Ye, that is confusing .This is an used graphics card ,so I did not test on my pc . I will try to test this graphics card on my pc.

There are some installtion pic : https://ibb.co/FsPXvL9    , https://ibb.co/q1hCyr3

Best Regards

Ning

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote