[HELP] eGPU not detected on two Macbooks.
 
Notifications
Clear all

[HELP] eGPU not detected on two Macbooks.  

  RSS

Raysquingini
(@raysquingini)
New Member
Joined: 5 months ago
 

Good afternoon everyone,

I apologize if this is in the wrong spot, but I’m an first time user and desperate at the moment. 

Im having a problem with a new eGPU set up I just got. I'm using:

\- MSI Radeon RX 570

\- Akitio Node

I first tried it out on my 2015 13' MacBook Pro (Catalina, i5, 8gb Ram) after installing all the necessary patches and workarounds. The purge-wrangler installer detected my card, and after that the GPU icon would appear in my toolbar but it would be grayed out and say "No Removable GPU". After that the icon disappeared from the toolbar. I checked system info and it listed the Akitio Node under the Thunderbolt section but NOT the card itself.

After multiple reinstalls and messing with settings, even downgrading from Catalina to Mojave (with the same problems appearing), I tried to use the set up on my other computer, a MacBook Air 2019 (Catalina, i5, 8gb ram as well).

Unfortunately, the same things happen. I plug it in through TB3, the icon appears in the tool bar and then it disappears after letting me know "No Removable GPU".

What I don't understand is the box is powering on just fine, and the fans on the GPU are spinning. On top of that, when I disconnect from both computers, I'll get the message that says I incorrectly unplugged the GPU.

I tried to find some help on different forums but couldn't find any concrete answers. I'd appreciate any suggestions that could help me out.

(Yes, I’m now aware I should have looked at the buying guide but I live in Japan and most of these options are outside my price range regardless. An still hoping to salvage what I have). 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
fatninja
(@fatninja)
New Member
Joined: 4 weeks ago
 

Hi, 

Same problem here. Did you find a solution . I would greatly appreciate any leads. 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote