[help] Razer Core X suddenly crashed and is no longer working - mac / Vega 64
 
Notifications
Clear all

[help] Razer Core X suddenly crashed and is no longer working - mac / Vega 64  

  RSS

home-grown-honkers
(@home-grown-honkers)
New Member
Joined: 2 months ago
 

Hello egpu.io community!

Just this morning I was using my egpu with an external monitor and my macbook closed, and I was in a google hangout when all of a sudden the screen went blank and I heard the audio coming out of my MacBook. I opened the lid to see the "egpu not disconnected properly" message.

Now I can't seem to get anything to work except power over the thunderbolt cable from the egpu enclosure. The lights aren't working, the gpu doesn't even look like it's receiving power, the fan isn't on, and non of the usb peripherals I have plugged in are working. I've contacted both apple and razer support, but none of their solutions have worked.

Additionally, the egpu also doesn't work when I boot in windows via bootcamp. Apart from this, for the last year I've been using this egpu with zero issues both in Mac and windows.

Here's what I've tried so far:

  • reset SMC / NVRAM
  • Swap thunderbolt cables
  • Power cycling both MacBook and egpu
  • Reseat the gpu
  • unplug all cables and plug back in
  • I've even tried different outlets

 

And here's some more info about my setup:

  • Razer Core X Chroma enclosure
  • 2019 MacBook Pro 13 inch, 4 thunderbolt ports, 2.4 gHz quad core i5
  • macOS Big Sur 11.0.1 (I upgraded two weeks ago and haven't had any issues until now)
  • Radeon Vega 64 gpu

 

Any help is appreciated! Thanks!

This topic was modified 2 months ago

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
home-grown-honkers
(@home-grown-honkers)
New Member
Joined: 2 months ago
 

Update: I've tried swapping the power supply, but that didn't solve it. I also have tried it with a couple other TB3 egpu capable computers, and I get the exact same results. 

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote