Help! The external display connected to the e-GPU can not be recognized
 
Notifications
Clear all

Help! The external display connected to the e-GPU can not be recognized  

  RSS

Chenlin Lu
(@chenlin_lu)
Active Member
Joined: 4 months ago
 

Following the detailed walkthrough offered by @ritero, I successfully built the e-GPU for bootcamp win10 1909. While I got a problem in macOS (Catalina, 10.15.4), as in most of the macOS builds my 5700xt can "plug and play" but the external display connected to the e-GPU can not be recognized. If I connect it to anther TB port through an adapter, it works fine. Could anybody offer some advice? Thanks in advance. By the  way, I used set-eGPU script to set all the applications prefer to use e-GPU.

2016 15" MacBook Pro (RP455) (6th,4C,H) + RX 5700 XT @ 32Gbps-TB3 (Razer Core X Chroma) + macOS 10.15.4 & Win10 1909


ReplyQuote
Brodlum
(@brodlum)
Active Member
Joined: 4 months ago
 

Same issue here, I think. If you wait until after logging in, then plug the eGPU in WITHOUT displays connected to it, then wait 10 seconds and plug in the displays, does it work for you? Also, which RX 5700 XT? I'm using a PowerColor dual fan RX 5700 XT. I see a few other people with issues on 10.15.4 and RX 5700 XTs and I'm trying to work out the common factor, as some people have it working.

 

I also ran set-eGPU. Did you change any of your boot security settings?

Mac mini 2018, [email protected], 1TB, 32GB. Razer Core X w/ AMD RX 5700 XT


ReplyQuote
Chenlin Lu
(@chenlin_lu)
Active Member
Joined: 4 months ago
 

@brodlum, Hi, I  am using ASUS ROG Strix RX5700 XT 8G.  I followed the steps you suggested and it didn't work. After connecting  the external display, I pressed the "Option" in display panel and click the "detect" and nothing happened. My exact macOS version is 10.15.4 (19E287).

 

No, I changed nothing in my boot security settings.

 

 

 

This post was modified 3 months ago

2016 15" MacBook Pro (RP455) (6th,4C,H) + RX 5700 XT @ 32Gbps-TB3 (Razer Core X Chroma) + macOS 10.15.4 & Win10 1909


ReplyQuote