HP Omen Accelerator GTX970 won't boot/connect - Macbook Pro 2015  

 

keesdev
(@keesdev)
New Member
Joined:3 months  ago
Posts: 4
May 15, 2018 8:44 pm  

Hi!

I've been watching this forum for a while now and finally decided to buy my own eGPU: the OMEN by HP Accelerator Shell.
According to HP this eGPU box works perfectly fine with the GTX970: that's why I went for this GPU.

I want to connect this beauty (or beast) to my Macbook Pro 2015 (13 inch) with an original (and new) Apple Thunderbolt 2 kabel (2 meters) and an original (and also new) Apple Thunderbolt 2 to 3 adapter, but the Omen wont buzz. What's going wrong here?

In the first place I want to use this setup on Bootcamp with Windows 10. I've followed the setup guide of HP:
https://support.hp.com/us-en/document/c05573720 or www.hp.com/go/OMENGA1-10
I installed:
- the latest Intel Thunderbolt Controller Driver which is (after installing and rebooting) telling me that 'there are no Thunderbolt ports available/found';
- the OMEN Accelerator - Realtek LAN Driver;
- the GTX970 GPU driver of the NVIDIA support page: can't install: no GPU detected;
- the Omen Accelerator app: doesn't open/start after installing and rebooting. Double click doesn't do anything. Weird;
- the firmware is downloaded, but can't be installed (obviously).
None of the installations - except for the NVIDIA driver - gives a warning during install.

Because this didn't work and I really want to use this eGPU anyhow, I decided to try the options listed on this forum:
1.  https://egpu.io/forums/mac-setup/wip-nvidia-egpu-support-for-high-sierra/
Problems: After installing step 3. (the webdriver.sh) my Macbook didn't boot. It was stuck at the Apple logo. Via the Recovery Mode and the Terminal I managed to delete all the .kext files in /Volume/Mac/System/Library/Extensions/GeF*.* and /Volume/Mac/Library/Extensions/GeF*.* + NVDA*.*
After these steps my Macbook booted again - pfiew.
Source:  https://www.tonymacx86.com/threads/fix-for-failure-nvidia-web-driver-on-high-sierra-black-screen-panics.234390/

2. I also tried the automated script of @fr34k at https://egpu.io/forums/mac-setup/script-fr34ks-macos-egpu-sh-one-script-all-solutions-fully-automated/
Disabled SIP and executed the bash file. Worked like a charm - I thought. After a reboot a pretty NVIDIA logo (eye) showed up at the top of my screen. But still no connection possible with my Omen. CUDA drivers were not installed: no GPU was found (CUDA said in the 'System Preferences > CUDA' window).
I read I might try to add '--uninstall' behind the bash command, reboot and try it again. This time the script asked to connect the eGPU, which it didn't before. Connected it, but no (e)GPU found. Damn it.

3. @mac_editor also made a script:  https://egpu.io/forums/mac-setup/script-enable-egpu-on-tb1-2-macs-on-macos-10-13-4/
Still no luck. Off course I firstly uninstalled the script of @fr34k

The Omen does not boot/show up or even light up. The logo should be red when booted/activated, but it doesn't do anything.
- Plugging in when Mac is shutdown and boot: nothing;
- Plugging in at Apple logo: nothing;
- Plugging in at login screen: nothing;
- Plugging in when fully booted: nothing.

Any help? Maybe I should get rid of this Omen beast and get an Akitio, Sonnet or something else? I just want to play a game in Windows (Bootcamp or virtually loaded in MacOS if that's even possible - Bootcamp has my preference).

13" Macbook Pro 2015 ft. i5 // 16GB // 512SSD
HP Omen Accelerator ft. MSI GTX970 4GB GDDR5 OC


ReplyQuote
keesdev
(@keesdev)
New Member
Joined:3 months  ago
Posts: 4
May 16, 2018 8:13 am  

I will try to get a Windows notebook today with a TB3 (USB-C) connection to test the whole shell and its GPU. Maybe there is something wrong here.
I could try to update its firmware.
The downside of the Omen is that it doesn't have a power button and automatically boots when it detects a compatible note-/macbook.

-- update --
I have tested this shell with an Acer i3 notebook with Windows, installed the software HP requests to do and connected the shell via the original TB3/USB-C cable, but nothing happens. I was not sure this type of notebook has TB3 compatibility in its USB-C connector. 
Therefore, I tried an Acer Nitro with (I hope) TB3, but still without luck.
I could try to search for a notebook with an actual (100% sure) TB3 connector. A friend of mine has the Macbook Pro 2016/2017 with TB3.

I also contacted HP about this issue, they state: "The OMEN by HP Accelerator needs an actual TB3 connection to kick in. TB2 does not give enough power/throughput for this shell to detect and power on." - such a shame HP.

13" Macbook Pro 2015 ft. i5 // 16GB // 512SSD
HP Omen Accelerator ft. MSI GTX970 4GB GDDR5 OC


ReplyQuote
4chip4
(@4chip4)
Estimable Member
Joined:1 year  ago
Posts: 195
May 16, 2018 12:51 pm  

FWIW TB2 seems to be a hit-and-miss (especially given some of the recent High Sierra updates), and NVidia already is the path less taken on eGPU Macs, which is why your combination is unfortunately firmly in "hack your way" land, regardless of the TB3 enclosure used. Other messages on the forum indicate that some people have gotten it to work, but it's far from plug and play, and definitely not something that will likely ever be officially supported. The Accelerator does support the GTX970, but enclosures are really just adapters in this context - the heavy lifting still needs to be done on the host laptop/OS/driver side.

The laptops that have TB3 USB-C ports should have a little lightning next to them, though manufacturers are pretty inconsistent in this regard (sometimes similar markings appear on always-on/charging USB ports). Also note that in some cases only *some* of the USB-C ports are TB3 ports.

2017 HP Spectre x360 15 i7-8550U GTX150 + GTX970@16Gbps-TB3 (HP Omen Accelerator) + Oculus Rift + Win10 [no guide]
HP Omen Accelerator Thunderbolt 3 enclosure legs stand removal walkthrough
Employed by HP, but my posts and opinions expressed on this forum are my own.


keesdev and theitsage liked
ReplyQuote