HP Omen and AMD RX580 and 2015 MacBook Pro
 
Notifications
Clear all

HP Omen and AMD RX580 and 2015 MacBook Pro  

  RSS

kamil6x
(@kamil6x)
New Member
Joined: 1 year ago
 

I have verified the HP Omen with AMD card work when hooked up to a 2018 Macbook Pro and a 2019 Mac Mini.  However with my 2015 Macbook pro and TB3-TB2 Apple cable, the card is not energized / activated.  The TB3/2 cable has been tested with hooking up the 2015 Macbook Pro in Thunderbolt drive slave mode to both the 2018 Macbook Pro and 2019 Mac Mini.  So all the cables work fine, the HP Omen and AMD card.  The only thing left is the software configuration on the mac with Mojave and the Egpu EFI was used after purge wrangler had also no effect.

Any suggestions?

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
RumianePoliczki
(@rumianepoliczki)
New Member
Joined: 2 years ago
 

I've had the same problem - exactly the same computer, GPU and enclosure. Simply put: TB2 doesn't kick HP Omen to work. If you have spare ATX PSU with a physical on/off switch, try to swap HP's original with it and share results. Personally, I gave up with Omen and bought Akitio Node which works flawlessly.

This post was modified 1 year ago

MBP 15" 2015, i7-4770, 16Gb 1600MHz, Iris Pro 5200 + Akitio Node, Sapphire Nitro+ RX580 8GB @TB2>TB3 Apple adapter & 2m cable.


ReplyQuote
kamil6x
(@kamil6x)
New Member
Joined: 1 year ago
 

Thank you Blushing Cheeks!  This gives me a clue that it's an HP Omen / TB2 problem.  I will get an Akitio and test.  Can you post what software if any you used outside normal OS X Mojave?

This post was modified 1 year ago

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote